aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-06-25 19:11:51 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2022-06-25 19:33:15 +0000
commit321f48066f52e9f667846cd87a4deba288199ee3 (patch)
tree04c56a89fe98d22b3c3165e9598e00e4810fc0f0 /databases
parent18153856d65da6a540ceba0eccdcf2eefee34de4 (diff)
downloadports-321f48066f52e9f667846cd87a4deba288199ee3.tar.gz
ports-321f48066f52e9f667846cd87a4deba288199ee3.zip
databases/pointcloud: Rework Makefile and remove libght dependency
Rework Makefile to follow Porters Handbook more closely Remove non needed variable Remove libght dependency, this was removed in 1.2.0 Reference: https://github.com/pgpointcloud/pointcloud/blob/v1.2.0/NEWS PR: 264184 Approved by: lbartoletti (maintainer timeout, 4+ weeks)
Diffstat (limited to 'databases')
-rw-r--r--databases/pointcloud/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/databases/pointcloud/Makefile b/databases/pointcloud/Makefile
index f924c0ef8be8..a59a349f49fc 100644
--- a/databases/pointcloud/Makefile
+++ b/databases/pointcloud/Makefile
@@ -1,31 +1,29 @@
# Created by: lbartoletti <lbartoletti@FreeBSD.org>
PORTNAME= pointcloud
-PORTVERSION= 1.2.2
DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.2
CATEGORIES= databases geography
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-
MAINTAINER= lbartoletti@FreeBSD.org
COMMENT= LIDAR types for PostgreSQL
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-LIB_DEPENDS= libght.so:devel/libght \
- liblazperf.so:archivers/lazperf
+LIB_DEPENDS= liblazperf.so:archivers/lazperf
USES= autoreconf compiler:c++0x gmake gnome pgsql
-WANT_PGSQL= server
-USE_GNOME= libxml2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-lazperf=${LOCALBASE}
-USE_LDCONFIG= yes
+WANT_PGSQL= server
USE_GITHUB= yes
GH_ACCOUNT= pgpointcloud
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+
+CONFIGURE_ARGS= --with-lazperf=${LOCALBASE}
post-install:
- ${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/lib/postgresql/pointcloud-${PORTVERSION:R}.so
+ ${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/lib/postgresql/pointcloud-${DISTVERSION:R}.so
.include <bsd.port.mk>