aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSean Chittenden <seanc@FreeBSD.org>2003-12-05 21:22:42 +0000
committerSean Chittenden <seanc@FreeBSD.org>2003-12-05 21:22:42 +0000
commit3581faeeac6b2c18fab57c228a4d436460a48e1d (patch)
tree18c1437b03079fba7bccd2c519114af0e743eff3 /databases
parent401b38542ecaaaa9face31706157bb06ee24508f (diff)
downloadports-3581faeeac6b2c18fab57c228a4d436460a48e1d.tar.gz
ports-3581faeeac6b2c18fab57c228a4d436460a48e1d.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql-client/Makefile4
-rw-r--r--databases/postgresql-devel-server/Makefile8
-rw-r--r--databases/postgresql-devel-server/files/patch-src:backend:utils:misc:postgresql.conf.sample24
-rw-r--r--databases/postgresql7/Makefile8
-rw-r--r--databases/postgresql7/files/patch-src:backend:utils:misc:postgresql.conf.sample24
-rw-r--r--databases/postgresql74-server/Makefile8
-rw-r--r--databases/postgresql74-server/files/patch-src:backend:utils:misc:postgresql.conf.sample24
-rw-r--r--databases/postgresql80-server/Makefile8
-rw-r--r--databases/postgresql80-server/files/patch-src:backend:utils:misc:postgresql.conf.sample24
-rw-r--r--databases/postgresql81-server/Makefile8
-rw-r--r--databases/postgresql81-server/files/patch-src:backend:utils:misc:postgresql.conf.sample24
-rw-r--r--databases/postgresql82-server/Makefile8
-rw-r--r--databases/postgresql82-server/files/patch-src:backend:utils:misc:postgresql.conf.sample24
-rw-r--r--databases/postgresql83-server/Makefile8
-rw-r--r--databases/postgresql83-server/files/patch-src:backend:utils:misc:postgresql.conf.sample24
-rw-r--r--databases/postgresql84-server/Makefile8
-rw-r--r--databases/postgresql84-server/files/patch-src:backend:utils:misc:postgresql.conf.sample24
-rw-r--r--databases/postgresql90-server/Makefile8
-rw-r--r--databases/postgresql90-server/files/patch-src:backend:utils:misc:postgresql.conf.sample24
-rw-r--r--databases/postgresql91-server/Makefile8
-rw-r--r--databases/postgresql91-server/files/patch-src:backend:utils:misc:postgresql.conf.sample24
-rw-r--r--databases/postgresql92-server/Makefile8
-rw-r--r--databases/postgresql92-server/files/patch-src:backend:utils:misc:postgresql.conf.sample24
23 files changed, 310 insertions, 46 deletions
diff --git a/databases/postgresql-client/Makefile b/databases/postgresql-client/Makefile
index a2b4b0fdc58e..8398149f40e6 100644
--- a/databases/postgresql-client/Makefile
+++ b/databases/postgresql-client/Makefile
@@ -5,9 +5,9 @@
# $FreeBSD$
#
-PORTNAME= postgresql7
+# The portname is set in MASTERDIR/Makefile
-MAINTAINER= ports@freebsd.org
+MAINTAINER= girgen@pingpong.net
COMMENT= The most advanced open-source database available anywhere - client only
WITHOUT_SERVER= yes
diff --git a/databases/postgresql-devel-server/Makefile b/databases/postgresql-devel-server/Makefile
index 9192a2f1d160..4f17a17f902b 100644
--- a/databases/postgresql-devel-server/Makefile
+++ b/databases/postgresql-devel-server/Makefile
@@ -74,11 +74,11 @@ CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
-CONFLICTS= postgresql-7*
+CONFLICTS= postgresql-7* postgresql-devel-*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
-CONFLICTS= postgresql-7*client
+CONFLICTS= postgresql-7*client postgreql-devel-*
PLIST_SUB+= SERVER=""
INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
@@ -86,12 +86,12 @@ MAKEFILE= GNUmakefile
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -178,7 +178,7 @@ pre-everything::
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONF})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @${ECHO} "and remake world."
@exit 1
.endif
diff --git a/databases/postgresql-devel-server/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql-devel-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
new file mode 100644
index 000000000000..b9842b0c94f6
--- /dev/null
+++ b/databases/postgresql-devel-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
@@ -0,0 +1,24 @@
+--- src/backend/utils/misc/postgresql.conf.sample~ Wed Oct 8 05:49:38 2003
++++ src/backend/utils/misc/postgresql.conf.sample Tue Nov 18 05:08:08 2003
+@@ -136,9 +136,9 @@
+
+ # - Syslog -
+
+-#syslog = 0 # range 0-2; 0=stdout; 1=both; 2=syslog
+-#syslog_facility = 'LOCAL0'
+-#syslog_ident = 'postgres'
++syslog = 2 # range 0-2; 0=stdout; 1=both; 2=syslog
++syslog_facility = 'LOCAL0'
++syslog_ident = 'postgres'
+
+ # - When to Log -
+
+@@ -162,7 +162,7 @@
+ # milliseconds. Zero prints all queries.
+ # Minus-one disables.
+
+-#silent_mode = false # DO NOT USE without Syslog!
++silent_mode = true # DO NOT USE without Syslog!
+
+ # - What to Log -
+
diff --git a/databases/postgresql7/Makefile b/databases/postgresql7/Makefile
index 9192a2f1d160..4f17a17f902b 100644
--- a/databases/postgresql7/Makefile
+++ b/databases/postgresql7/Makefile
@@ -74,11 +74,11 @@ CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
-CONFLICTS= postgresql-7*
+CONFLICTS= postgresql-7* postgresql-devel-*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
-CONFLICTS= postgresql-7*client
+CONFLICTS= postgresql-7*client postgreql-devel-*
PLIST_SUB+= SERVER=""
INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
@@ -86,12 +86,12 @@ MAKEFILE= GNUmakefile
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -178,7 +178,7 @@ pre-everything::
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONF})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @${ECHO} "and remake world."
@exit 1
.endif
diff --git a/databases/postgresql7/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql7/files/patch-src:backend:utils:misc:postgresql.conf.sample
new file mode 100644
index 000000000000..b9842b0c94f6
--- /dev/null
+++ b/databases/postgresql7/files/patch-src:backend:utils:misc:postgresql.conf.sample
@@ -0,0 +1,24 @@
+--- src/backend/utils/misc/postgresql.conf.sample~ Wed Oct 8 05:49:38 2003
++++ src/backend/utils/misc/postgresql.conf.sample Tue Nov 18 05:08:08 2003
+@@ -136,9 +136,9 @@
+
+ # - Syslog -
+
+-#syslog = 0 # range 0-2; 0=stdout; 1=both; 2=syslog
+-#syslog_facility = 'LOCAL0'
+-#syslog_ident = 'postgres'
++syslog = 2 # range 0-2; 0=stdout; 1=both; 2=syslog
++syslog_facility = 'LOCAL0'
++syslog_ident = 'postgres'
+
+ # - When to Log -
+
+@@ -162,7 +162,7 @@
+ # milliseconds. Zero prints all queries.
+ # Minus-one disables.
+
+-#silent_mode = false # DO NOT USE without Syslog!
++silent_mode = true # DO NOT USE without Syslog!
+
+ # - What to Log -
+
diff --git a/databases/postgresql74-server/Makefile b/databases/postgresql74-server/Makefile
index 9192a2f1d160..4f17a17f902b 100644
--- a/databases/postgresql74-server/Makefile
+++ b/databases/postgresql74-server/Makefile
@@ -74,11 +74,11 @@ CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
-CONFLICTS= postgresql-7*
+CONFLICTS= postgresql-7* postgresql-devel-*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
-CONFLICTS= postgresql-7*client
+CONFLICTS= postgresql-7*client postgreql-devel-*
PLIST_SUB+= SERVER=""
INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
@@ -86,12 +86,12 @@ MAKEFILE= GNUmakefile
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -178,7 +178,7 @@ pre-everything::
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONF})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @${ECHO} "and remake world."
@exit 1
.endif
diff --git a/databases/postgresql74-server/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql74-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
new file mode 100644
index 000000000000..b9842b0c94f6
--- /dev/null
+++ b/databases/postgresql74-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
@@ -0,0 +1,24 @@
+--- src/backend/utils/misc/postgresql.conf.sample~ Wed Oct 8 05:49:38 2003
++++ src/backend/utils/misc/postgresql.conf.sample Tue Nov 18 05:08:08 2003
+@@ -136,9 +136,9 @@
+
+ # - Syslog -
+
+-#syslog = 0 # range 0-2; 0=stdout; 1=both; 2=syslog
+-#syslog_facility = 'LOCAL0'
+-#syslog_ident = 'postgres'
++syslog = 2 # range 0-2; 0=stdout; 1=both; 2=syslog
++syslog_facility = 'LOCAL0'
++syslog_ident = 'postgres'
+
+ # - When to Log -
+
+@@ -162,7 +162,7 @@
+ # milliseconds. Zero prints all queries.
+ # Minus-one disables.
+
+-#silent_mode = false # DO NOT USE without Syslog!
++silent_mode = true # DO NOT USE without Syslog!
+
+ # - What to Log -
+
diff --git a/databases/postgresql80-server/Makefile b/databases/postgresql80-server/Makefile
index 9192a2f1d160..4f17a17f902b 100644
--- a/databases/postgresql80-server/Makefile
+++ b/databases/postgresql80-server/Makefile
@@ -74,11 +74,11 @@ CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
-CONFLICTS= postgresql-7*
+CONFLICTS= postgresql-7* postgresql-devel-*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
-CONFLICTS= postgresql-7*client
+CONFLICTS= postgresql-7*client postgreql-devel-*
PLIST_SUB+= SERVER=""
INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
@@ -86,12 +86,12 @@ MAKEFILE= GNUmakefile
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -178,7 +178,7 @@ pre-everything::
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONF})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @${ECHO} "and remake world."
@exit 1
.endif
diff --git a/databases/postgresql80-server/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql80-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
new file mode 100644
index 000000000000..b9842b0c94f6
--- /dev/null
+++ b/databases/postgresql80-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
@@ -0,0 +1,24 @@
+--- src/backend/utils/misc/postgresql.conf.sample~ Wed Oct 8 05:49:38 2003
++++ src/backend/utils/misc/postgresql.conf.sample Tue Nov 18 05:08:08 2003
+@@ -136,9 +136,9 @@
+
+ # - Syslog -
+
+-#syslog = 0 # range 0-2; 0=stdout; 1=both; 2=syslog
+-#syslog_facility = 'LOCAL0'
+-#syslog_ident = 'postgres'
++syslog = 2 # range 0-2; 0=stdout; 1=both; 2=syslog
++syslog_facility = 'LOCAL0'
++syslog_ident = 'postgres'
+
+ # - When to Log -
+
+@@ -162,7 +162,7 @@
+ # milliseconds. Zero prints all queries.
+ # Minus-one disables.
+
+-#silent_mode = false # DO NOT USE without Syslog!
++silent_mode = true # DO NOT USE without Syslog!
+
+ # - What to Log -
+
diff --git a/databases/postgresql81-server/Makefile b/databases/postgresql81-server/Makefile
index 9192a2f1d160..4f17a17f902b 100644
--- a/databases/postgresql81-server/Makefile
+++ b/databases/postgresql81-server/Makefile
@@ -74,11 +74,11 @@ CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
-CONFLICTS= postgresql-7*
+CONFLICTS= postgresql-7* postgresql-devel-*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
-CONFLICTS= postgresql-7*client
+CONFLICTS= postgresql-7*client postgreql-devel-*
PLIST_SUB+= SERVER=""
INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
@@ -86,12 +86,12 @@ MAKEFILE= GNUmakefile
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -178,7 +178,7 @@ pre-everything::
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONF})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @${ECHO} "and remake world."
@exit 1
.endif
diff --git a/databases/postgresql81-server/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql81-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
new file mode 100644
index 000000000000..b9842b0c94f6
--- /dev/null
+++ b/databases/postgresql81-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
@@ -0,0 +1,24 @@
+--- src/backend/utils/misc/postgresql.conf.sample~ Wed Oct 8 05:49:38 2003
++++ src/backend/utils/misc/postgresql.conf.sample Tue Nov 18 05:08:08 2003
+@@ -136,9 +136,9 @@
+
+ # - Syslog -
+
+-#syslog = 0 # range 0-2; 0=stdout; 1=both; 2=syslog
+-#syslog_facility = 'LOCAL0'
+-#syslog_ident = 'postgres'
++syslog = 2 # range 0-2; 0=stdout; 1=both; 2=syslog
++syslog_facility = 'LOCAL0'
++syslog_ident = 'postgres'
+
+ # - When to Log -
+
+@@ -162,7 +162,7 @@
+ # milliseconds. Zero prints all queries.
+ # Minus-one disables.
+
+-#silent_mode = false # DO NOT USE without Syslog!
++silent_mode = true # DO NOT USE without Syslog!
+
+ # - What to Log -
+
diff --git a/databases/postgresql82-server/Makefile b/databases/postgresql82-server/Makefile
index 9192a2f1d160..4f17a17f902b 100644
--- a/databases/postgresql82-server/Makefile
+++ b/databases/postgresql82-server/Makefile
@@ -74,11 +74,11 @@ CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
-CONFLICTS= postgresql-7*
+CONFLICTS= postgresql-7* postgresql-devel-*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
-CONFLICTS= postgresql-7*client
+CONFLICTS= postgresql-7*client postgreql-devel-*
PLIST_SUB+= SERVER=""
INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
@@ -86,12 +86,12 @@ MAKEFILE= GNUmakefile
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -178,7 +178,7 @@ pre-everything::
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONF})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @${ECHO} "and remake world."
@exit 1
.endif
diff --git a/databases/postgresql82-server/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql82-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
new file mode 100644
index 000000000000..b9842b0c94f6
--- /dev/null
+++ b/databases/postgresql82-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
@@ -0,0 +1,24 @@
+--- src/backend/utils/misc/postgresql.conf.sample~ Wed Oct 8 05:49:38 2003
++++ src/backend/utils/misc/postgresql.conf.sample Tue Nov 18 05:08:08 2003
+@@ -136,9 +136,9 @@
+
+ # - Syslog -
+
+-#syslog = 0 # range 0-2; 0=stdout; 1=both; 2=syslog
+-#syslog_facility = 'LOCAL0'
+-#syslog_ident = 'postgres'
++syslog = 2 # range 0-2; 0=stdout; 1=both; 2=syslog
++syslog_facility = 'LOCAL0'
++syslog_ident = 'postgres'
+
+ # - When to Log -
+
+@@ -162,7 +162,7 @@
+ # milliseconds. Zero prints all queries.
+ # Minus-one disables.
+
+-#silent_mode = false # DO NOT USE without Syslog!
++silent_mode = true # DO NOT USE without Syslog!
+
+ # - What to Log -
+
diff --git a/databases/postgresql83-server/Makefile b/databases/postgresql83-server/Makefile
index 9192a2f1d160..4f17a17f902b 100644
--- a/databases/postgresql83-server/Makefile
+++ b/databases/postgresql83-server/Makefile
@@ -74,11 +74,11 @@ CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
-CONFLICTS= postgresql-7*
+CONFLICTS= postgresql-7* postgresql-devel-*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
-CONFLICTS= postgresql-7*client
+CONFLICTS= postgresql-7*client postgreql-devel-*
PLIST_SUB+= SERVER=""
INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
@@ -86,12 +86,12 @@ MAKEFILE= GNUmakefile
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -178,7 +178,7 @@ pre-everything::
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONF})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @${ECHO} "and remake world."
@exit 1
.endif
diff --git a/databases/postgresql83-server/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql83-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
new file mode 100644
index 000000000000..b9842b0c94f6
--- /dev/null
+++ b/databases/postgresql83-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
@@ -0,0 +1,24 @@
+--- src/backend/utils/misc/postgresql.conf.sample~ Wed Oct 8 05:49:38 2003
++++ src/backend/utils/misc/postgresql.conf.sample Tue Nov 18 05:08:08 2003
+@@ -136,9 +136,9 @@
+
+ # - Syslog -
+
+-#syslog = 0 # range 0-2; 0=stdout; 1=both; 2=syslog
+-#syslog_facility = 'LOCAL0'
+-#syslog_ident = 'postgres'
++syslog = 2 # range 0-2; 0=stdout; 1=both; 2=syslog
++syslog_facility = 'LOCAL0'
++syslog_ident = 'postgres'
+
+ # - When to Log -
+
+@@ -162,7 +162,7 @@
+ # milliseconds. Zero prints all queries.
+ # Minus-one disables.
+
+-#silent_mode = false # DO NOT USE without Syslog!
++silent_mode = true # DO NOT USE without Syslog!
+
+ # - What to Log -
+
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index 9192a2f1d160..4f17a17f902b 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -74,11 +74,11 @@ CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
-CONFLICTS= postgresql-7*
+CONFLICTS= postgresql-7* postgresql-devel-*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
-CONFLICTS= postgresql-7*client
+CONFLICTS= postgresql-7*client postgreql-devel-*
PLIST_SUB+= SERVER=""
INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
@@ -86,12 +86,12 @@ MAKEFILE= GNUmakefile
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -178,7 +178,7 @@ pre-everything::
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONF})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @${ECHO} "and remake world."
@exit 1
.endif
diff --git a/databases/postgresql84-server/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql84-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
new file mode 100644
index 000000000000..b9842b0c94f6
--- /dev/null
+++ b/databases/postgresql84-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
@@ -0,0 +1,24 @@
+--- src/backend/utils/misc/postgresql.conf.sample~ Wed Oct 8 05:49:38 2003
++++ src/backend/utils/misc/postgresql.conf.sample Tue Nov 18 05:08:08 2003
+@@ -136,9 +136,9 @@
+
+ # - Syslog -
+
+-#syslog = 0 # range 0-2; 0=stdout; 1=both; 2=syslog
+-#syslog_facility = 'LOCAL0'
+-#syslog_ident = 'postgres'
++syslog = 2 # range 0-2; 0=stdout; 1=both; 2=syslog
++syslog_facility = 'LOCAL0'
++syslog_ident = 'postgres'
+
+ # - When to Log -
+
+@@ -162,7 +162,7 @@
+ # milliseconds. Zero prints all queries.
+ # Minus-one disables.
+
+-#silent_mode = false # DO NOT USE without Syslog!
++silent_mode = true # DO NOT USE without Syslog!
+
+ # - What to Log -
+
diff --git a/databases/postgresql90-server/Makefile b/databases/postgresql90-server/Makefile
index 9192a2f1d160..4f17a17f902b 100644
--- a/databases/postgresql90-server/Makefile
+++ b/databases/postgresql90-server/Makefile
@@ -74,11 +74,11 @@ CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
-CONFLICTS= postgresql-7*
+CONFLICTS= postgresql-7* postgresql-devel-*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
-CONFLICTS= postgresql-7*client
+CONFLICTS= postgresql-7*client postgreql-devel-*
PLIST_SUB+= SERVER=""
INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
@@ -86,12 +86,12 @@ MAKEFILE= GNUmakefile
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -178,7 +178,7 @@ pre-everything::
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONF})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @${ECHO} "and remake world."
@exit 1
.endif
diff --git a/databases/postgresql90-server/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql90-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
new file mode 100644
index 000000000000..b9842b0c94f6
--- /dev/null
+++ b/databases/postgresql90-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
@@ -0,0 +1,24 @@
+--- src/backend/utils/misc/postgresql.conf.sample~ Wed Oct 8 05:49:38 2003
++++ src/backend/utils/misc/postgresql.conf.sample Tue Nov 18 05:08:08 2003
+@@ -136,9 +136,9 @@
+
+ # - Syslog -
+
+-#syslog = 0 # range 0-2; 0=stdout; 1=both; 2=syslog
+-#syslog_facility = 'LOCAL0'
+-#syslog_ident = 'postgres'
++syslog = 2 # range 0-2; 0=stdout; 1=both; 2=syslog
++syslog_facility = 'LOCAL0'
++syslog_ident = 'postgres'
+
+ # - When to Log -
+
+@@ -162,7 +162,7 @@
+ # milliseconds. Zero prints all queries.
+ # Minus-one disables.
+
+-#silent_mode = false # DO NOT USE without Syslog!
++silent_mode = true # DO NOT USE without Syslog!
+
+ # - What to Log -
+
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index 9192a2f1d160..4f17a17f902b 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -74,11 +74,11 @@ CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
-CONFLICTS= postgresql-7*
+CONFLICTS= postgresql-7* postgresql-devel-*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
-CONFLICTS= postgresql-7*client
+CONFLICTS= postgresql-7*client postgreql-devel-*
PLIST_SUB+= SERVER=""
INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
@@ -86,12 +86,12 @@ MAKEFILE= GNUmakefile
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -178,7 +178,7 @@ pre-everything::
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONF})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @${ECHO} "and remake world."
@exit 1
.endif
diff --git a/databases/postgresql91-server/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql91-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
new file mode 100644
index 000000000000..b9842b0c94f6
--- /dev/null
+++ b/databases/postgresql91-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
@@ -0,0 +1,24 @@
+--- src/backend/utils/misc/postgresql.conf.sample~ Wed Oct 8 05:49:38 2003
++++ src/backend/utils/misc/postgresql.conf.sample Tue Nov 18 05:08:08 2003
+@@ -136,9 +136,9 @@
+
+ # - Syslog -
+
+-#syslog = 0 # range 0-2; 0=stdout; 1=both; 2=syslog
+-#syslog_facility = 'LOCAL0'
+-#syslog_ident = 'postgres'
++syslog = 2 # range 0-2; 0=stdout; 1=both; 2=syslog
++syslog_facility = 'LOCAL0'
++syslog_ident = 'postgres'
+
+ # - When to Log -
+
+@@ -162,7 +162,7 @@
+ # milliseconds. Zero prints all queries.
+ # Minus-one disables.
+
+-#silent_mode = false # DO NOT USE without Syslog!
++silent_mode = true # DO NOT USE without Syslog!
+
+ # - What to Log -
+
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 9192a2f1d160..4f17a17f902b 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -74,11 +74,11 @@ CONFIGURE_ARGS+= "--with-openssl=${OPENSSLBASE}"
PLIST_SUB+= SERVER="@comment "
PKGNAMESUFFIX= -client
PKGMSG= ""
-CONFLICTS= postgresql-7*
+CONFLICTS= postgresql-7* postgresql-devel-*
.else
PKGMESSAGE= ${FILESDIR}/pkg-message.server
PKGMSG= ${PKGMESSAGE}
-CONFLICTS= postgresql-7*client
+CONFLICTS= postgresql-7*client postgreql-devel-*
PLIST_SUB+= SERVER=""
INSTALL_TARGET+= install-all-headers
MAKEFILE= GNUmakefile
@@ -86,12 +86,12 @@ MAKEFILE= GNUmakefile
.if defined(WITH_MIT_KRB5)
KRB5CONF= ${LOCALBASE}/bin/krb5-config
+LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
.if defined(WITH_HEIMDAL_KRB5)
KRB5CONF= /usr/bin/krb5-config
-LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
WITH_KRB5= yes
.endif
@@ -178,7 +178,7 @@ pre-everything::
.if defined(WITH_HEIMDAL_KRB5) && !exists(${KRB5CONF})
@${ECHO} "Unable to find krb5-config in the base system. Undefine"
@${ECHO} "WITH_HEIMDAL_KRB5 or add MAKE_KERBEROS5=yes to /etc/make.conf"
- @${ECHO} "and remake world (or undefine the WITH_HEIMDAL_KRB5 tunable)."
+ @${ECHO} "and remake world."
@exit 1
.endif
diff --git a/databases/postgresql92-server/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql92-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
new file mode 100644
index 000000000000..b9842b0c94f6
--- /dev/null
+++ b/databases/postgresql92-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
@@ -0,0 +1,24 @@
+--- src/backend/utils/misc/postgresql.conf.sample~ Wed Oct 8 05:49:38 2003
++++ src/backend/utils/misc/postgresql.conf.sample Tue Nov 18 05:08:08 2003
+@@ -136,9 +136,9 @@
+
+ # - Syslog -
+
+-#syslog = 0 # range 0-2; 0=stdout; 1=both; 2=syslog
+-#syslog_facility = 'LOCAL0'
+-#syslog_ident = 'postgres'
++syslog = 2 # range 0-2; 0=stdout; 1=both; 2=syslog
++syslog_facility = 'LOCAL0'
++syslog_ident = 'postgres'
+
+ # - When to Log -
+
+@@ -162,7 +162,7 @@
+ # milliseconds. Zero prints all queries.
+ # Minus-one disables.
+
+-#silent_mode = false # DO NOT USE without Syslog!
++silent_mode = true # DO NOT USE without Syslog!
+
+ # - What to Log -
+