aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-05 16:44:26 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-05 16:44:26 +0000
commit35902762f20c26f34d1c851b8fb42d0bfcf603dc (patch)
treec5a8d3cd613954656ab9326d19c236f08232ac77 /databases
parent94a144531f8eb2d2c0070fc0a076f401071bb3d6 (diff)
downloadports-35902762f20c26f34d1c851b8fb42d0bfcf603dc.tar.gz
ports-35902762f20c26f34d1c851b8fb42d0bfcf603dc.zip
Convert to use libevent2
Notes
Notes: svn path=/head/; revision=347121
Diffstat (limited to 'databases')
-rw-r--r--databases/sharedance/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/databases/sharedance/Makefile b/databases/sharedance/Makefile
index ef3f43e328af..3ccee5f36f40 100644
--- a/databases/sharedance/Makefile
+++ b/databases/sharedance/Makefile
@@ -3,22 +3,27 @@
PORTNAME= sharedance
PORTVERSION= 0.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases
MASTER_SITES= http://download.pureftpd.org/pub/sharedance/
MAINTAINER= gslin@gslin.org
-COMMENT= A daemon to centralize keys and associated data
+COMMENT= Daemon to centralize keys and associated data
-LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent-2.0.so:${PORTSDIR}/devel/libevent2
CONFIGURE_ARGS= --with-largefile
GNU_CONFIGURE= yes
USE_BZIP2= yes
+CFLAGS+= -I${LOCALBASE}/include/event2/compat \
+ -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib/event2
+
+post-patch:
+ @${REINPLACE_CMD} -e "s/-levent/-levent-2.0/g" ${WRKSRC}/configure
-NO_STAGE= yes
post-install:
- ${MKDIR} ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/php/*.php ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/php/*.php ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>