aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-03-23 10:49:23 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-03-23 10:49:23 +0000
commit3f768813bc58fb0efdfc990c85f5a397a48733e0 (patch)
tree8a42b78124bcc4846b7b88f970e90783fc89c1b5 /databases
parent14ef28458dccc7f1651101c73aa6cdfa8ab37955 (diff)
downloadports-3f768813bc58fb0efdfc990c85f5a397a48733e0.tar.gz
ports-3f768813bc58fb0efdfc990c85f5a397a48733e0.zip
databases/mysql57-server: don't use LLD for linking on powerpc
LLD currently fails: ld: error: relocation refers to a discarded section: .rodata._ZN5boost6detail8function15functor_managerINS_9algorithm6detail13token_finderFINS4_10is_any_ofFIcEEEEE7managerERKNS1_15function_bufferERSA_NS1_30functor_manager_operation_typeEN4mpl_5bool_ILb0EEE >>> defined in ../../archive_output_directory/libmysqlpump_lib.a(object_filter.cc.o) >>> referenced by object_filter.cc >>> object_filter.cc.o:(.got2+0x108) in archive ../../archive_output_directory/libmysqlpump_lib.a ld: error: relocation refers to a discarded section: .rodata._ZN5boost6detail8function15functor_managerINS_9algorithm6detail13token_finderFINS4_10is_any_ofFIcEEEEE7managerERKNS1_15function_bufferERSA_NS1_30functor_manager_operation_typeEN4mpl_5bool_ILb0EEE >>> defined in ../../archive_output_directory/libmysqlpump_lib.a(sql_formatter.cc.o) >>> referenced by sql_formatter.cc >>> sql_formatter.cc.o:(.got2+0x130) in archive ../../archive_output_directory/libmysqlpump_lib.a ld: error: relocation refers to a discarded section: .rodata._ZN5boost6detail8function15functor_managerINS_9algorithm6detail13token_finderFINS4_10is_any_ofFIcEEEEE7managerERKNS1_15function_bufferERSA_NS1_30functor_manager_operation_typeEN4mpl_5bool_ILb0EEE >>> defined in ../../archive_output_directory/libmysqlpump_lib.a(table.cc.o) >>> referenced by table.cc >>> table.cc.o:(.got2+0x50) in archive ../../archive_output_directory/libmysqlpump_lib.a clang++: error: linker command failed with exit code 1 (use -v to see invocation)
Notes
Notes: svn path=/head/; revision=569017
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql57-server/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/databases/mysql57-server/Makefile b/databases/mysql57-server/Makefile
index 1f2bdd7e5847..bebdfc8692ba 100644
--- a/databases/mysql57-server/Makefile
+++ b/databases/mysql57-server/Makefile
@@ -174,6 +174,10 @@ CC= ${LOCALBASE}/bin/clang${LLVM_DEFAULT}
CXX= ${LOCALBASE}/bin/clang++${LLVM_DEFAULT}
.endif
+.if ${ARCH} == powerpc
+LLD_UNSAFE= yes
+.endif
+
post-extract:
@${RM} -rv ${WRKSRC}/sql/sql_hints.yy.cc ${WRKSRC}/sql/sql_hints.yy.h