aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-08-14 16:26:10 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-08-14 16:26:10 +0000
commit44e1cdb9b697d8a56275b89d910b751fa98743a1 (patch)
tree990dd730e0c4306cf4633df92b397687f8228d6d /databases
parent42e96c2210b73a78842ba1a92dcee41d3aedf4b3 (diff)
downloadports-44e1cdb9b697d8a56275b89d910b751fa98743a1.tar.gz
ports-44e1cdb9b697d8a56275b89d910b751fa98743a1.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/gnomedb2/Makefile2
-rw-r--r--databases/libgda2/Makefile2
-rw-r--r--databases/libgda3/Makefile2
-rw-r--r--databases/libgnomedb/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/databases/gnomedb2/Makefile b/databases/gnomedb2/Makefile
index bf8d1dc59577..d4603dc0bf11 100644
--- a/databases/gnomedb2/Makefile
+++ b/databases/gnomedb2/Makefile
@@ -31,7 +31,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/databases/libgda2/Makefile b/databases/libgda2/Makefile
index 73e600b2ff6c..601eefda5ad2 100644
--- a/databases/libgda2/Makefile
+++ b/databases/libgda2/Makefile
@@ -57,7 +57,7 @@ pre-extract:
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/databases/libgda3/Makefile b/databases/libgda3/Makefile
index 73e600b2ff6c..601eefda5ad2 100644
--- a/databases/libgda3/Makefile
+++ b/databases/libgda3/Makefile
@@ -57,7 +57,7 @@ pre-extract:
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/databases/libgnomedb/Makefile b/databases/libgnomedb/Makefile
index d2ff6069be73..66319694bf98 100644
--- a/databases/libgnomedb/Makefile
+++ b/databases/libgnomedb/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|-pthread|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
.include <bsd.port.mk>