aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-06-30 23:07:29 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-06-30 23:07:29 +0000
commit562eeefecf551ed9701e476f2a3cddb528fa4575 (patch)
treeaa6154c5b830f054b9d2886f6d5de6b6d9a566d0 /databases
parent8f9204e1f4ce60b6bf361cdf34e76729c982251f (diff)
Fixes build with readline from ports
Notes
Notes: svn path=/head/; revision=359941
Diffstat (limited to 'databases')
-rw-r--r--databases/postgresql84-client/Makefile1
-rw-r--r--databases/postgresql90-client/Makefile1
-rw-r--r--databases/postgresql91-client/Makefile1
-rw-r--r--databases/postgresql92-client/Makefile1
-rw-r--r--databases/postgresql93-client/Makefile2
-rw-r--r--databases/postgresql94-client/Makefile2
6 files changed, 6 insertions, 2 deletions
diff --git a/databases/postgresql84-client/Makefile b/databases/postgresql84-client/Makefile
index aa9595d43d8d..45474043cf33 100644
--- a/databases/postgresql84-client/Makefile
+++ b/databases/postgresql84-client/Makefile
@@ -15,5 +15,6 @@ BUILD_DIRS= config src/include src/interfaces src/port \
CLIENT_ONLY= yes
COMPONENT= -client
USE_LDCONFIG= yes
+USES= readline
.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql90-client/Makefile b/databases/postgresql90-client/Makefile
index c1116b4d9563..4b04da60f60a 100644
--- a/databases/postgresql90-client/Makefile
+++ b/databases/postgresql90-client/Makefile
@@ -16,5 +16,6 @@ INSTALL_DIRS= ${BUILD_DIRS}
CLIENT_ONLY= yes
COMPONENT= -client
USE_LDCONFIG= yes
+USES= readline
.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql91-client/Makefile b/databases/postgresql91-client/Makefile
index fc93896be7eb..7eec899450a0 100644
--- a/databases/postgresql91-client/Makefile
+++ b/databases/postgresql91-client/Makefile
@@ -16,5 +16,6 @@ INSTALL_DIRS= ${BUILD_DIRS}
CLIENT_ONLY= yes
COMPONENT= -client
USE_LDCONFIG= yes
+USES= readline
.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql92-client/Makefile b/databases/postgresql92-client/Makefile
index 8c9cceafc0a0..e3c91bf4f0df 100644
--- a/databases/postgresql92-client/Makefile
+++ b/databases/postgresql92-client/Makefile
@@ -16,5 +16,6 @@ INSTALL_DIRS= ${BUILD_DIRS}
CLIENT_ONLY= yes
COMPONENT= -client
USE_LDCONFIG= yes
+USES= readline
.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql93-client/Makefile b/databases/postgresql93-client/Makefile
index eefdc8d34c33..c87d5cd80b32 100644
--- a/databases/postgresql93-client/Makefile
+++ b/databases/postgresql93-client/Makefile
@@ -17,6 +17,6 @@ INSTALL_DIRS= ${BUILD_DIRS}
CLIENT_ONLY= yes
COMPONENT= -client
USE_LDCONFIG= yes
-USES= pkgconfig
+USES= pkgconfig readline
.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql94-client/Makefile b/databases/postgresql94-client/Makefile
index 8e3a54034d9f..a048dd978678 100644
--- a/databases/postgresql94-client/Makefile
+++ b/databases/postgresql94-client/Makefile
@@ -17,6 +17,6 @@ INSTALL_DIRS= ${BUILD_DIRS}
CLIENT_ONLY= yes
COMPONENT= -client
USE_LDCONFIG= yes
-USES= pkgconfig
+USES= pkgconfig readline
.include "${MASTERDIR}/Makefile"