aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2010-10-09 14:43:57 +0000
committerMatthias Andree <mandree@FreeBSD.org>2010-10-09 14:43:57 +0000
commit6f942caec74f1d629f0b90ed72218dc3f775cf38 (patch)
tree1cb0c104804bac56ed1f994a46a850fc03a52862 /databases
parent18794da1c67833b425cb32391e01611725497d0d (diff)
downloadports-6f942caec74f1d629f0b90ed72218dc3f775cf38.tar.gz
ports-6f942caec74f1d629f0b90ed72218dc3f775cf38.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/db43/Makefile4
-rw-r--r--databases/db43/distinfo3
-rw-r--r--databases/db43/files/patch-upstream.4.3.29.124
3 files changed, 24 insertions, 7 deletions
diff --git a/databases/db43/Makefile b/databases/db43/Makefile
index a36dcd8a23e9..d0ce31f16987 100644
--- a/databases/db43/Makefile
+++ b/databases/db43/Makefile
@@ -15,10 +15,6 @@ MASTER_SITES= http://download-west.oracle.com/berkeley-db/ \
DISTNAME= db-${PORTVERSION}
DIST_SUBDIR= bdb
-PATCH_SITES= http://www.oracle.com/technology/products/berkeley-db/db/update/${PORTVERSION}/
-PATCHFILES= patch.${PORTVERSION}.1
-PATCH_DIST_STRIP= -d ..
-
MAINTAINER= mandree@FreeBSD.org
COMMENT= The Berkeley DB package, revision 4.3
diff --git a/databases/db43/distinfo b/databases/db43/distinfo
index ce72aa870846..460bec77e307 100644
--- a/databases/db43/distinfo
+++ b/databases/db43/distinfo
@@ -1,6 +1,3 @@
MD5 (bdb/db-4.3.29.tar.gz) = 200b9f5d74175875fcb3ee54adbf0007
SHA256 (bdb/db-4.3.29.tar.gz) = a1fa714482f25a67a19490303a0164326ac63bd7653ae3f4664c2536b14f3337
SIZE (bdb/db-4.3.29.tar.gz) = 5942547
-MD5 (bdb/patch.4.3.29.1) = 947f07dd8fae5001feedb2deded40ad5
-SHA256 (bdb/patch.4.3.29.1) = 6fbda9c0554cfe3d281161b288f779e7cf2c814f311c69e1c6309b6f97d75931
-SIZE (bdb/patch.4.3.29.1) = 835
diff --git a/databases/db43/files/patch-upstream.4.3.29.1 b/databases/db43/files/patch-upstream.4.3.29.1
new file mode 100644
index 000000000000..2bec8e0200bb
--- /dev/null
+++ b/databases/db43/files/patch-upstream.4.3.29.1
@@ -0,0 +1,24 @@
+*** ../mp/mp_fget.c.orig 2006-05-30 20:44:11.000000000 -0700
+--- ../mp/mp_fget.c 2006-05-30 20:44:22.000000000 -0700
+***************
+*** 577,584 ****
+ */
+ if (state != SECOND_MISS && bhp->ref == 1) {
+ bhp->priority = UINT32_MAX;
+! SH_TAILQ_REMOVE(&hp->hash_bucket, bhp, hq, __bh);
+! SH_TAILQ_INSERT_TAIL(&hp->hash_bucket, bhp, hq);
+ hp->hash_priority =
+ SH_TAILQ_FIRST(&hp->hash_bucket, __bh)->priority;
+ }
+--- 577,587 ----
+ */
+ if (state != SECOND_MISS && bhp->ref == 1) {
+ bhp->priority = UINT32_MAX;
+! if (SH_TAILQ_FIRST(&hp->hash_bucket, __bh) !=
+! SH_TAILQ_LAST(&hp->hash_bucket, hq, __bh)) {
+! SH_TAILQ_REMOVE(&hp->hash_bucket, bhp, hq, __bh);
+! SH_TAILQ_INSERT_TAIL(&hp->hash_bucket, bhp, hq);
+! }
+ hp->hash_priority =
+ SH_TAILQ_FIRST(&hp->hash_bucket, __bh)->priority;
+ }