aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-29 20:45:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-29 20:45:26 +0000
commit7314254d76267820238a3893861c914cfcbeb5ea (patch)
tree9cdb997034078f582cf7ae26500d1592eefd513a /databases
parent7887c65e94ca35ebeff0a0bca6079232392ca34f (diff)
PEAR::DB_Sqlite_Tools is an object oriented interface to effectively
manage and backup Sqlite databases.It extends the existing functionality by providing a comprehensive solution for database backup, live replication, export in XML format, performance optmization and other functionalities like the insertion and retrieval of encrypted data from an Sqlite database without any external extension. WWW: http://pear.php.net/package/DB_Sqlite_Tools/
Notes
Notes: svn path=/head/; revision=191144
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pear-DB_Sqlite_Tools/Makefile25
-rw-r--r--databases/pear-DB_Sqlite_Tools/distinfo3
-rw-r--r--databases/pear-DB_Sqlite_Tools/pkg-descr8
4 files changed, 37 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 7037d4416d12..9d3498d9871d 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -315,6 +315,7 @@
SUBDIR += pear-DB_DataObject_FormBuilder
SUBDIR += pear-DB_Pager
SUBDIR += pear-DB_QueryTool
+ SUBDIR += pear-DB_Sqlite_Tools
SUBDIR += pear-DB_Table
SUBDIR += pear-DB_ldap
SUBDIR += pear-DBA
diff --git a/databases/pear-DB_Sqlite_Tools/Makefile b/databases/pear-DB_Sqlite_Tools/Makefile
new file mode 100644
index 000000000000..33caeedc5a2c
--- /dev/null
+++ b/databases/pear-DB_Sqlite_Tools/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: pear-DB_Sqlite_Tools
+# Date created: 29 April 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DB_Sqlite_Tools
+PORTVERSION= 0.1.6
+CATEGORIES= databases www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= an object oriented interface to backup Sqlite databases
+
+BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \
+ ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= DB
+FILES= DB/Sqlite/Tools.php DB/Sqlite/Tools/ArcFour.php DB/Sqlite/Tools/DBC.php \
+ DB/Sqlite/Tools/XMLParser.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/databases/pear-DB_Sqlite_Tools/distinfo b/databases/pear-DB_Sqlite_Tools/distinfo
new file mode 100644
index 000000000000..f89c85b4eb36
--- /dev/null
+++ b/databases/pear-DB_Sqlite_Tools/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/DB_Sqlite_Tools-0.1.6.tgz) = 8204a8d346fe5aa52fb57345ac0e1069
+SHA256 (PEAR/DB_Sqlite_Tools-0.1.6.tgz) = d57f42b02a9c9217437dac0b5fd59cb8129936d972b35069dcc47cead1ca49de
+SIZE (PEAR/DB_Sqlite_Tools-0.1.6.tgz) = 17012
diff --git a/databases/pear-DB_Sqlite_Tools/pkg-descr b/databases/pear-DB_Sqlite_Tools/pkg-descr
new file mode 100644
index 000000000000..5fbf1058885b
--- /dev/null
+++ b/databases/pear-DB_Sqlite_Tools/pkg-descr
@@ -0,0 +1,8 @@
+PEAR::DB_Sqlite_Tools is an object oriented interface to effectively
+manage and backup Sqlite databases.It extends the existing functionality
+by providing a comprehensive solution for database backup, live replication,
+export in XML format, performance optmization and other functionalities like
+the insertion and retrieval of encrypted data from an Sqlite database without
+any external extension.
+
+WWW: http://pear.php.net/package/DB_Sqlite_Tools/