aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2015-04-26 12:33:09 +0000
committerAlex Dupre <ale@FreeBSD.org>2015-04-26 12:33:09 +0000
commit7f5193f66b0af0f4a41b4a33f50f5def888f2048 (patch)
tree0011c406a68bee1b12bcc57ba4285e2f89ec369c /databases
parent072f4f6c980db8d9619bb55c0d513b27d938b430 (diff)
downloadports-7f5193f66b0af0f4a41b4a33f50f5def888f2048.tar.gz
ports-7f5193f66b0af0f4a41b4a33f50f5def888f2048.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/php56-odbc/files/patch-config.m458
-rw-r--r--databases/php56-pdo_sqlite/Makefile1
-rw-r--r--databases/php56-sqlite3/Makefile1
3 files changed, 29 insertions, 31 deletions
diff --git a/databases/php56-odbc/files/patch-config.m4 b/databases/php56-odbc/files/patch-config.m4
index 6d3d81b34ade..742efcb7e881 100644
--- a/databases/php56-odbc/files/patch-config.m4
+++ b/databases/php56-odbc/files/patch-config.m4
@@ -1,5 +1,5 @@
---- config.m4.orig 2015-03-19 00:19:30.000000000 +0000
-+++ config.m4 2015-04-01 08:21:21.242902661 +0000
+--- config.m4.orig 2015-04-15 18:05:57.000000000 +0000
++++ config.m4 2015-04-26 12:08:54.914235064 +0000
@@ -100,13 +100,17 @@
dnl configure options
dnl
@@ -17,113 +17,113 @@
-[ --with-adabas[=DIR] Include Adabas D support [/usr/local]])
+[ --with-adabas[=DIR] Include Adabas D support [/usr/local]], no, no)
+ AC_MSG_CHECKING([for Adabas support])
if test "$PHP_ADABAS" != "no"; then
- AC_MSG_CHECKING([for Adabas support])
-@@ -133,7 +137,7 @@
+@@ -135,7 +139,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(sapdb,,
-[ --with-sapdb[=DIR] Include SAP DB support [/usr/local]])
+[ --with-sapdb[=DIR] Include SAP DB support [/usr/local]], no, no)
+ AC_MSG_CHECKING([for SAP DB support])
if test "$PHP_SAPDB" != "no"; then
- AC_MSG_CHECKING([for SAP DB support])
-@@ -151,7 +155,7 @@
+@@ -155,7 +159,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(solid,,
-[ --with-solid[=DIR] Include Solid support [/usr/local/solid]])
+[ --with-solid[=DIR] Include Solid support [/usr/local/solid]], no, no)
+ AC_MSG_CHECKING(for Solid support)
if test "$PHP_SOLID" != "no"; then
- AC_MSG_CHECKING(for Solid support)
-@@ -176,7 +180,7 @@
+@@ -182,7 +186,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(ibm-db2,,
-[ --with-ibm-db2[=DIR] Include IBM DB2 support [/home/db2inst1/sqllib]])
+[ --with-ibm-db2[=DIR] Include IBM DB2 support [/home/db2inst1/sqllib]], no, no)
+ AC_MSG_CHECKING(for IBM DB2 support)
if test "$PHP_IBM_DB2" != "no"; then
- AC_MSG_CHECKING(for IBM DB2 support)
-@@ -213,7 +217,7 @@
+@@ -221,7 +225,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(ODBCRouter,,
-[ --with-ODBCRouter[=DIR] Include ODBCRouter.com support [/usr]])
+[ --with-ODBCRouter[=DIR] Include ODBCRouter.com support [/usr]], no, no)
+ AC_MSG_CHECKING(for ODBCRouter.com support)
if test "$PHP_ODBCROUTER" != "no"; then
- AC_MSG_CHECKING(for ODBCRouter.com support)
-@@ -234,7 +238,7 @@
+@@ -244,7 +248,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(empress,,
[ --with-empress[=DIR] Include Empress support [\$EMPRESSPATH]
- (Empress Version >= 8.60 required)])
+ (Empress Version >= 8.60 required)], no, no)
+ AC_MSG_CHECKING(for Empress support)
if test "$PHP_EMPRESS" != "no"; then
- AC_MSG_CHECKING(for Empress support)
-@@ -258,7 +262,7 @@
+@@ -270,7 +274,7 @@
PHP_ARG_WITH(empress-bcs,,
[ --with-empress-bcs[=DIR]
Include Empress Local Access support [\$EMPRESSPATH]
- (Empress Version >= 8.60 required)])
+ (Empress Version >= 8.60 required)], no, no)
+ AC_MSG_CHECKING(for Empress local access support)
if test "$PHP_EMPRESS_BCS" != "no"; then
- AC_MSG_CHECKING(for Empress local access support)
-@@ -296,7 +300,7 @@
+@@ -310,7 +314,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(birdstep,,
-[ --with-birdstep[=DIR] Include Birdstep support [/usr/local/birdstep]])
+[ --with-birdstep[=DIR] Include Birdstep support [/usr/local/birdstep]], no, no)
+ AC_MSG_CHECKING(for Birdstep support)
if test "$PHP_BIRDSTEP" != "no"; then
- AC_MSG_CHECKING(for Birdstep support)
-@@ -350,7 +354,7 @@
+@@ -366,7 +370,7 @@
running this configure script:
CPPFLAGS=\"-DODBC_QNX -DSQLANY_BUG\"
LDFLAGS=-lunix
- CUSTOM_ODBC_LIBS=\"-ldblib -lodbc\"])
+ CUSTOM_ODBC_LIBS=\"-ldblib -lodbc\"], no, no)
+ AC_MSG_CHECKING(for a custom ODBC support)
if test "$PHP_CUSTOM_ODBC" != "no"; then
- AC_MSG_CHECKING(for a custom ODBC support)
-@@ -370,7 +374,7 @@
+@@ -388,7 +392,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(iodbc,,
--[ --with-iodbc[=DIR] Include iODBC support])
-+[ --with-iodbc[=DIR] Include iODBC support], no, no)
+-[ --with-iodbc[=DIR] Include iODBC support [/usr/local]])
++[ --with-iodbc[=DIR] Include iODBC support [/usr/local]], no, no)
+ AC_MSG_CHECKING(for iODBC support)
if test "$PHP_IODBC" != "no"; then
- AC_MSG_CHECKING(for iODBC support)
-@@ -406,7 +410,7 @@
+@@ -426,7 +430,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(esoob,,
-[ --with-esoob[=DIR] Include Easysoft OOB support [/usr/local/easysoft/oob/client]])
+[ --with-esoob[=DIR] Include Easysoft OOB support [/usr/local/easysoft/oob/client]], no, no)
+ AC_MSG_CHECKING(for Easysoft ODBC-ODBC Bridge support)
if test "$PHP_ESOOB" != "no"; then
- AC_MSG_CHECKING(for Easysoft ODBC-ODBC Bridge support)
-@@ -426,7 +430,7 @@
+@@ -448,7 +452,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(unixODBC,,
-[ --with-unixODBC[=DIR] Include unixODBC support [/usr/local]])
+[ --with-unixODBC[=DIR] Include unixODBC support [/usr/local]], no, no)
+ AC_MSG_CHECKING(for unixODBC support)
if test "$PHP_UNIXODBC" != "no"; then
- AC_MSG_CHECKING(for unixODBC support)
-@@ -447,7 +451,7 @@
+@@ -471,7 +475,7 @@
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(dbmaker,,
-[ --with-dbmaker[=DIR] Include DBMaker support])
+[ --with-dbmaker[=DIR] Include DBMaker support], no, no)
+ AC_MSG_CHECKING(for DBMaker support)
if test "$PHP_DBMAKER" != "no"; then
- AC_MSG_CHECKING(for DBMaker support)
diff --git a/databases/php56-pdo_sqlite/Makefile b/databases/php56-pdo_sqlite/Makefile
index cf6f3cc9e4c8..636387699694 100644
--- a/databases/php56-pdo_sqlite/Makefile
+++ b/databases/php56-pdo_sqlite/Makefile
@@ -1,7 +1,6 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= databases
MASTERDIR= ${.CURDIR}/../../lang/php56
diff --git a/databases/php56-sqlite3/Makefile b/databases/php56-sqlite3/Makefile
index 00b59a490f0d..f1db0136fe5c 100644
--- a/databases/php56-sqlite3/Makefile
+++ b/databases/php56-sqlite3/Makefile
@@ -1,7 +1,6 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= databases
MASTERDIR= ${.CURDIR}/../../lang/php56