aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2019-05-28 20:02:03 +0000
committerMark Felder <feld@FreeBSD.org>2019-05-28 20:02:03 +0000
commit844674b90d7032b5570b9eda80dcb5c7cfc0148c (patch)
treebf4787218e6ed5ee1963847f2e45e4f521dfd880 /databases
parent5474f744a3b835ee3774b2d9a6d1756ed17df29b (diff)
downloadports-844674b90d7032b5570b9eda80dcb5c7cfc0148c.tar.gz
ports-844674b90d7032b5570b9eda80dcb5c7cfc0148c.zip
The rum module provides access method to work with RUM index. It is
based on the GIN access methods code. WWW: https://github.com/postgrespro/rum
Notes
Notes: svn path=/head/; revision=502910
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/postgresql-rum/Makefile28
-rw-r--r--databases/postgresql-rum/distinfo3
-rw-r--r--databases/postgresql-rum/pkg-descr4
-rw-r--r--databases/postgresql-rum/pkg-plist9
5 files changed, 45 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 6726fe3df0c4..44e640449d08 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -682,6 +682,7 @@
SUBDIR += postgresql-prefix
SUBDIR += postgresql-relay
SUBDIR += postgresql-repmgr
+ SUBDIR += postgresql-rum
SUBDIR += postgresql-tds_fdw
SUBDIR += postgresql-zhparser
SUBDIR += postgresql10-client
diff --git a/databases/postgresql-rum/Makefile b/databases/postgresql-rum/Makefile
new file mode 100644
index 000000000000..3d49d59f17a8
--- /dev/null
+++ b/databases/postgresql-rum/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= rum
+PORTVERSION= 1.3.1
+PORTREVISION= 0
+CATEGORIES= databases
+PKGNAMEPREFIX= postgresql${PGSQL_VER:S/.//}-
+
+MAINTAINER= feld@FreeBSD.org
+COMMENT= Inverted index with additional information in posting lists
+
+LICENSE= PostgreSQL
+
+USES= gmake pgsql:9.6+
+
+LLD_UNSAFE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= postgrespro
+
+WANT_PGSQL= server
+
+do-build:
+ cd ${WRKSRC} && ${MAKE_CMD} USE_PGXS=1
+
+do-install:
+ cd ${WRKSRC} && ${MAKE_CMD} USE_PGXS=1 DESTDIR=${STAGEDIR} install
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-rum/distinfo b/databases/postgresql-rum/distinfo
new file mode 100644
index 000000000000..e00c1a942436
--- /dev/null
+++ b/databases/postgresql-rum/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1559069682
+SHA256 (postgrespro-rum-1.3.1_GH0.tar.gz) = 2f0dbe101a4760856591b1ea69053fdd6b867a1d2906442fcfd5a18fe7179cbb
+SIZE (postgrespro-rum-1.3.1_GH0.tar.gz) = 313595
diff --git a/databases/postgresql-rum/pkg-descr b/databases/postgresql-rum/pkg-descr
new file mode 100644
index 000000000000..e0094aae56c5
--- /dev/null
+++ b/databases/postgresql-rum/pkg-descr
@@ -0,0 +1,4 @@
+The rum module provides access method to work with RUM index. It is
+based on the GIN access methods code.
+
+WWW: https://github.com/postgrespro/rum
diff --git a/databases/postgresql-rum/pkg-plist b/databases/postgresql-rum/pkg-plist
new file mode 100644
index 000000000000..f72f9218daeb
--- /dev/null
+++ b/databases/postgresql-rum/pkg-plist
@@ -0,0 +1,9 @@
+include/postgresql/server/rum.h
+include/postgresql/server/rumsort.h
+lib/postgresql/rum.so
+share/postgresql/extension/rum--1.0--1.1.sql
+share/postgresql/extension/rum--1.0.sql
+share/postgresql/extension/rum--1.1--1.2.sql
+share/postgresql/extension/rum--1.2--1.3.sql
+share/postgresql/extension/rum--1.3.sql
+share/postgresql/extension/rum.control