aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2020-07-14 18:00:34 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2020-07-14 18:00:34 +0000
commit904e2c69b75352a06aae4cbe492c64be08a09abc (patch)
treeac56e7fd7272dac9b0f84272002b0365930e705c /databases
parent09f9cc4233b790d5e43ed94575c3a0ac875d59ac (diff)
downloadports-904e2c69b75352a06aae4cbe492c64be08a09abc.tar.gz
ports-904e2c69b75352a06aae4cbe492c64be08a09abc.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql80-client/Makefile1
-rw-r--r--databases/mysql80-server/Makefile4
-rw-r--r--databases/mysql80-server/distinfo6
-rw-r--r--databases/mysql80-server/files/patch-cmake_plugin.cmake29
-rw-r--r--databases/mysql80-server/files/patch-extra_libevent_openssl-compat.h19
-rw-r--r--databases/mysql80-server/files/patch-plugin_group__replication_libmysqlgcs_src_bindings_xcom_xcom_xcom__ssl__transport.c4
-rw-r--r--databases/mysql80-server/files/patch-sql_mysqld.cc10
-rw-r--r--databases/mysql80-server/files/patch-storage_temptable_include_temptable_lock_free_type.h17
-rw-r--r--databases/mysql80-server/pkg-plist2
9 files changed, 53 insertions, 39 deletions
diff --git a/databases/mysql80-client/Makefile b/databases/mysql80-client/Makefile
index 8ba57f8c5f2e..919911486fe4 100644
--- a/databases/mysql80-client/Makefile
+++ b/databases/mysql80-client/Makefile
@@ -2,7 +2,6 @@
# $FreeBSD$
PORTNAME= mysql
-PORTREVISION= 1
PKGNAMESUFFIX= 80-client
COMMENT= Multithreaded SQL database (client)
diff --git a/databases/mysql80-server/Makefile b/databases/mysql80-server/Makefile
index 841ad425191f..ba643c9ddfb6 100644
--- a/databases/mysql80-server/Makefile
+++ b/databases/mysql80-server/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME?= mysql
-PORTVERSION= 8.0.20
-PORTREVISION?= 1
+PORTVERSION= 8.0.21
+PORTREVISION?= 0
CATEGORIES= databases
MASTER_SITES= MYSQL/MySQL-8.0
PKGNAMESUFFIX?= 80-server
diff --git a/databases/mysql80-server/distinfo b/databases/mysql80-server/distinfo
index a892ada9a822..a3d7f64c4c31 100644
--- a/databases/mysql80-server/distinfo
+++ b/databases/mysql80-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588248990
-SHA256 (mysql-boost-8.0.20.tar.gz) = b6ad1a09eb146fa913f1afc257bbed8ffab688e2d504fb8ddb652f69f551a9c1
-SIZE (mysql-boost-8.0.20.tar.gz) = 266282970
+TIMESTAMP = 1594631042
+SHA256 (mysql-boost-8.0.21.tar.gz) = 37231a123372a95f409857364dc1deb196b6f2c0b1fe60cc8382c7686b487f11
+SIZE (mysql-boost-8.0.21.tar.gz) = 278292192
diff --git a/databases/mysql80-server/files/patch-cmake_plugin.cmake b/databases/mysql80-server/files/patch-cmake_plugin.cmake
index c0d9994299b6..ecd2598f320e 100644
--- a/databases/mysql80-server/files/patch-cmake_plugin.cmake
+++ b/databases/mysql80-server/files/patch-cmake_plugin.cmake
@@ -1,12 +1,27 @@
--- cmake/plugin.cmake.orig 2019-09-20 08:30:51 UTC
+++ cmake/plugin.cmake
-@@ -226,9 +226,6 @@ MACRO(MYSQL_ADD_PLUGIN)
- MYSQL_INSTALL_TARGETS(${target}
- DESTINATION ${INSTALL_PLUGINDIR}
- COMPONENT ${INSTALL_COMPONENT})
-- INSTALL_DEBUG_TARGET(${target}
-- DESTINATION ${INSTALL_PLUGINDIR}/debug
-- COMPONENT ${INSTALL_COMPONENT})
+@@ -230,15 +230,15 @@ MACRO(MYSQL_ADD_PLUGIN plugin_arg)
+
+ # For testing purposes, we need
+ # <...>/lib/plugin/debug/authentication_ldap_sasl_client.so
+- IF(ARG_CLIENT_ONLY)
+- INSTALL_DEBUG_TARGET(${target}
+- DESTINATION ${INSTALL_PLUGINDIR}/debug
+- COMPONENT Test)
+- ELSE()
+- INSTALL_DEBUG_TARGET(${target}
+- DESTINATION ${INSTALL_PLUGINDIR}/debug
+- COMPONENT ${INSTALL_COMPONENT})
+- ENDIF()
++# IF(ARG_CLIENT_ONLY)
++# INSTALL_DEBUG_TARGET(${target}
++# DESTINATION ${INSTALL_PLUGINDIR}/debug
++# COMPONENT Test)
++# ELSE()
++# INSTALL_DEBUG_TARGET(${target}
++# DESTINATION ${INSTALL_PLUGINDIR}/debug
++# COMPONENT ${INSTALL_COMPONENT})
++# ENDIF()
ENDIF()
ELSE()
IF(WITHOUT_${plugin})
diff --git a/databases/mysql80-server/files/patch-extra_libevent_openssl-compat.h b/databases/mysql80-server/files/patch-extra_libevent_openssl-compat.h
deleted file mode 100644
index 22616ed7ca9f..000000000000
--- a/databases/mysql80-server/files/patch-extra_libevent_openssl-compat.h
+++ /dev/null
@@ -1,19 +0,0 @@
---- extra/libevent/openssl-compat.h.orig 2019-09-20 08:30:51 UTC
-+++ extra/libevent/openssl-compat.h
-@@ -24,12 +24,15 @@ static inline BIO_METHOD *BIO_meth_new(int type, const
- #define BIO_set_init(b, val) (b)->init = (val)
- #define BIO_set_data(b, val) (b)->ptr = (val)
- #define BIO_set_shutdown(b, val) (b)->shutdown = (val)
--#define BIO_get_init(b) (b)->init
- #define BIO_get_data(b) (b)->ptr
- #define BIO_get_shutdown(b) (b)->shutdown
-
- #define TLS_method SSLv23_method
-
- #endif /* OPENSSL_VERSION_NUMBER < 0x10100000L */
-+
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+#define BIO_get_init(b) (b)->init
-+#endif
-
- #endif /* OPENSSL_COMPAT_H */
diff --git a/databases/mysql80-server/files/patch-plugin_group__replication_libmysqlgcs_src_bindings_xcom_xcom_xcom__ssl__transport.c b/databases/mysql80-server/files/patch-plugin_group__replication_libmysqlgcs_src_bindings_xcom_xcom_xcom__ssl__transport.c
index ad66725947e7..66630594fdf0 100644
--- a/databases/mysql80-server/files/patch-plugin_group__replication_libmysqlgcs_src_bindings_xcom_xcom_xcom__ssl__transport.c
+++ b/databases/mysql80-server/files/patch-plugin_group__replication_libmysqlgcs_src_bindings_xcom_xcom_xcom__ssl__transport.c
@@ -1,5 +1,5 @@
---- plugin/group_replication/libmysqlgcs/src/bindings/xcom/xcom/xcom_ssl_transport.c.orig 2019-09-20 08:30:51 UTC
-+++ plugin/group_replication/libmysqlgcs/src/bindings/xcom/xcom/xcom_ssl_transport.c
+--- plugin/group_replication/libmysqlgcs/src/bindings/xcom/xcom/xcom_ssl_transport.cc.orig 2019-09-20 08:30:51 UTC
++++ plugin/group_replication/libmysqlgcs/src/bindings/xcom/xcom/xcom_ssl_transport.cc
@@ -329,6 +329,7 @@ error:
return 1;
}
diff --git a/databases/mysql80-server/files/patch-sql_mysqld.cc b/databases/mysql80-server/files/patch-sql_mysqld.cc
index 8b283e401563..39a7fb89844a 100644
--- a/databases/mysql80-server/files/patch-sql_mysqld.cc
+++ b/databases/mysql80-server/files/patch-sql_mysqld.cc
@@ -1,6 +1,6 @@
--- sql/mysqld.cc.orig 2019-09-20 08:30:51 UTC
+++ sql/mysqld.cc
-@@ -4818,7 +4818,7 @@ static int init_thread_environment() {
+@@ -5109,7 +5109,7 @@ static int init_thread_environment() {
static PSI_memory_key key_memory_openssl = PSI_NOT_INSTRUMENTED;
@@ -9,7 +9,7 @@
#define FILE_LINE_ARGS
#else
#define FILE_LINE_ARGS , const char *, int
-@@ -4854,12 +4854,14 @@ static void init_ssl() {
+@@ -5143,12 +5143,14 @@ static void init_ssl() {
}
static int init_ssl_communication() {
@@ -21,6 +21,6 @@
return 1;
}
+#endif /* LIBRESSL_VERSION_NUMBER */
- if (SslAcceptorContext::singleton_init(opt_use_ssl)) return 1;
-
- #if OPENSSL_VERSION_NUMBER < 0x10100000L
+ if (TLS_channel::singleton_init(&mysql_main, mysql_main_channel, opt_use_ssl,
+ &server_main_callback, opt_initialize))
+ return 1;
diff --git a/databases/mysql80-server/files/patch-storage_temptable_include_temptable_lock_free_type.h b/databases/mysql80-server/files/patch-storage_temptable_include_temptable_lock_free_type.h
new file mode 100644
index 000000000000..b847ce64d5da
--- /dev/null
+++ b/databases/mysql80-server/files/patch-storage_temptable_include_temptable_lock_free_type.h
@@ -0,0 +1,17 @@
+--- storage/temptable/include/temptable/lock_free_type.h.orig 2020-06-16 16:31:03 UTC
++++ storage/temptable/include/temptable/lock_free_type.h
+@@ -31,6 +31,14 @@ Lock-free type (selection) implementation. */
+
+ #include "storage/temptable/include/temptable/constants.h"
+
++#if defined(__i386__) //&& defined(__GCC_HAVE_SYNC_COMPARE_AND_SWAP_8)
++/* Fix for clang setting __GCC_ATOMIC_LLONG_LOCK_FREE incorecctly for x86
++ * https://llvm.org/bugs/show_bug.cgi?id=19355
++ */
++#undef ATOMIC_LLONG_LOCK_FREE
++#define ATOMIC_LLONG_LOCK_FREE 2
++#endif
++
+ namespace temptable {
+
+ /** Enum class describing alignment-requirements. */
diff --git a/databases/mysql80-server/pkg-plist b/databases/mysql80-server/pkg-plist
index 38e6c9364c98..76924792f8c8 100644
--- a/databases/mysql80-server/pkg-plist
+++ b/databases/mysql80-server/pkg-plist
@@ -41,6 +41,7 @@ lib/mysql/mysqlrouter/rest_api.so
lib/mysql/mysqlrouter/rest_metadata_cache.so
lib/mysql/mysqlrouter/rest_router.so
lib/mysql/mysqlrouter/rest_routing.so
+lib/mysql/mysqlrouter/router_protobuf.so
lib/mysql/mysqlrouter/routing.so
lib/mysql/plugin/adt_null.so
lib/mysql/plugin/auth.so
@@ -59,6 +60,7 @@ lib/mysql/plugin/component_pfs_example.so
lib/mysql/plugin/component_pfs_example_component_population.so
lib/mysql/plugin/component_test_audit_api_message.so
lib/mysql/plugin/component_test_backup_lock_service.so
+lib/mysql/plugin/component_test_component_deinit.so
lib/mysql/plugin/component_test_host_application_signal.so
lib/mysql/plugin/component_test_mysql_current_thread_reader.so
lib/mysql/plugin/component_test_mysql_runtime_error.so