aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-06-06 06:44:37 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-06-06 06:44:37 +0000
commit9c2f65e3958e906d7f49ce94318d22defb3fffb2 (patch)
treebc087bd13fb3e313884021b8e0a5e2046e75d491 /databases
parent7db146587f345a51482b4b1c314fe71cfeb37e6c (diff)
downloadports-9c2f65e3958e906d7f49ce94318d22defb3fffb2.tar.gz
ports-9c2f65e3958e906d7f49ce94318d22defb3fffb2.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/akonadi-google/Makefile3
-rw-r--r--databases/akonadi-googledata/Makefile3
-rw-r--r--databases/akonadi/Makefile7
-rw-r--r--databases/kbibtex/Makefile3
-rw-r--r--databases/py-qt4-sql/Makefile3
-rw-r--r--databases/qt4-ibase-plugin/Makefile3
-rw-r--r--databases/qt4-mysql-plugin/Makefile3
-rw-r--r--databases/qt4-odbc-plugin/Makefile3
-rw-r--r--databases/qt4-pgsql-plugin/Makefile3
-rw-r--r--databases/qt4-sql/Makefile3
-rw-r--r--databases/qt4-sqlite-plugin/Makefile3
-rw-r--r--databases/qt4-sqlite3-plugin/Makefile3
-rw-r--r--databases/sqliteman/Makefile3
-rw-r--r--databases/tora/Makefile3
14 files changed, 16 insertions, 30 deletions
diff --git a/databases/akonadi-google/Makefile b/databases/akonadi-google/Makefile
index 96f1a13f84ea..27a39550a600 100644
--- a/databases/akonadi-google/Makefile
+++ b/databases/akonadi-google/Makefile
@@ -22,8 +22,7 @@ LIB_DEPENDS= qjson.0:${PORTSDIR}/devel/qjson
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
USE_KDE4= kdehier kdelibs kdeprefix pimlibs automoc4
-USE_QT_VER= 4
-QT_COMPONENTS= dbus gui network webkit xml \
+USE_QT4= dbus gui network webkit xml \
moc_build qmake_build rcc_build uic_build
USE_CMAKE= yes
MAKE_JOBS_SAFE= yes
diff --git a/databases/akonadi-googledata/Makefile b/databases/akonadi-googledata/Makefile
index 6aab8d79c144..7f0c083aa1bc 100644
--- a/databases/akonadi-googledata/Makefile
+++ b/databases/akonadi-googledata/Makefile
@@ -19,8 +19,7 @@ LIB_DEPENDS= gcal:${PORTSDIR}/deskutils/libgcal
USE_BZIP2= yes
USE_CMAKE= yes
USE_GETTEXT= yes
-USE_QT_VER= 4
-QT_COMPONENTS= qmake_build rcc_build moc_build uic_build dbus
+USE_QT4= qmake_build rcc_build moc_build uic_build dbus
USE_KDE4= kdelibs kdeprefix pimlibs automoc4 akonadi
.include <bsd.port.mk>
diff --git a/databases/akonadi/Makefile b/databases/akonadi/Makefile
index 97a590f27b4c..ce84eced1e7e 100644
--- a/databases/akonadi/Makefile
+++ b/databases/akonadi/Makefile
@@ -24,8 +24,7 @@ LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
USE_BZIP2= yes
-USE_QT_VER= 4
-QT_COMPONENTS= corelib network qtestlib dbus gui sql \
+USE_QT4= corelib network qtestlib dbus gui sql \
qmake_build moc_build rcc_build uic_build
USE_KDE4= kdehier kdeprefix sharedmime automoc4 soprano
KDE4_BUILDENV= yes
@@ -44,7 +43,7 @@ OPTIONS= MYSQL "Install MySQL plugin and server (recommended)" on \
.ifndef(WITHOUT_MYSQL)
USE_MYSQL= server
-QT_COMPONENTS+= sql-mysql_run
+USE_QT4+= sql-mysql_run
.endif
.ifdef(WITH_PGSQL)
@@ -52,7 +51,7 @@ QT_COMPONENTS+= sql-mysql_run
# it over MySQL might like to use some advanced configuration like a
# remote server.
#USE_PGSQL= server
-QT_COMPONENTS+= sql-pgsql_run
+USE_QT4+= sql-pgsql_run
.endif
.ifdef(WITH_SQLITE)
diff --git a/databases/kbibtex/Makefile b/databases/kbibtex/Makefile
index eba7b9596938..99510b815c60 100644
--- a/databases/kbibtex/Makefile
+++ b/databases/kbibtex/Makefile
@@ -19,8 +19,7 @@ USE_BZIP2= yes
USE_CMAKE= yes
USE_GNOME= libxml2 libxslt
USE_KDE4= kdelibs kdeprefix automoc4 sharedmime
-USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build uic_build rcc_build \
+USE_QT4= qmake_build moc_build uic_build rcc_build \
webkit
MAKE_JOBS_SAFE= yes
diff --git a/databases/py-qt4-sql/Makefile b/databases/py-qt4-sql/Makefile
index cdfd6b399bab..7ac43108fc9f 100644
--- a/databases/py-qt4-sql/Makefile
+++ b/databases/py-qt4-sql/Makefile
@@ -22,8 +22,7 @@ RUN_DEPENDS= ${PKGNAMEPREFIX}gui>=${PYQT4_VERSION}:${PORTSDIR}/x11-toolkits/py-q
DISTINFO_FILE= ${PYQT4_DISTINFO_FILE}
HAS_CONFIGURE= yes
USE_PYTHON= 2.5+
-USE_QT_VER= 4
-QT_COMPONENTS= sql qmake_build
+USE_QT4= sql qmake_build
OPTIONS= API "Install QtSql API for QScintilla2" on \
DEBUG "Enable debugging in generated code" off \
diff --git a/databases/qt4-ibase-plugin/Makefile b/databases/qt4-ibase-plugin/Makefile
index 1522a5b10de4..5a8128810d0a 100644
--- a/databases/qt4-ibase-plugin/Makefile
+++ b/databases/qt4-ibase-plugin/Makefile
@@ -16,8 +16,7 @@ COMMENT= Qt IBase/Firebird database plugin
DB= ibase
USE_FIREBIRD= yes
-USE_QT_VER= 4
-QT_COMPONENTS= moc_build sql
+USE_QT4= moc_build sql
QT_NONSTANDARD= yes
QT_DIST= yes
MAKE_JOBS_SAFE= yes
diff --git a/databases/qt4-mysql-plugin/Makefile b/databases/qt4-mysql-plugin/Makefile
index d7553face495..c554119f6a89 100644
--- a/databases/qt4-mysql-plugin/Makefile
+++ b/databases/qt4-mysql-plugin/Makefile
@@ -15,8 +15,7 @@ COMMENT= Qt MySQL database plugin
DB= mysql
-USE_QT_VER= 4
-QT_COMPONENTS= moc_build sql
+USE_QT4= moc_build sql
QT_NONSTANDARD= yes
QT_DIST= yes
MAKE_JOBS_SAFE= yes
diff --git a/databases/qt4-odbc-plugin/Makefile b/databases/qt4-odbc-plugin/Makefile
index e14c60e384a7..148140a7c151 100644
--- a/databases/qt4-odbc-plugin/Makefile
+++ b/databases/qt4-odbc-plugin/Makefile
@@ -17,8 +17,7 @@ DB= odbc
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
-USE_QT_VER= 4
-QT_COMPONENTS= moc_build sql
+USE_QT4= moc_build sql
QT_NONSTANDARD= yes
QT_DIST= yes
MAKE_JOBS_SAFE= yes
diff --git a/databases/qt4-pgsql-plugin/Makefile b/databases/qt4-pgsql-plugin/Makefile
index ae8b81659e3d..7af82d56a597 100644
--- a/databases/qt4-pgsql-plugin/Makefile
+++ b/databases/qt4-pgsql-plugin/Makefile
@@ -15,8 +15,7 @@ COMMENT= Qt PostgreSQL database plugin
DB= psql
-USE_QT_VER= 4
-QT_COMPONENTS= moc_build sql
+USE_QT4= moc_build sql
QT_NONSTANDARD= yes
QT_DIST= yes
MAKE_JOBS_SAFE= yes
diff --git a/databases/qt4-sql/Makefile b/databases/qt4-sql/Makefile
index 57fc3a25f969..43a52983414d 100644
--- a/databases/qt4-sql/Makefile
+++ b/databases/qt4-sql/Makefile
@@ -14,8 +14,7 @@ PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt SQL library
-USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build corelib
+USE_QT4= qmake_build moc_build corelib
QT_NONSTANDARD= yes
QT_DIST= yes
MAKE_JOBS_SAFE= yes
diff --git a/databases/qt4-sqlite-plugin/Makefile b/databases/qt4-sqlite-plugin/Makefile
index f1396a71eb12..72a342fb8ff7 100644
--- a/databases/qt4-sqlite-plugin/Makefile
+++ b/databases/qt4-sqlite-plugin/Makefile
@@ -17,8 +17,7 @@ DB= sqlite2
LIB_DEPENDS+= sqlite.2:${PORTSDIR}/databases/sqlite2
-USE_QT_VER= 4
-QT_COMPONENTS= moc_build sql
+USE_QT4= moc_build sql
QT_NONSTANDARD= yes
QT_DIST= yes
MAKE_JOBS_SAFE= yes
diff --git a/databases/qt4-sqlite3-plugin/Makefile b/databases/qt4-sqlite3-plugin/Makefile
index a7a957c831ac..befcb225d775 100644
--- a/databases/qt4-sqlite3-plugin/Makefile
+++ b/databases/qt4-sqlite3-plugin/Makefile
@@ -18,8 +18,7 @@ DISTINFO_FILE= ${PORTSDIR}/devel/qt4/distinfo
LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
-USE_QT_VER= 4
-QT_COMPONENTS= moc_build sql
+USE_QT4= moc_build sql
QT_NONSTANDARD= yes
QT_DIST= yes
MAKE_JOBS_SAFE= yes
diff --git a/databases/sqliteman/Makefile b/databases/sqliteman/Makefile
index 4be522840a27..a600ea2722b6 100644
--- a/databases/sqliteman/Makefile
+++ b/databases/sqliteman/Makefile
@@ -17,10 +17,9 @@ COMMENT= Admin's GUI tool for Sqlite3
LIB_DEPENDS= qscintilla2:${PORTSDIR}/devel/qscintilla2
USE_CMAKE= yes
-USE_QT_VER= 4
USE_SQLITE= yes
CMAKE_ENV+= QMAKESPEC=${QMAKESPEC}
-QT_COMPONENTS= qmake_build gui moc_build rcc_build uic_build xml sql
+USE_QT4= qmake_build gui moc_build rcc_build uic_build xml sql
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/databases/tora/Makefile b/databases/tora/Makefile
index b824c2fc061b..0fb1306186d2 100644
--- a/databases/tora/Makefile
+++ b/databases/tora/Makefile
@@ -24,8 +24,7 @@ OPTIONS= ORACLE "Build with Oracle support (i386 only)" off \
MYSQL "Build with MySQL support" on
USE_AUTOTOOLS= aclocal automake autoconf autoheader libtool
-USE_QT_VER= 4
-QT_COMPONENTS= gui corelib sql xml network linguist moc_build uic_build rcc_build
+USE_QT4= gui corelib sql xml network linguist moc_build uic_build rcc_build
USE_GMAKE= yes
GNU_CONFIGURE= yes