aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorDaniel Morante <daniel@morante.net>2023-08-22 08:13:29 +0000
committerJuraj Lutter <otis@FreeBSD.org>2023-08-22 08:16:26 +0000
commitad47ed371cbbbc06f45722d6ac3afcdb3f6465a4 (patch)
treecfbc1af24d6095ebf4c8f60a90f5c79d546e22dd /databases
parent0f386067b1cd99c6a276d3e195fa1d0251eadc17 (diff)
downloadports-ad47ed371cbbbc06f45722d6ac3afcdb3f6465a4.tar.gz
ports-ad47ed371cbbbc06f45722d6ac3afcdb3f6465a4.zip
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/postgresql-wal2json/Makefile23
-rw-r--r--databases/postgresql-wal2json/distinfo3
-rw-r--r--databases/postgresql-wal2json/pkg-descr5
-rw-r--r--databases/postgresql-wal2json/pkg-message17
5 files changed, 49 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 60e6efc6ef0c..25d125b8eab0 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -672,6 +672,7 @@
SUBDIR += postgresql-rum
SUBDIR += postgresql-semver
SUBDIR += postgresql-tds_fdw
+ SUBDIR += postgresql-wal2json
SUBDIR += postgresql-zhparser
SUBDIR += postgresql11-client
SUBDIR += postgresql11-contrib
diff --git a/databases/postgresql-wal2json/Makefile b/databases/postgresql-wal2json/Makefile
new file mode 100644
index 000000000000..1fc6676ee1ce
--- /dev/null
+++ b/databases/postgresql-wal2json/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= wal2json
+PORTVERSION= 2.5
+CATEGORIES= databases
+PKGNAMEPREFIX= postgresql${PGSQL_VER:S/.//}-
+
+MAINTAINER= daniel@morante.net
+COMMENT= JSON output plugin for changeset extraction for PostgreSQL databases
+WWW= https://github.com/getsentry/wal2json/
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake pgsql:11-14
+WANT_PGSQL= server
+USE_GITHUB= yes
+GH_ACCOUNT= eulerto
+GH_TAGNAME= ${PORTNAME}_${PORTVERSION:S/./_/}
+
+MAKE_ARGS= PG_CONFIG=${LOCALBASE}/bin/pg_config
+
+PLIST_FILES= lib/postgresql/wal2json.so
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-wal2json/distinfo b/databases/postgresql-wal2json/distinfo
new file mode 100644
index 000000000000..27c45dc415dc
--- /dev/null
+++ b/databases/postgresql-wal2json/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1692687620
+SHA256 (eulerto-wal2json-2.5-wal2json_2_5_GH0.tar.gz) = b516653575541cf221b99cf3f8be9b6821f6dbcfc125675c85f35090f824f00e
+SIZE (eulerto-wal2json-2.5-wal2json_2_5_GH0.tar.gz) = 91040
diff --git a/databases/postgresql-wal2json/pkg-descr b/databases/postgresql-wal2json/pkg-descr
new file mode 100644
index 000000000000..dc54712928f1
--- /dev/null
+++ b/databases/postgresql-wal2json/pkg-descr
@@ -0,0 +1,5 @@
+wal2json is an output plugin for logical decoding. It means that the plugin have
+access to tuples produced by INSERT and UPDATE. Also, UPDATE/DELETE old row
+versions can be accessed depending on the configured replica identity.
+Changes can be consumed using the streaming protocol (logical replication slots)
+or by a special SQL API.
diff --git a/databases/postgresql-wal2json/pkg-message b/databases/postgresql-wal2json/pkg-message
new file mode 100644
index 000000000000..9d3553ba00e8
--- /dev/null
+++ b/databases/postgresql-wal2json/pkg-message
@@ -0,0 +1,17 @@
+[
+{ type: install
+ message: <<EOM
+You need to set up at least two parameters in postgresql.conf:
+
+ wal_level = logical
+ #
+ # these parameters only need to set in versions 9.4, 9.5 and 9.6
+ # default values are ok in version 10 or later
+ #
+ max_replication_slots = 10
+ max_wal_senders = 10
+
+After changing these parameters, a restart is needed.
+EOM
+}
+]