aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-12-09 14:47:15 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-12-09 14:47:15 +0000
commitb00df58af0733837ebe38c1bdd261620ebc7b484 (patch)
treee7339ec77c43f13e174ecbc545b500782be0d426 /databases
parentceded8c05695b7528a3d94714d7515902ed2f995 (diff)
downloadports-b00df58af0733837ebe38c1bdd261620ebc7b484.tar.gz
ports-b00df58af0733837ebe38c1bdd261620ebc7b484.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/gom/Makefile19
-rw-r--r--databases/gom/distinfo3
-rw-r--r--databases/gom/pkg-descr5
-rw-r--r--databases/gom/pkg-plist19
5 files changed, 47 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 07b4c7c1af2b..64c48b05f5f2 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -98,6 +98,7 @@
SUBDIR += gnats4
SUBDIR += gnatsweb4
SUBDIR += go-carbon
+ SUBDIR += gom
SUBDIR += gomdb
SUBDIR += gosqlite3
SUBDIR += gqlplus
diff --git a/databases/gom/Makefile b/databases/gom/Makefile
new file mode 100644
index 000000000000..13ed21d2bae0
--- /dev/null
+++ b/databases/gom/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= gom
+PORTVERSION= 0.3.3
+CATEGORIES= databases gnome
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GObject Data Mapper
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gnome meson pkgconfig python:3.4+ sqlite tar:xz
+USE_GNOME= gdkpixbuf2 glib20 introspection pygobject3
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/databases/gom/distinfo b/databases/gom/distinfo
new file mode 100644
index 000000000000..4ed95717ca68
--- /dev/null
+++ b/databases/gom/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1544364106
+SHA256 (gom-0.3.3.tar.xz) = ac57e34b5fe273ed306efaeabb346712c264e341502913044a782cdf8c1036d8
+SIZE (gom-0.3.3.tar.xz) = 101580
diff --git a/databases/gom/pkg-descr b/databases/gom/pkg-descr
new file mode 100644
index 000000000000..ce6d639d6c02
--- /dev/null
+++ b/databases/gom/pkg-descr
@@ -0,0 +1,5 @@
+This is an attempt to make a DataMapper for GObject. Mostly because I'm
+sick of doing this by hand in C. It would be cool if it would work across
+language boundries using GObject Introspection too.
+
+WWW: https://wiki.gnome.org/Projects/Gom
diff --git a/databases/gom/pkg-plist b/databases/gom/pkg-plist
new file mode 100644
index 000000000000..c034f3e00054
--- /dev/null
+++ b/databases/gom/pkg-plist
@@ -0,0 +1,19 @@
+include/gom-1.0/gom/gom-adapter.h
+include/gom-1.0/gom/gom-autocleanups.h
+include/gom-1.0/gom/gom-command-builder.h
+include/gom-1.0/gom/gom-command.h
+include/gom-1.0/gom/gom-cursor.h
+include/gom-1.0/gom/gom-error.h
+include/gom-1.0/gom/gom-filter.h
+include/gom-1.0/gom/gom-repository.h
+include/gom-1.0/gom/gom-resource-group.h
+include/gom-1.0/gom/gom-resource.h
+include/gom-1.0/gom/gom-sorting.h
+include/gom-1.0/gom/gom.h
+lib/girepository-1.0/Gom-1.0.typelib
+lib/libgom-1.0.so
+lib/libgom-1.0.so.0
+lib/libgom-1.0.so.0.1.0
+lib/python3.6/site-packages/gi/overrides/Gom.py
+libdata/pkgconfig/gom-1.0.pc
+share/gir-1.0/Gom-1.0.gir