aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-03-06 08:26:33 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-03-06 08:26:33 +0000
commitb337f93003df8c6540a44f6181c3c3fac3b5e09a (patch)
treeb099b492523ed54d2b58982ab44b3aae04bcc5e8 /databases
parent906864d7d527d923b5d954deeda2b42e896849fd (diff)
downloadports-b337f93003df8c6540a44f6181c3c3fac3b5e09a.tar.gz
ports-b337f93003df8c6540a44f6181c3c3fac3b5e09a.zip
Hook the tests to our framework. Unfortunately, `devel/check' should be
available during the build stage (it is detected by the configure script), so it must be put on the BUILD_DEPENDS rather than expected TEST_DEPENDS.
Notes
Notes: svn path=/head/; revision=567468
Diffstat (limited to 'databases')
-rw-r--r--databases/recutils/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/databases/recutils/Makefile b/databases/recutils/Makefile
index e55eb2eb24da..16eefb987527 100644
--- a/databases/recutils/Makefile
+++ b/databases/recutils/Makefile
@@ -18,12 +18,11 @@ USES= charsetfix libtool makeinfo pkgconfig readline
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-TEST_TARGET= check
INFO= rec-mode recutils
PORTDOCS= AUTHORS ChangeLog NEWS README
-OPTIONS_DEFINE= BASH DOCS CURL GCRYPT MDB NLS
+OPTIONS_DEFINE= BASH CURL DOCS GCRYPT MDB NLS TEST
OPTIONS_DEFAULT= CURL GCRYPT MDB
OPTIONS_SUB= yes
@@ -48,6 +47,9 @@ MDB_CONFIGURE_ENV_OFF= ac_cv_lib_mdb_mdb_get_version=no
NLS_USES= gettext
NLS_CONFIGURE_OFF= --disable-nls
+TEST_BUILD_DEPENDS= ${LOCALBASE}/include/check.h:devel/check
+TEST_VARS= TEST_TARGET=check
+
post-patch:
@${REINPLACE_CMD} -e 's,mdb_init,mdb_get_version,' \
${WRKSRC}/configure