aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-03 14:55:28 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-03 14:55:28 +0000
commitb8c44519360544de915a48b9ad20d4415c0e50dd (patch)
tree87bc866292198ff38114c9b3a25fe0d6472dedb8 /databases
parentafd4eca55b5c4484360ec309753b25621db9260c (diff)
downloadports-b8c44519360544de915a48b9ad20d4415c0e50dd.tar.gz
ports-b8c44519360544de915a48b9ad20d4415c0e50dd.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/apq-mysql/Makefile8
-rw-r--r--databases/apq/Makefile.version2
2 files changed, 7 insertions, 3 deletions
diff --git a/databases/apq-mysql/Makefile b/databases/apq-mysql/Makefile
index 70797f4e7980..aa95818095a6 100644
--- a/databases/apq-mysql/Makefile
+++ b/databases/apq-mysql/Makefile
@@ -20,8 +20,6 @@ RUN_DEPENDS= ${LOCALBASE}/lib/gnat/apq.gpr:${PORTSDIR}/databases/apq
USES= ada tar:bzip2
USE_MYSQL= yes
-MYSQL_DEFAULT= 55
-IGNORE_MYSQL_VER= 56
HAS_CONFIGURE= yes
WRKPATH= ${WRKDIR}/build
CONFIGURE_ARGS= --prefix=${PREFIX} \
@@ -39,6 +37,12 @@ post-patch:
${REINPLACE_CMD} -e 's|-ws|-ws --autoconf=dummy.cgpr|' \
${WRKSRC}/scripts/buildutil.sh
+post-configure:
+ # The header generated with MySQL 5.6 comes with two instances of
+ # double underscore variables, which is illegal in Ada
+ ${REINPLACE_CMD} -e 's|__|_|' \
+ ${WRKDIR}/build/include/apq-mysql/apq-mysql.ads
+
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/gnat \
${STAGEDIR}${PREFIX}/lib/apq-mysql/static \
diff --git a/databases/apq/Makefile.version b/databases/apq/Makefile.version
index 9180d40c6919..3c65ebd5b8ba 100644
--- a/databases/apq/Makefile.version
+++ b/databases/apq/Makefile.version
@@ -3,5 +3,5 @@
APQ_VERSION= 3.2.0
BASE_PORTREV= 0
DRV_ODBC_PR= 0
-DRV_MYSQL_PR= 0
+DRV_MYSQL_PR= 1
DRV_PGSQL_PR= 0