aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-11-17 16:55:55 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-11-17 16:55:55 +0000
commitc51add673e4ba5d5ddd9b35a14902216fb092de9 (patch)
treef5dd154f599b6c98696d7eb22d986cb8cc2de6cd /databases
parent3db32d4173d4a43af2ba366c104e67d339354d51 (diff)
downloadports-c51add673e4ba5d5ddd9b35a14902216fb092de9.tar.gz
ports-c51add673e4ba5d5ddd9b35a14902216fb092de9.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/ruby-pg/Makefile46
-rw-r--r--databases/ruby-pg/distinfo3
-rw-r--r--databases/ruby-pg/pkg-descr10
-rw-r--r--databases/ruby-pg/pkg-plist15
5 files changed, 75 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 18c8d0409609..ace530dc34cf 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -625,6 +625,7 @@
SUBDIR += ruby-mysql
SUBDIR += ruby-o_dbm
SUBDIR += ruby-odbc
+ SUBDIR += ruby-pg
SUBDIR += ruby-postgres
SUBDIR += ruby-qdbm
SUBDIR += ruby-rdbc1
diff --git a/databases/ruby-pg/Makefile b/databases/ruby-pg/Makefile
new file mode 100644
index 000000000000..e514e4bbf9cd
--- /dev/null
+++ b/databases/ruby-pg/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: ruby-postgres
+# Date created: 17 Nov 2009
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgres
+PORTVERSION= 0.8.0
+CATEGORIES= databases ruby
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ruby-pg
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-pg-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Ruby interface to PostgreSQL library
+
+USE_PGSQL= yes
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/ext
+CONFIGURE_ARGS= --with-pgsql-include-dir="${LOCALBASE}/include"
+INSTALL_TARGET= site-install
+
+DOCS_EN= ChangeLog README doc/postgres.html
+DOCS_JA= README.ja doc/postgres.jp.html
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/../sample/*.rb ${RUBY_MODEXAMPLESDIR}/
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/../${f} ${RUBY_MODDOCDIR}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/../${f} ${RUBY_MODDOCDIR}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/ruby-pg/distinfo b/databases/ruby-pg/distinfo
new file mode 100644
index 000000000000..6f4a91f28a3c
--- /dev/null
+++ b/databases/ruby-pg/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/ruby-pg-0.8.0.tar.gz) = 9a27359820c93a48797f69df2f8e55bf
+SHA256 (ruby/ruby-pg-0.8.0.tar.gz) = 2abdd885fd6751d457fdfe7386573a3f23e4e1a9aef9b89dd63501642ebd17e2
+SIZE (ruby/ruby-pg-0.8.0.tar.gz) = 74730
diff --git a/databases/ruby-pg/pkg-descr b/databases/ruby-pg/pkg-descr
new file mode 100644
index 000000000000..df5d60683a3e
--- /dev/null
+++ b/databases/ruby-pg/pkg-descr
@@ -0,0 +1,10 @@
+A Ruby interface to the PostgreSQL Relational Database Management System.
+
+The 'pg' module is the newer module, that has been greatly improved, and
+is almost a complete rewrite. It is not backwards compatible. Use this module
+for newly written code. It should be more stable, less buggy, and has more
+features.
+
+LICENSE: BSD or GPL2
+
+WWW: http://rubyforge.org/projects/ruby-pg/
diff --git a/databases/ruby-pg/pkg-plist b/databases/ruby-pg/pkg-plist
new file mode 100644
index 000000000000..43469c36ffb0
--- /dev/null
+++ b/databases/ruby-pg/pkg-plist
@@ -0,0 +1,15 @@
+%%RUBY_SITEARCHLIBDIR%%/pg.so
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/losample.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/psql.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/psqlHelp.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/test1.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/test2.rb
+%%PORTEXAMPLES%%%%RUBY_MODEXAMPLESDIR%%/test4.rb
+%%PORTEXAMPLES%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/postgres.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/README.ja
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/postgres.jp.html
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%