aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-22 06:55:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-22 06:55:03 +0000
commitdb3c0ef5d8744d5ad7581a929f7c3c5176129e53 (patch)
treea52ac247d6153a6f527c54ee12240ae27dd64388 /databases
parentaecd9ae416a47483718e09d50199f2df9b7c9832 (diff)
- Simplify patch for FreeBSD 9.x
Notes
Notes: svn path=/head/; revision=426781
Diffstat (limited to 'databases')
-rw-r--r--databases/xapian-core/Makefile2
-rw-r--r--databases/xapian-core/files/extrapatch-backends_flint__lock.cc16
2 files changed, 1 insertions, 17 deletions
diff --git a/databases/xapian-core/Makefile b/databases/xapian-core/Makefile
index e6686f90b49d..0638a1f95380 100644
--- a/databases/xapian-core/Makefile
+++ b/databases/xapian-core/Makefile
@@ -32,7 +32,7 @@ SSE2_CONFIGURE_ENABLE= sse
# FreeBSD 9 does not have SOCK_CLOEXEC.
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-EXTRA_PATCHES= ${FILESDIR}/extrapatch-backends_flint__lock.cc
+CXXFLAGS+= -DSOCK_CLOEXEC=0
.endif
post-install:
diff --git a/databases/xapian-core/files/extrapatch-backends_flint__lock.cc b/databases/xapian-core/files/extrapatch-backends_flint__lock.cc
deleted file mode 100644
index 5fe3505080e8..000000000000
--- a/databases/xapian-core/files/extrapatch-backends_flint__lock.cc
+++ /dev/null
@@ -1,16 +0,0 @@
-FreeBSD 9 does not have SOCK_CLOEXEC. Define it to 0, as the code already deals
-with it.
-Xapian 1.4 has a safesyssocket.h that takes care of this.
---- backends/flint_lock.cc.orig 2016-09-16 01:59:15 UTC
-+++ backends/flint_lock.cc
-@@ -59,6 +59,10 @@ using namespace std;
- # endif
- #endif
-
-+#ifndef SOCK_CLOEXEC
-+#define SOCK_CLOEXEC 0
-+#endif
-+
- FlintLock::reason
- FlintLock::lock(bool exclusive, string & explanation) {
- // Currently we only support exclusive locks.