aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-14 18:03:48 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-14 18:03:48 +0000
commite4b8424f336a69682278ac3b5d2bdc4a90ee0fff (patch)
tree7fa01b5d6e789a414aab041ca7a0197b3c41f716 /databases
parentc36bd24ce791a2aabf29e5b8b54ffb2c71b98a50 (diff)
downloadports-e4b8424f336a69682278ac3b5d2bdc4a90ee0fff.tar.gz
ports-e4b8424f336a69682278ac3b5d2bdc4a90ee0fff.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/mysql-gui/Makefile26
-rw-r--r--databases/mysql-gui/files/patch-Animated_Icon.cc11
-rw-r--r--databases/mysql-gui/files/patch-FL-Fl_Editor.H10
-rw-r--r--databases/mysql-gui/files/patch-FL-Selection.H11
-rw-r--r--databases/mysql-gui/files/patch-Fl_NSlider.cc10
-rw-r--r--databases/mysql-gui/files/patch-Makefile10
-rw-r--r--databases/mysql-gui/files/patch-about.cc10
-rw-r--r--databases/mysql-gui/files/patch-bebac.h10
-rw-r--r--databases/mysql-gui/files/patch-client.h10
-rw-r--r--databases/mysql-gui/files/patch-db_tree.cc9
-rw-r--r--databases/mysql-gui/files/patch-do_sql.cc25
-rw-r--r--databases/mysql-gui/files/patch-get_table.cc10
-rw-r--r--databases/mysql-gui/files/patch-gif.cc17
-rw-r--r--databases/mysql-gui/files/patch-grant.cc10
-rw-r--r--databases/mysql-gui/files/patch-main.cc22
-rw-r--r--databases/mysql-gui/files/patch-password.cc10
-rw-r--r--databases/mysql-gui/files/patch-process.cc10
-rw-r--r--databases/mysql-gui/files/patch-single.cc8
-rw-r--r--databases/mysql-gui/files/patch-status.cc8
19 files changed, 207 insertions, 30 deletions
diff --git a/databases/mysql-gui/Makefile b/databases/mysql-gui/Makefile
index d5bb3b1eb414..a00f42ddb240 100644
--- a/databases/mysql-gui/Makefile
+++ b/databases/mysql-gui/Makefile
@@ -7,33 +7,27 @@
PORTNAME= mysql-gui
PORTVERSION= 1.7.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases
-MASTER_SITES= http://www.mysql.com/Downloads/%SUBDIR%/ \
- ftp://mysql.nixc.net/pub/mysql/Downloads/%SUBDIR%/ \
- ftp://sunsite.dk/ftp/mirrors/mysql/Downloads/%SUBDIR%/ \
- ftp://ftp.sunet.se/pub/unix/databases/relational/mysql/Downloads/%SUBDIR%/
+MASTER_SITES= http://mysql.ftp.cvut.cz/Downloads/%SUBDIR%/ \
+ http://sunsite.informatik.rwth-aachen.de/mysql/Downloads/%SUBDIR%/ \
+ http://mysql.he.net/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= mysqlgui
DISTNAME= ${PORTNAME:S/-//}-${PORTVERSION}
MAINTAINER= cyrille.lefevre@laposte.net
COMMENT= A graphical SQL client for MySQL
-BROKEN= Does not patch
-
-# Global variables
-#
-
LIB_DEPENDS= sqlplus.1:${PORTSDIR}/databases/mysql++ \
intl.5:${PORTSDIR}/devel/gettext \
glut.3:${PORTSDIR}/graphics/libglut \
jpeg.9:${PORTSDIR}/graphics/jpeg \
fleditor.1:${PORTSDIR}/x11-toolkits/fl_editor \
flvw.1:${PORTSDIR}/x11-toolkits/flvw
+PATCH_DEPENDS= ${X11BASE}/include/FL/Fl_Editor.H:${PORTSDIR}/x11-toolkits/fl_editor
USE_REINPLACE= yes
USE_X_PREFIX= yes
-USE_MESA= yes
WRKSRC= ${WRKDIR}/${DISTNAME:S/-/-src-/}
MAKE_ARGS= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
@@ -47,6 +41,12 @@ OLD_FILES= Fl_Editor.h Fl_FancyEditor.h Fl_ProgressBox.h \
editor.h math.h strings.h vartypes.h wstrings.h
NEW_FILES= Fl_Editor.H editengine.h
+.include <bsd.port.pre.mk>
+
+.if (${OSVERSION} >= 500000)
+BROKEN= Does not build
+.endif
+
# Post-extract
#
@@ -66,7 +66,7 @@ pre-patch: copy-inc
copy-inc:
.for file in ${NEW_FILES}
- @${CP} ${PREFIX}/include/FL/${file} ${WRKSRC}/FL/
+ @${CP} ${X11BASE}/include/FL/${file} ${WRKSRC}/FL/
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/mysql-gui/files/patch-Animated_Icon.cc b/databases/mysql-gui/files/patch-Animated_Icon.cc
new file mode 100644
index 000000000000..1f6d7174128d
--- /dev/null
+++ b/databases/mysql-gui/files/patch-Animated_Icon.cc
@@ -0,0 +1,11 @@
+--- Animated_Icon.cc.orig Wed Sep 3 19:04:06 2003
++++ Animated_Icon.cc Wed Sep 3 19:04:14 2003
+@@ -1,7 +1,7 @@
+ #include <FL/Fl.H>
+ #include <FL/Animated_Icon.h>
+
+-Animated_Icon::Animated_Icon(int x, int y, int w, int h, const char *l = 0) :
++Animated_Icon::Animated_Icon(int x, int y, int w, int h, const char *l) :
+ Fl_Box(x, y, w, h, l)
+ {
+ first = current = 0;
diff --git a/databases/mysql-gui/files/patch-FL-Fl_Editor.H b/databases/mysql-gui/files/patch-FL-Fl_Editor.H
index f2fe5cdea533..b8d466e74b02 100644
--- a/databases/mysql-gui/files/patch-FL-Fl_Editor.H
+++ b/databases/mysql-gui/files/patch-FL-Fl_Editor.H
@@ -1,10 +1,10 @@
---- FL/Fl_Editor.H.orig Sat Aug 18 18:19:48 2001
-+++ FL/Fl_Editor.H Sat Aug 18 17:32:18 2001
-@@ -186,6 +186,7 @@
+--- FL/Fl_Editor.H.orig Mon Feb 3 01:53:09 2003
++++ FL/Fl_Editor.H Mon Feb 3 02:04:37 2003
+@@ -210,6 +210,7 @@
Fl_Color textcolor() const { return(Fl_Color)textcolor_; }
void textcolor(uchar n) { textcolor_ = n; }
- void LoadFrom(FILE *file) { engine->LoadFrom(file); ShowCursor(CURSOR_UNHIDE); SyncDisplay(); }
+ void LoadFrom(FILE *file) { engine->LoadFrom(file); engine->Command(MOVE_BOF); SyncDisplay(); ShowCursor(CURSOR_UNHIDE); }
+ void LoadSQL (const char *query) { engine->LoadSQL(query); ShowCursor(CURSOR_UNHIDE); SyncDisplay(); }
void SaveTo(FILE *file) { engine->SaveTo(file); }
- void LoadFrom(const char *buffer) { engine->LoadFrom(buffer); ShowCursor(CURSOR_UNHIDE); SyncDisplay(); }
+ void LoadFrom(const char *buffer) { engine->LoadFrom(buffer); SyncDisplay(); ShowCursor(CURSOR_UNHIDE); }
void SaveTo(char *buffer) { engine->SaveTo(buffer); }
diff --git a/databases/mysql-gui/files/patch-FL-Selection.H b/databases/mysql-gui/files/patch-FL-Selection.H
new file mode 100644
index 000000000000..7c9e2db4fe49
--- /dev/null
+++ b/databases/mysql-gui/files/patch-FL-Selection.H
@@ -0,0 +1,11 @@
+--- FL/Selection.H.orig Wed Sep 3 19:03:20 2003
++++ FL/Selection.H Wed Sep 3 19:03:27 2003
+@@ -17,7 +17,7 @@
+ private:
+ class SelectionRange
+ {
+- friend Selection;
++ friend class Selection;
+ private:
+ int mFrom;
+ int mTo;
diff --git a/databases/mysql-gui/files/patch-Fl_NSlider.cc b/databases/mysql-gui/files/patch-Fl_NSlider.cc
new file mode 100644
index 000000000000..d1484ffa24ba
--- /dev/null
+++ b/databases/mysql-gui/files/patch-Fl_NSlider.cc
@@ -0,0 +1,10 @@
+--- Fl_NSlider.cc.orig Mon Feb 3 02:17:30 2003
++++ Fl_NSlider.cc Mon Feb 3 02:16:37 2003
+@@ -9,6 +9,7 @@
+ * provided "as is" without express or implied warranty.
+ */
+ #include <FL/Fl_NSlider.H>
++#include <FL/Fl_Group.H>
+
+ static uchar isHoz = 0; //for image draw setup
+ static uchar r1, g1, b1; //for color ramp
diff --git a/databases/mysql-gui/files/patch-Makefile b/databases/mysql-gui/files/patch-Makefile
index 650f4728a62f..ca405a541f2d 100644
--- a/databases/mysql-gui/files/patch-Makefile
+++ b/databases/mysql-gui/files/patch-Makefile
@@ -1,6 +1,6 @@
--- Makefile.orig Wed Apr 11 21:12:20 2001
-+++ Makefile Sun Aug 19 03:41:52 2001
-@@ -1,27 +1,51 @@
++++ Makefile Mon Feb 3 18:19:49 2003
+@@ -1,27 +1,53 @@
# --------------------- M a c r o s -------------------------------
-CC = gcc
-CXX = g++
@@ -19,7 +19,8 @@
+BSD_INSTALL_PROGRAM?= install -C -c -s -o root -g wheel -m 555
+PTHREAD_CFLAGS?= -D_THREAD_SAFE
+PTHREAD_LIBS?= -pthread
-+CPPFLAGS= ${PTHREAD_CFLAGS} \
++CPPFLAGS+= ${PTHREAD_CFLAGS} \
++ -DFLTK_1_0_COMPAT \
+ -I. \
+ -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/mysql \
@@ -28,7 +29,8 @@
+ -L${LOCALBASE}/lib/mysql \
+ -L${X11BASE}/lib
+LIBS= -lsqlplus -lmysqlclient -lfleditor -lflvw -lfltk \
-+ -ljpeg -lGLU -lGL -lXext -lX11 -lintl -lm -lz ${PTHREAD_LIBS}
++ -ljpeg -lGLU -lGL -lXext -lX11 -lintl -lm -lz ${PTHREAD_LIBS} \
++ -lcipher
+
+TARGET= mysqlgui
+OBJS = Fl_Dir.o Fl_Envelope.o Fl_Envelope_Scroll.o \
diff --git a/databases/mysql-gui/files/patch-about.cc b/databases/mysql-gui/files/patch-about.cc
new file mode 100644
index 000000000000..a74d95c52605
--- /dev/null
+++ b/databases/mysql-gui/files/patch-about.cc
@@ -0,0 +1,10 @@
+--- about.cc.orig Wed Sep 3 19:04:33 2003
++++ about.cc Wed Sep 3 19:04:46 2003
+@@ -11,6 +11,7 @@
+ #include <stdio.h>
+ #endif
+ #include <string>
++using namespace std;
+ extern string c_info,s_info;
+ static Fl_Double_Window *xxx=(Fl_Double_Window *)0;
+ Fl_Window *splash=(Fl_Window *)0;
diff --git a/databases/mysql-gui/files/patch-bebac.h b/databases/mysql-gui/files/patch-bebac.h
new file mode 100644
index 000000000000..71e1c4776532
--- /dev/null
+++ b/databases/mysql-gui/files/patch-bebac.h
@@ -0,0 +1,10 @@
+--- bebac.h.orig Wed Apr 11 21:12:19 2001
++++ bebac.h Mon Feb 3 02:28:44 2003
+@@ -5,6 +5,7 @@
+ #include <FL/Fl.H>
+ #include <FL/Fl_Double_Window.H>
+ #include "client.h"
++#undef Success
+ #include <mysql++>
+ extern Connection *con;
+ extern void do_exit(Fl_Double_Window*, void*);
diff --git a/databases/mysql-gui/files/patch-client.h b/databases/mysql-gui/files/patch-client.h
new file mode 100644
index 000000000000..dce7f74f128f
--- /dev/null
+++ b/databases/mysql-gui/files/patch-client.h
@@ -0,0 +1,10 @@
+--- client.h.orig Wed Sep 3 19:05:06 2003
++++ client.h Wed Sep 3 19:05:21 2003
+@@ -45,6 +45,7 @@
+ typedef long ssize_t;
+ #endif
+ #include <vector>
++using namespace std;
+
+ class store_query {
+ public:
diff --git a/databases/mysql-gui/files/patch-db_tree.cc b/databases/mysql-gui/files/patch-db_tree.cc
new file mode 100644
index 000000000000..66944fd72954
--- /dev/null
+++ b/databases/mysql-gui/files/patch-db_tree.cc
@@ -0,0 +1,9 @@
+--- db_tree.cc.orig Wed Apr 11 21:12:19 2001
++++ db_tree.cc Mon Feb 3 02:32:09 2003
+@@ -28,6 +28,7 @@
+ #endif
+ #include <iomanip>
+ #include <string>
++#undef Success
+ #include <sqlplus.hh>
+ #include "client.h"
diff --git a/databases/mysql-gui/files/patch-do_sql.cc b/databases/mysql-gui/files/patch-do_sql.cc
new file mode 100644
index 000000000000..fad5479f5ff2
--- /dev/null
+++ b/databases/mysql-gui/files/patch-do_sql.cc
@@ -0,0 +1,25 @@
+--- do_sql.cc.orig Wed Apr 11 12:12:19 2001
++++ do_sql.cc Thu Sep 4 02:17:56 2003
+@@ -1,3 +1,5 @@
++#include <FL/Enumerations.H>
++#undef frame
+ #include <FL/Flv_Table.H>
+ #include <FL/Flve_Input.H>
+ #include <FL/Fl_Window.H>
+@@ -5,10 +7,15 @@
+ #include <FL/Fl_Pixmap.H>
+ #include <FL/Fl_Check_Button.H>
+ #include <FL/Fl_Round_Button.H>
++#define filename_setext fl_filename_setext
+ #include "bebac.h"
+ #include <sqlplus.hh>
+ #include <ctype.h>
+-extern string real_sql; extern enum ios::open_mode how_to_open; extern char *pass;
++#include <iostream>
++using namespace std;
++extern string real_sql;
++extern enum ios::open_mode how_to_open;
++extern char *pass;
+ #define depth 18
+ #define minmin 5
+ #define fontsize 14
diff --git a/databases/mysql-gui/files/patch-get_table.cc b/databases/mysql-gui/files/patch-get_table.cc
new file mode 100644
index 000000000000..6cb1cce50edb
--- /dev/null
+++ b/databases/mysql-gui/files/patch-get_table.cc
@@ -0,0 +1,10 @@
+--- get_table.cc.orig Wed Apr 11 21:12:25 2001
++++ get_table.cc Mon Feb 3 03:40:34 2003
+@@ -1,6 +1,7 @@
+ // generated by Fast Light User Interface Designer (fluid) version 1.00
+ #include <FL/Fl_Menu_.H>
+ #include "get_table.h"
++#undef Success
+ #include <sqlplus.hh>
+ #include "client.h"
+ #include <FL/Fl_Pixmap.H>
diff --git a/databases/mysql-gui/files/patch-gif.cc b/databases/mysql-gui/files/patch-gif.cc
new file mode 100644
index 000000000000..33276477b436
--- /dev/null
+++ b/databases/mysql-gui/files/patch-gif.cc
@@ -0,0 +1,17 @@
+--- gif.cc.orig Wed Apr 11 21:12:24 2001
++++ gif.cc Mon Feb 3 03:46:27 2003
+@@ -107,11 +107,11 @@
+ box(FL_NO_BOX); end(); show();
+ }
+ ~gif_window () {
+- if (p && p->data) {
+- char** real_data = (char**)(p->data);
++ if (p && p->alloc_data) {
++ char** real_data = (char**)(p->alloc_data);
+ for (int i = 0; i < 3; i++) delete[] real_data[i];
+ delete[] real_data;
+- p->data = 0; delete p; p = 0;
++ p->alloc_data = 0; delete p; p = 0;
+ }
+ if (linelength) free((void*)linelength);
+ }
diff --git a/databases/mysql-gui/files/patch-grant.cc b/databases/mysql-gui/files/patch-grant.cc
new file mode 100644
index 000000000000..6f9e3b8b4110
--- /dev/null
+++ b/databases/mysql-gui/files/patch-grant.cc
@@ -0,0 +1,10 @@
+--- grant.cc.orig Wed Apr 11 21:12:24 2001
++++ grant.cc Mon Feb 3 03:47:34 2003
+@@ -23,6 +23,7 @@
+ #endif
+ #include <iomanip>
+ #include <string>
++#undef Success
+ #include <sqlplus.hh>
+
+ #define REFRESH_GRANT 1 /* Refresh grant tables */
diff --git a/databases/mysql-gui/files/patch-main.cc b/databases/mysql-gui/files/patch-main.cc
index 5469c1db5ca6..56c7e93ebbe6 100644
--- a/databases/mysql-gui/files/patch-main.cc
+++ b/databases/mysql-gui/files/patch-main.cc
@@ -1,6 +1,20 @@
---- main.cc.orig Sat Aug 18 18:18:16 2001
-+++ main.cc Sat Aug 18 09:57:03 2001
-@@ -461,7 +461,7 @@
+--- main.cc.orig Wed Apr 11 21:12:20 2001
++++ main.cc Sun Dec 14 18:17:33 2003
+@@ -1,3 +1,4 @@
++#define filename_setext fl_filename_setext
+ #include "bebac.h"
+ #include "qsort.h"
+ #include "komande.h"
+@@ -18,7 +19,7 @@
+ extern "C" {
+ char *intern_filename(char *,const char *); extern char *home_dir;
+ char *fn_format(char *to,const char *name,const char *dsk,const char *form,int flag);
+- void load_defaults(const char *conf_file, const char **groups, int *argc, char ***argv);
++ int load_defaults(const char *conf_file, const char **groups, int *argc, char ***argv);
+ void free_defaults(char **argv);
+ void mysql_read_default_options(struct st_mysql_options *options, const char *filename,const char *group);
+ int strcasecmp(const char *,const char *);
+@@ -461,7 +462,7 @@
}
static void if_conn (void) {
@@ -9,7 +23,7 @@
try {
Query query = con->query(); if (ldb) {ddd=(string)ldb; ldb=(char*)ddd.c_str();}
query << "show databases";
-@@ -526,7 +526,7 @@
+@@ -526,7 +527,7 @@
tables.insert(tables.end(),xx);
}
qSortHelp (0, (size_t) tables.size(), Fcmp, Exchange);
diff --git a/databases/mysql-gui/files/patch-password.cc b/databases/mysql-gui/files/patch-password.cc
new file mode 100644
index 000000000000..1fb6843e60b6
--- /dev/null
+++ b/databases/mysql-gui/files/patch-password.cc
@@ -0,0 +1,10 @@
+--- password.cc.orig Wed Apr 11 21:12:25 2001
++++ password.cc Mon Feb 3 03:58:35 2003
+@@ -1,6 +1,7 @@
+ // generated by Fast Light User Interface Designer (fluid) version 1.00
+ #include <FL/Fl_Menu_.H>
+ #include "password.h"
++#undef Success
+ #include <sqlplus.hh>
+ #include "client.h"
+ #include <FL/Fl_Pixmap.H>
diff --git a/databases/mysql-gui/files/patch-process.cc b/databases/mysql-gui/files/patch-process.cc
new file mode 100644
index 000000000000..d377aba4e0f2
--- /dev/null
+++ b/databases/mysql-gui/files/patch-process.cc
@@ -0,0 +1,10 @@
+--- process.cc.orig Wed Apr 11 21:12:24 2001
++++ process.cc Mon Feb 3 04:00:41 2003
+@@ -1,6 +1,7 @@
+ // generated by Fast Light User Interface Designer (fluid) version 1.00
+
+ #include "process.h"
++#undef Success
+ #include <sqlplus.hh>
+ extern char *pass; extern int w7_x, w7_y, server_version; extern Connection *con;
+ #include <FL/Fl_Pixmap.H>
diff --git a/databases/mysql-gui/files/patch-single.cc b/databases/mysql-gui/files/patch-single.cc
index 595b52f2f999..b6e72c9b5f0b 100644
--- a/databases/mysql-gui/files/patch-single.cc
+++ b/databases/mysql-gui/files/patch-single.cc
@@ -1,9 +1,10 @@
---- single.cc.orig Sat Aug 18 18:18:16 2001
-+++ single.cc Sat Aug 18 18:17:24 2001
-@@ -1,16 +1,13 @@
+--- single.cc.orig Wed Apr 11 21:12:23 2001
++++ single.cc Mon Feb 3 04:05:55 2003
+@@ -1,16 +1,14 @@
// generated by Fast Light User Interface Designer (fluid) version 1.00
-
#include <client.h>
++#undef Success
#include <sqlplus.hh>
+#undef Time
//
@@ -17,4 +18,3 @@
-#include <FL/editor.h>
extern Connection *con;
-
diff --git a/databases/mysql-gui/files/patch-status.cc b/databases/mysql-gui/files/patch-status.cc
new file mode 100644
index 000000000000..ee7f27bcc9c8
--- /dev/null
+++ b/databases/mysql-gui/files/patch-status.cc
@@ -0,0 +1,8 @@
+--- status.cc.orig Wed Apr 11 21:12:24 2001
++++ status.cc Mon Feb 3 04:10:54 2003
+@@ -1,4 +1,5 @@
+ #include "status.h"
++#undef Success
+ #include <sqlplus.hh>
+ extern char *pass; extern int w8_x, w8_y;
+ #include <FL/Fl_Pixmap.H>