aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-23 17:20:08 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-23 17:20:08 +0000
commiteb3241498ccf01ed1506221d3c4d93683d62be1e (patch)
treef309e380c5977245f9ba6961e26ef71f20ed4c8c /databases
parent6666951b0a2f5f929527fb521ff9e4b99c472901 (diff)
downloadports-eb3241498ccf01ed1506221d3c4d93683d62be1e.tar.gz
ports-eb3241498ccf01ed1506221d3c4d93683d62be1e.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/py-redis/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/databases/py-redis/Makefile b/databases/py-redis/Makefile
index 4153bb046c89..0307ff92e514 100644
--- a/databases/py-redis/Makefile
+++ b/databases/py-redis/Makefile
@@ -3,6 +3,7 @@
PORTNAME= redis
PORTVERSION= 2.10.1
+PORTREVISION= 1
CATEGORIES= databases python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,10 +12,8 @@ COMMENT= Python client for Redis key-value store
LICENSE= MIT
-OPTIONS_DEFINE= HIREDIS HTMLDOCS
+OPTIONS_DEFINE= DOCS HIREDIS
HIREDIS_DESC= High performance response parser (via hiredis)
-HTMLDOCS_DESC= Build and install API docs using Sphinx
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
DOCGEN= ${LOCALBASE}/bin/sphinx-apidoc
HIREDIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hiredis>0:${PORTSDIR}/databases/py-hiredis
@@ -22,6 +21,7 @@ HIREDIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hiredis>0:${PORTSDIR}/databases/py-h
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
+PYTHON_CONCURRENT_INSTALL=yes
USE_GITHUB= yes
GH_ACCOUNT= andymccurdy
@@ -29,10 +29,8 @@ GH_PROJECT= ${PORTNAME}-py
GH_COMMIT= e7589d7
.include <bsd.port.options.mk>
-.if !empty(PORT_OPTIONS:MHTMLDOCS)
-. if empty(PORT_OPTIONS:MDOCS)
-IGNORE= you cannot build documentation with DOCS option disabled
-. endif
+
+.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sphinx>0:${PORTSDIR}/textproc/py-sphinx
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MarkupSafe>0:${PORTSDIR}/textproc/py-MarkupSafe
PORTDOCS= *
@@ -43,7 +41,7 @@ regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
post-build:
-.if ${PORT_OPTIONS:MHTMLDOCS}
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_CMD} "Building documentation"
@cd ${WRKSRC} && ${DOCGEN} -o apidocs -F -H 'redis-py' \
-V ${PORTVERSION} -A '2014, Andy McCurdy, Mahdi Yusuf' \
@@ -53,7 +51,7 @@ post-build:
.endif
post-install:
-.if ${PORT_OPTIONS:MHTMLDOCS}
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${RM} ${WRKSRC}/apidocs/_build/html/.buildinfo
@cd ${WRKSRC}/apidocs/_build/html && ${COPYTREE_SHARE} . \