aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
authorBabak Farrokhi <farrokhi@FreeBSD.org>2018-07-07 06:34:04 +0000
committerBabak Farrokhi <farrokhi@FreeBSD.org>2018-07-07 06:34:04 +0000
commitfff981e77f48dca40425db2d55dbc98dbfb94f3a (patch)
tree1267bb7dc7058b44b6a7704eb7599568142528e9 /databases
parentbff5d83e44cf7ff161f8372e97776f35c091ddef (diff)
downloadports-fff981e77f48dca40425db2d55dbc98dbfb94f3a.tar.gz
ports-fff981e77f48dca40425db2d55dbc98dbfb94f3a.zip
Notes
Diffstat (limited to 'databases')
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-aiopg/Makefile27
-rw-r--r--databases/py-aiopg/distinfo3
-rw-r--r--databases/py-aiopg/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index b65606918ecd..dc3255ed688d 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -773,6 +773,7 @@
SUBDIR += py-PyGreSQL
SUBDIR += py-Pyrseas
SUBDIR += py-agate-sql
+ SUBDIR += py-aiopg
SUBDIR += py-aioredis
SUBDIR += py-alembic
SUBDIR += py-apsw
diff --git a/databases/py-aiopg/Makefile b/databases/py-aiopg/Makefile
new file mode 100644
index 000000000000..f189ca8e25a1
--- /dev/null
+++ b/databases/py-aiopg/Makefile
@@ -0,0 +1,27 @@
+# Created by: Babak Farrokhi <farrokhi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= aiopg
+PORTVERSION= 0.14.0
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= farrokhi@FreeBSD.org
+COMMENT= Python library for accessing PostgreSQL database using asyncio
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+OPTIONS_DEFINE= DOCS
+
+USES= pgsql:9.2+ python:3.4+
+USE_PYTHON= autoplist concurrent distutils setuptools
+
+PORTDOCS= PKG-INFO README.rst CHANGES.txt
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/databases/py-aiopg/distinfo b/databases/py-aiopg/distinfo
new file mode 100644
index 000000000000..ec740c38ee65
--- /dev/null
+++ b/databases/py-aiopg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530944962
+SHA256 (aiopg-0.14.0.tar.gz) = 7dee52e0fa4697bace62d39180df96e94a328ee96aa211c8e93c346b8ffd1bcc
+SIZE (aiopg-0.14.0.tar.gz) = 27071
diff --git a/databases/py-aiopg/pkg-descr b/databases/py-aiopg/pkg-descr
new file mode 100644
index 000000000000..b25d64da067b
--- /dev/null
+++ b/databases/py-aiopg/pkg-descr
@@ -0,0 +1,5 @@
+aiopg is a library for accessing a PostgreSQL database from the asyncio
+(PEP-3156/tulip) framework. It wraps asynchronous features of the Psycopg
+database driver.
+
+WWW: https://github.com/aio-libs/aiopg