aboutsummaryrefslogtreecommitdiff
path: root/deskutils/ausweisapp2
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-03-12 14:08:55 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-03-12 14:08:55 +0000
commit058df51f0167647a64710b917bd53139134a4516 (patch)
tree42c1492ae6e4c4f946c031acf4f436de341009ba /deskutils/ausweisapp2
parent903227db5db7c150f3f514e106904dd0d7545250 (diff)
downloadports-058df51f0167647a64710b917bd53139134a4516.tar.gz
ports-058df51f0167647a64710b917bd53139134a4516.zip
Use libhttp_parser from ports instead of the bundled one
While here, remove unused variables. PR: 243794 Reported by: André Klitzing (upstream)
Notes
Notes: svn path=/head/; revision=528293
Diffstat (limited to 'deskutils/ausweisapp2')
-rw-r--r--deskutils/ausweisapp2/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/deskutils/ausweisapp2/Makefile b/deskutils/ausweisapp2/Makefile
index b17b32295adb..60e9229017de 100644
--- a/deskutils/ausweisapp2/Makefile
+++ b/deskutils/ausweisapp2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= ausweisapp2
DISTVERSION= 1.20.0
+PORTREVISION= 1
CATEGORIES= deskutils security
MAINTAINER= freebsd@sysctl.cz
@@ -13,12 +14,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= pcsc-lite>0:devel/pcsc-lite
-LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
+LIB_DEPENDS= libhttp_parser.so:www/http-parser \
+ libpcsclite.so:devel/pcsc-lite
USES= cmake pkgconfig qmake qt:5 ssl
USE_GITHUB= yes
GH_ACCOUNT= Governikus
-GH_PROJECT= ${_PROGRAM_NAME}
+GH_PROJECT= AusweisApp2
USE_QT= buildtools concurrent core declarative gui linguisttools \
network quickcontrols2 svg websockets widgets
@@ -26,6 +28,4 @@ USE_QT= buildtools concurrent core declarative gui linguisttools \
CMAKE_ARGS= -DVENDOR=${PORTNAME}
MAKE_ENV= DESTDIR=${STAGEDIR}
-_PROGRAM_NAME= AusweisApp2
-
.include <bsd.port.mk>