aboutsummaryrefslogtreecommitdiff
path: root/deskutils/ausweisapp2
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-04-11 05:00:37 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-04-11 05:00:37 +0000
commitbff0879784e3857bfffd0c7bdad3fcd0f500c61b (patch)
tree8e4543031f3d4333b671086873c7ccea26570a7d /deskutils/ausweisapp2
parent11e77a62dd3e65bd52d2eeaf6393e9b3de3c2d68 (diff)
downloadports-bff0879784e3857bfffd0c7bdad3fcd0f500c61b.tar.gz
ports-bff0879784e3857bfffd0c7bdad3fcd0f500c61b.zip
deskutils/ausweisapp2: Fix build on FreeBSD 11.3
CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:146 (message): Could NOT find OpenSSL, try to set the path to OpenSSL root folder in the system variable OPENSSL_ROOT_DIR: Found unsuitable version "1.0.2s", but required is at least "1.1" (found /usr/lib/libcrypto.so) Call Stack (most recent call first): /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:391 (_FPHSA_FAILURE_MESSAGE) /usr/local/share/cmake/Modules/FindOpenSSL.cmake:447 (find_package_handle_standard_args) cmake/Libraries.cmake:71 (FIND_PACKAGE) CMakeLists.txt:145 (INCLUDE) While here remove unnecessary qt5-buildtools and qt5-linguisttools run dependencies. PR: 245088 Approved by: freebsd@sysctl.cz (maintainer)
Notes
Notes: svn path=/head/; revision=531394
Diffstat (limited to 'deskutils/ausweisapp2')
-rw-r--r--deskutils/ausweisapp2/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/deskutils/ausweisapp2/Makefile b/deskutils/ausweisapp2/Makefile
index 97058b9e13f1..9bf384855b65 100644
--- a/deskutils/ausweisapp2/Makefile
+++ b/deskutils/ausweisapp2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ausweisapp2
DISTVERSION= 1.20.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils security
MAINTAINER= freebsd@sysctl.cz
@@ -21,11 +21,17 @@ USES= cmake compiler:c++17-lang pkgconfig qmake qt:5 ssl
USE_GITHUB= yes
GH_ACCOUNT= Governikus
GH_PROJECT= AusweisApp2
-USE_QT= buildtools concurrent core declarative gui linguisttools \
- network quickcontrols2 svg websockets widgets
+USE_QT= concurrent core declarative gui network quickcontrols2 svg \
+ websockets widgets buildtools_build linguisttools_build
# The VENDOR variable controls the name of the directory in ${PREFIX}/share.
CMAKE_ARGS= -DVENDOR=${PORTNAME}
MAKE_ENV= DESTDIR=${STAGEDIR}
+.include <bsd.port.options.mk>
+
+.if ${SSL_DEFAULT} == base && ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085
+CMAKE_ON+= FORCE_LEGACY_OPENSSL
+.endif
+
.include <bsd.port.mk>