aboutsummaryrefslogtreecommitdiff
path: root/deskutils/cairo-dock-plugins
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-11-03 19:14:16 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-11-03 19:14:16 +0000
commitf12cf1f8d22309ec29b1333fa858000dade14e12 (patch)
treeb51acdfe0dec856f0c06bb874d427f5c25f435ce /deskutils/cairo-dock-plugins
parent7c805bf4df08d7742686c17e345a5e739c1d3c1b (diff)
downloadports-f12cf1f8d22309ec29b1333fa858000dade14e12.tar.gz
ports-f12cf1f8d22309ec29b1333fa858000dade14e12.zip
Notes
Diffstat (limited to 'deskutils/cairo-dock-plugins')
-rw-r--r--deskutils/cairo-dock-plugins/Makefile2
-rw-r--r--deskutils/cairo-dock-plugins/files/patch-CMakeLists.txt22
2 files changed, 24 insertions, 0 deletions
diff --git a/deskutils/cairo-dock-plugins/Makefile b/deskutils/cairo-dock-plugins/Makefile
index 652d8ba27417..ef921dc9ae9a 100644
--- a/deskutils/cairo-dock-plugins/Makefile
+++ b/deskutils/cairo-dock-plugins/Makefile
@@ -91,6 +91,8 @@ KEYBOARD_INDICATOR_LIB_DEPENDS= libexif.so:graphics/libexif \
libxklavier.so:x11/libxklavier
KEYBOARD_INDICATOR_CMAKE_BOOL= enable-keyboard-indicator
+# libetpan 1.9.4 replaces libetpan-config with libetpan.pc
+MAIL_BUILD_DEPENDS= libetpan>=1.9.4:mail/libetpan
MAIL_LIB_DEPENDS= libetpan.so:mail/libetpan
MAIL_CMAKE_BOOL= enable-mail
diff --git a/deskutils/cairo-dock-plugins/files/patch-CMakeLists.txt b/deskutils/cairo-dock-plugins/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d82a6bc0f7f7
--- /dev/null
+++ b/deskutils/cairo-dock-plugins/files/patch-CMakeLists.txt
@@ -0,0 +1,22 @@
+--- CMakeLists.txt.orig 2015-02-19 16:13:47 UTC
++++ CMakeLists.txt
+@@ -978,9 +978,8 @@ set (with_mail no)
+ # find the compilation flags
+ enable_if_not_defined (enable-mail)
+ if (enable-mail)
+- find_program (LIBETPAN_CONFIG_EXECUTABLE libetpan-config)
+ execute_process(
+- COMMAND ${LIBETPAN_CONFIG_EXECUTABLE} --cflags
++ COMMAND pkg-config libetpan --cflags
+ OUTPUT_VARIABLE MAIL_PACKAGE_CFLAGS)
+ if (NOT "${MAIL_PACKAGE_CFLAGS}" STREQUAL "" AND NOT "${MAIL_PACKAGE_CFLAGS}" STREQUAL "\n") # if there is a problem with the previous, we don't want to have a lot of errors
+ STRING (REGEX REPLACE "\n" "" TMP_VARIABLE "${MAIL_PACKAGE_CFLAGS}") # to not skip the last option
+@@ -993,7 +992,7 @@ if (enable-mail)
+ endif()
+ # find the link flags
+ execute_process(
+- COMMAND ${LIBETPAN_CONFIG_EXECUTABLE} --libs
++ COMMAND pkg-config libetpan --libs
+ OUTPUT_VARIABLE MAIL_PACKAGE_LIBS)
+ if (NOT "${MAIL_PACKAGE_LIBS}" STREQUAL "")
+ STRING (REGEX REPLACE "\n" "" MAIL_PACKAGE_LIBS "${MAIL_PACKAGE_LIBS}")