aboutsummaryrefslogtreecommitdiff
path: root/deskutils/cairo-dock
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2012-04-09 19:26:39 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2012-04-09 19:26:39 +0000
commit6033e5285f82aa7e60cfa9f36dd2d79f0666b536 (patch)
tree43f97254d2d3d77eec9fb3ff46c187e1f7668284 /deskutils/cairo-dock
parent6346574009b305284ca42fa87eea3b36138b9b2a (diff)
downloadports-6033e5285f82aa7e60cfa9f36dd2d79f0666b536.tar.gz
ports-6033e5285f82aa7e60cfa9f36dd2d79f0666b536.zip
Fix a number of bugs related to (default) directory locations.
PR: 165925 Submitted by: maintainer (fidaj@ukr.net) Feature safe: yes
Notes
Notes: svn path=/head/; revision=294439
Diffstat (limited to 'deskutils/cairo-dock')
-rw-r--r--deskutils/cairo-dock/Makefile16
-rw-r--r--deskutils/cairo-dock/files/patch-cairo-dock19
-rw-r--r--deskutils/cairo-dock/files/patch-cairo-dock-applet-facility.c18
-rw-r--r--deskutils/cairo-dock/files/patch-cairo-dock-class-manager.c19
-rw-r--r--deskutils/cairo-dock/files/patch-cairo-dock-gui-factory.c11
-rw-r--r--deskutils/cairo-dock/files/patch-cairo-dock-menu.c25
-rw-r--r--deskutils/cairo-dock/files/patch-cairo-dock-package-theme (renamed from deskutils/cairo-dock/files/patch-fetch)10
-rw-r--r--deskutils/cairo-dock/files/patch-cairo-dock_theme-creator.sh8
8 files changed, 111 insertions, 15 deletions
diff --git a/deskutils/cairo-dock/Makefile b/deskutils/cairo-dock/Makefile
index 5ac90acabb35..957c24f4ec7a 100644
--- a/deskutils/cairo-dock/Makefile
+++ b/deskutils/cairo-dock/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cairo-dock
DISTVERSION= 2.3.0~3
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://launchpadlibrarian.net/73753213/
@@ -17,6 +18,7 @@ LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo \
curl.6:${PORTSDIR}/ftp/curl \
dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
USE_GETTEXT= yes
@@ -32,17 +34,5 @@ MANCOMPRESSED= yes
post-patch:
@${REINPLACE_CMD} -e 's|libdir}/pkgconfig|prefix}/libdata/pkgconfig| ; s|datadir}/man|prefix}/man|' \
${WRKSRC}/CMakeLists.txt ${WRKSRC}/src/gldit/CMakeLists.txt
- ${REINPLACE_CMD} -e 's,/usr,${PREFIX},g' \
- ${WRKSRC}/src/gldit/cairo-dock-gui-factory.c
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/include/cairo/cairo-glitz.h)
-# Glitz support can only be enabled if cairo is built with glitz support
-CONFIGURE_ARGS+=--enable-glitz
-LIB_DEPENDS+= glitz:${PORTSDIR}/graphics/glitz
-.else
-CONFIGURE_ARGS+=--disable-glitz
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/deskutils/cairo-dock/files/patch-cairo-dock b/deskutils/cairo-dock/files/patch-cairo-dock
new file mode 100644
index 000000000000..6dffcd6826e7
--- /dev/null
+++ b/deskutils/cairo-dock/files/patch-cairo-dock
@@ -0,0 +1,19 @@
+--- data/cairo-dock.orig 2012-03-10 14:08:41.784016085 +0200
++++ data/cairo-dock 2012-03-10 14:09:03.014030514 +0200
+@@ -2,12 +2,12 @@
+ section="Applications/System" \
+ hints="dock" \
+ title="Cairo-Dock (no OpenGL)" \
+- icon="/usr/share/pixmaps/cairo-dock.svg" \
+- command="/usr/bin/cairo-dock -c"
++ icon="/usr/local/share/pixmaps/cairo-dock.svg" \
++ command="/usr/local/bin/cairo-dock -c"
+
+ ?package(cairo-dock):needs="X11" \
+ section="Applications/System" \
+ hints="dock" \
+ title="GLX-Dock (Cairo-Dock with OpenGL)" \
+- icon="/usr/share/pixmaps/cairo-dock.svg" \
+- command="/usr/bin/cairo-dock -o"
++ icon="/usr/local/share/pixmaps/cairo-dock.svg" \
++ command="/usr/local/bin/cairo-dock -o"
diff --git a/deskutils/cairo-dock/files/patch-cairo-dock-applet-facility.c b/deskutils/cairo-dock/files/patch-cairo-dock-applet-facility.c
new file mode 100644
index 000000000000..35643d034053
--- /dev/null
+++ b/deskutils/cairo-dock/files/patch-cairo-dock-applet-facility.c
@@ -0,0 +1,18 @@
+--- src/gldit/cairo-dock-applet-facility.c.orig 2012-04-08 11:31:10.000000000 +0300
++++ src/gldit/cairo-dock-applet-facility.c 2012-04-08 11:32:21.000000000 +0300
+@@ -350,13 +350,13 @@
+
+ GError *erreur = NULL;
+ gchar *cSoundCommand = NULL;
+- if (g_file_test ("/usr/bin/paplay", G_FILE_TEST_EXISTS))
++ if (g_file_test ("/usr/local/bin/paplay", G_FILE_TEST_EXISTS))
+ cSoundCommand = g_strdup_printf("paplay --client-name=cairo-dock \"%s\"", cSoundPath);
+
+ else if (g_file_test ("/usr/bin/aplay", G_FILE_TEST_EXISTS))
+ cSoundCommand = g_strdup_printf("aplay \"%s\"", cSoundPath);
+
+- else if (g_file_test ("/usr/bin/play", G_FILE_TEST_EXISTS))
++ else if (g_file_test ("/usr/local/bin/play", G_FILE_TEST_EXISTS))
+ cSoundCommand = g_strdup_printf("play \"%s\"", cSoundPath);
+
+
diff --git a/deskutils/cairo-dock/files/patch-cairo-dock-class-manager.c b/deskutils/cairo-dock/files/patch-cairo-dock-class-manager.c
new file mode 100644
index 000000000000..4d0d6619a23a
--- /dev/null
+++ b/deskutils/cairo-dock/files/patch-cairo-dock-class-manager.c
@@ -0,0 +1,19 @@
+--- src/gldit/cairo-dock-class-manager.c.orig 2012-03-10 14:05:52.663999155 +0200
++++ src/gldit/cairo-dock-class-manager.c 2012-03-10 14:06:17.963989866 +0200
+@@ -1189,13 +1189,13 @@
+ {
+ gboolean bFound = TRUE;
+ GString *sDesktopFilePath = g_string_new ("");
+- g_string_printf (sDesktopFilePath, "/usr/share/applications/%s.desktop", cClass);
++ g_string_printf (sDesktopFilePath, "/usr/local/share/applications/%s.desktop", cClass);
+ if (! g_file_test (sDesktopFilePath->str, G_FILE_TEST_EXISTS))
+ {
+- g_string_printf (sDesktopFilePath, "/usr/share/applications/xfce4/%s.desktop", cClass);
++ g_string_printf (sDesktopFilePath, "/usr/local/share/applications/xfce4/%s.desktop", cClass);
+ if (! g_file_test (sDesktopFilePath->str, G_FILE_TEST_EXISTS))
+ {
+- g_string_printf (sDesktopFilePath, "/usr/share/applications/kde4/%s.desktop", cClass);
++ g_string_printf (sDesktopFilePath, "/usr/local/share/applications/kde4/%s.desktop", cClass);
+ if (! g_file_test (sDesktopFilePath->str, G_FILE_TEST_EXISTS))
+ {
+ bFound = FALSE;
diff --git a/deskutils/cairo-dock/files/patch-cairo-dock-gui-factory.c b/deskutils/cairo-dock/files/patch-cairo-dock-gui-factory.c
new file mode 100644
index 000000000000..1b084f8c94d2
--- /dev/null
+++ b/deskutils/cairo-dock/files/patch-cairo-dock-gui-factory.c
@@ -0,0 +1,11 @@
+--- src/gldit/cairo-dock-gui-factory.c.orig 2011-06-19 02:27:14.000000000 +0300
++++ src/gldit/cairo-dock-gui-factory.c 2012-03-10 14:01:45.373972001 +0200
+@@ -2429,7 +2429,7 @@
+ gchar *cUserPath = g_strdup_printf ("%s/.icons", g_getenv ("HOME"));
+ const gchar *path[3];
+ path[0] = (const gchar *)cUserPath;
+- path[1] = "/usr/share/icons";
++ path[1] = "/usr/local/share/icons";
+ path[2] = NULL;
+
+ GHashTable *pHashTable = _cairo_dock_build_icon_themes_list (path);
diff --git a/deskutils/cairo-dock/files/patch-cairo-dock-menu.c b/deskutils/cairo-dock/files/patch-cairo-dock-menu.c
new file mode 100644
index 000000000000..ac4a480fcee7
--- /dev/null
+++ b/deskutils/cairo-dock/files/patch-cairo-dock-menu.c
@@ -0,0 +1,25 @@
+--- src/cairo-dock-menu.c.orig 2012-03-10 14:07:34.504001097 +0200
++++ src/cairo-dock-menu.c 2012-03-10 14:07:43.434017412 +0200
+@@ -293,7 +293,7 @@
+ return ;
+ }
+ }
+- gchar *cCommand = g_strdup_printf ("cp '/usr/share/applications/cairo-dock%s.desktop' '%s'", (g_bForceCairo ? "-cairo" : ""), cCairoAutoStartDirPath);
++ gchar *cCommand = g_strdup_printf ("cp '/usr/local/share/applications/cairo-dock%s.desktop' '%s'", (g_bForceCairo ? "-cairo" : ""), cCairoAutoStartDirPath);
+ int r = system (cCommand);
+ g_free (cCommand);
+ g_free (cCairoAutoStartDirPath);
+@@ -861,11 +861,11 @@
+
+ // on trouve le .desktop du programme.
+ cd_debug ("%s (%s)\n", __func__, icon->cClass);
+- gchar *cDesktopFilePath = g_strdup_printf ("/usr/share/applications/%s.desktop", icon->cClass);
++ gchar *cDesktopFilePath = g_strdup_printf ("/usr/local/share/applications/%s.desktop", icon->cClass);
+ if (! g_file_test (cDesktopFilePath, G_FILE_TEST_EXISTS)) // on n'a pas trouve la, on cherche chez KDE.
+ {
+ g_free (cDesktopFilePath);
+- cDesktopFilePath = g_strdup_printf ("/usr/share/applications/kde4/%s.desktop", icon->cClass);
++ cDesktopFilePath = g_strdup_printf ("/usr/local/share/applications/kde4/%s.desktop", icon->cClass);
+ if (! g_file_test (cDesktopFilePath, G_FILE_TEST_EXISTS)) // toujours rien, on utilise locate.
+ {
+ g_free (cDesktopFilePath);
diff --git a/deskutils/cairo-dock/files/patch-fetch b/deskutils/cairo-dock/files/patch-cairo-dock-package-theme
index 870230895007..66fe4f726749 100644
--- a/deskutils/cairo-dock/files/patch-fetch
+++ b/deskutils/cairo-dock/files/patch-cairo-dock-package-theme
@@ -1,5 +1,11 @@
---- cairo-dock-package-theme.orig 2010-12-11 01:37:14.000000000 +0200
-+++ cairo-dock-package-theme 2010-12-11 01:37:33.000000000 +0200
+--- cairo-dock-package-theme.orig 2011-06-19 02:27:14.000000000 +0300
++++ cairo-dock-package-theme 2012-03-10 13:56:42.504012481 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/local/bin/bash
+
+ # Packager for Cairo-Dock
+ #
@@ -125,7 +125,7 @@
if test "x${theme}" != "x"; then
#\__________ On cherche si ce theme est un theme officiel ou non.
diff --git a/deskutils/cairo-dock/files/patch-cairo-dock_theme-creator.sh b/deskutils/cairo-dock/files/patch-cairo-dock_theme-creator.sh
new file mode 100644
index 000000000000..a30d5ff0a294
--- /dev/null
+++ b/deskutils/cairo-dock/files/patch-cairo-dock_theme-creator.sh
@@ -0,0 +1,8 @@
+--- cairo-dock_theme-creator.sh.orig 2012-03-10 13:56:15.674011880 +0200
++++ cairo-dock_theme-creator.sh 2012-03-10 13:56:23.814030235 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/local/bin/bash
+
+ # Theme creator for Cairo-Dock
+ #