aboutsummaryrefslogtreecommitdiff
path: root/deskutils/calibre/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2019-10-05 15:37:43 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2019-10-05 15:37:43 +0000
commit36db4209cdf7f111122f942bc936cf3dd00b4e26 (patch)
treeccd6b8fa306717c61f50aaa22d138decab69aa9b /deskutils/calibre/Makefile
parent89727325bf7cc7104d4674d543e0046e8dbc4021 (diff)
downloadports-36db4209cdf7f111122f942bc936cf3dd00b4e26.tar.gz
ports-36db4209cdf7f111122f942bc936cf3dd00b4e26.zip
- Update calibre to 4.0.0
- Sort plist using C locale - Import upstream patch to fix regression in this release [1] Obtained from: https://github.com/kovidgoyal/calibre/commit/e0630cadd345a1b368a2f552cbae08ac1e4da3c6 [1]
Notes
Notes: svn path=/head/; revision=513829
Diffstat (limited to 'deskutils/calibre/Makefile')
-rw-r--r--deskutils/calibre/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index 9825b666e1d2..6462bf4420f9 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= calibre
-PORTVERSION= 3.48.0
-PORTREVISION= 2
+PORTVERSION= 4.0.0
CATEGORIES= deskutils python
MASTER_SITES= http://download.calibre-ebook.com/${PORTVERSION}/
@@ -19,7 +18,8 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libicudata.so:devel/icu \
libpodofo.so:graphics/podofo \
libmtp.so:multimedia/libmtp \
- libfreetype.so:print/freetype2
+ libfreetype.so:print/freetype2 \
+ libhunspell-1.7.so:textproc/hunspell
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
@@ -51,7 +51,7 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils \
USES= desktop-file-utils gettext-runtime gl gnome localbase:ldflags pkgconfig \
python:2.7 pyqt:5 qt:5 shared-mime-info shebangfix ssl tar:xz
USE_RC_SUBR= calibre
-USE_PYQT= core gui network sip svg webkit widgets webkitwidgets xmlpatterns
+USE_PYQT= core gui network sip svg webengine widgets xmlpatterns
USE_QT= buildtools_build core dbus gui qmake_build widgets
USE_GL= egl gl
USE_GNOME= glib20