aboutsummaryrefslogtreecommitdiff
path: root/deskutils/calibre
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-03-24 19:54:57 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-03-24 19:54:57 +0000
commit1bf9457272318a99eb550ee7603ef85903c36cea (patch)
tree30969701cc82a93abc61c62dd66cf03666bbe585 /deskutils/calibre
parentb4990c3eb608adca7aab250206f47b154ccd7711 (diff)
downloadports-1bf9457272318a99eb550ee7603ef85903c36cea.tar.gz
ports-1bf9457272318a99eb550ee7603ef85903c36cea.zip
Convert the tree to use PY_PILLOW
With hat: portmgr Originally submitted by: kai
Notes
Notes: svn path=/head/; revision=529063
Diffstat (limited to 'deskutils/calibre')
-rw-r--r--deskutils/calibre/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index 2675b4bc6c0d..72127ed97cc9 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -29,7 +29,8 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVO
${PYTHON_PKGNAMEPREFIX}apsw>=0:databases/py-apsw@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}msgpack>=0.3:devel/py-msgpack@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}regex>=0:textproc/py-regex@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}html5-parser>=0.4.3:www/py-html5-parser@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}html5-parser>=0.4.3:www/py-html5-parser@${PY_FLAVOR} \
+ ${PY_PILLOW}
RUN_DEPENDS= xdg-open:devel/xdg-utils \
${PYTHON_PKGNAMEPREFIX}css-parser>=1.0.4:www/py-css-parser@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dnspython>=0:dns/py-dnspython@${PY_FLAVOR} \
@@ -47,6 +48,7 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils \
${PYTHON_PKGNAMEPREFIX}markdown>=0:textproc/py-markdown@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}html5-parser>=0.4.3:www/py-html5-parser@${PY_FLAVOR} \
+ ${PY_PILLOW} \
pdftohtml:graphics/poppler-utils
USES= desktop-file-utils gettext-runtime gl gnome localbase:ldflags \
@@ -85,16 +87,12 @@ OPTIONS_SINGLE_PYTHON= PYTHON2 PYTHON3
OPTIONS_DEFAULT= PYTHON2
OPTINS_SUB= yes
-PYTHON2_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow6>=0:graphics/py-pillow6@${PY_FLAVOR}
-PYTHON2_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow6>=0:graphics/py-pillow6@${PY_FLAVOR}
PYTHON2_USES= python:2.7
PYTHON2_VARS= PYTHON_BIN=${LOCALBASE}/bin/python2 \
DEPRECATED="Uses deprecated version of python" \
EXPIRATION_DATE=2020-09-15
PYTHON2_PLIST_SUB= SODIR=""
-PYTHON3_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
-PYTHON3_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
PYTHON3_USES= python:3.5+
PYTHON3_VARS= PYTHON_BIN=${LOCALBASE}/bin/python3
PYTHON3_MAKE_ENV= CALIBRE_PY3_PORT=1