aboutsummaryrefslogtreecommitdiff
path: root/deskutils/clipit
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-01-25 06:33:14 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-01-25 06:33:14 +0000
commit6247f3d8844ec93ead228d47008f40b9a2a9f389 (patch)
treef86c75ee3d1a0f13e0511a40601b816e2efdaa80 /deskutils/clipit
parente6ba99ed6ed0592bd14ee1db2fa93b92369b1f5d (diff)
downloadports-6247f3d8844ec93ead228d47008f40b9a2a9f389.tar.gz
ports-6247f3d8844ec93ead228d47008f40b9a2a9f389.zip
- add new port: deskutils/clipit
ClipIt is a lightweight GTK+ clipboard manager forked from parcellite. WWW: http://clipit.rspwn.com/ PR: 175483 Submitted by: jrm@ftfl.ca
Notes
Notes: svn path=/head/; revision=310967
Diffstat (limited to 'deskutils/clipit')
-rw-r--r--deskutils/clipit/Makefile40
-rw-r--r--deskutils/clipit/distinfo2
-rw-r--r--deskutils/clipit/pkg-descr3
-rw-r--r--deskutils/clipit/pkg-plist64
4 files changed, 109 insertions, 0 deletions
diff --git a/deskutils/clipit/Makefile b/deskutils/clipit/Makefile
new file mode 100644
index 000000000000..529571bbb922
--- /dev/null
+++ b/deskutils/clipit/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= clipit
+PORTVERSION= 1.4.2
+CATEGORIES= deskutils
+MASTER_SITES= SF/gtkclipit/Version%201
+
+MAINTAINER= jrm@ftfl.ca
+COMMENT= Lightweight GTK+ clipboard manager forked from parcellite
+
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20
+
+OPTIONS_DEFINE= NLS XDOTOOL
+XDOTOOL_DESC= Automatic paste functionality
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+CONFIGURE_ARGS+= --localedir=${LOCALBASE}/share/locale
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MXDOTOOL}
+RUN_DEPENDS+= xdotool:${PORTSDIR}/x11/xdotool
+.endif
+
+MAN1= clipit.1
+
+post-patch-script:
+ @${REINPLACE_CMD} -e 's|^itlocaledir =.*|itlocaledir = $$(datarootdir)/locale|' \
+ ${WRKSRC}/po/Makefile.in.in
+
+.include <bsd.port.mk>
diff --git a/deskutils/clipit/distinfo b/deskutils/clipit/distinfo
new file mode 100644
index 000000000000..d572bc4f758f
--- /dev/null
+++ b/deskutils/clipit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (clipit-1.4.2.tar.gz) = 6a63c7c4c39b423a266907e5b76f7d16301b164437dc7635cf25ace730b23c4b
+SIZE (clipit-1.4.2.tar.gz) = 284614
diff --git a/deskutils/clipit/pkg-descr b/deskutils/clipit/pkg-descr
new file mode 100644
index 000000000000..0c9e025f94d8
--- /dev/null
+++ b/deskutils/clipit/pkg-descr
@@ -0,0 +1,3 @@
+ClipIt is a lightweight GTK+ clipboard manager forked from parcellite.
+
+WWW: http://clipit.rspwn.com/
diff --git a/deskutils/clipit/pkg-plist b/deskutils/clipit/pkg-plist
new file mode 100644
index 000000000000..4902987ed94d
--- /dev/null
+++ b/deskutils/clipit/pkg-plist
@@ -0,0 +1,64 @@
+bin/clipit
+etc/xdg/autostart/clipit-startup.desktop
+share/applications/clipit.desktop
+share/icons/hicolor/scalable/apps/clipit-trayicon.svg
+%%NLS%%share/locale/cs/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/da/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/de/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/es/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/es_ES/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/et/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/it/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/clipit.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/clipit.mo
+@dirrmtry etc/xdg/autostart/
+@dirrmtry etc/xdg/
+@dirrmtry share/applications
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+%%NLS%%@dirrmtry share/locale/cs/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/cs
+%%NLS%%@dirrmtry share/locale/da/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/da
+%%NLS%%@dirrmtry share/locale/de/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/de
+%%NLS%%@dirrmtry share/locale/es/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es
+%%NLS%%@dirrmtry share/locale/et/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/et
+%%NLS%%@dirrmtry share/locale/fr/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/fr
+%%NLS%%@dirrmtry share/locale/hu/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/hu
+%%NLS%%@dirrmtry share/locale/it/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/it
+%%NLS%%@dirrmtry share/locale/ja/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ja
+%%NLS%%@dirrmtry share/locale/nb/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/nb
+%%NLS%%@dirrmtry share/locale/pl/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pl
+%%NLS%%@dirrmtry share/locale/pt/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pt
+%%NLS%%@dirrmtry share/locale/ro/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ro
+%%NLS%%@dirrmtry share/locale/ru/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ru
+%%NLS%%@dirrmtry share/locale/sv/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sv
+%%NLS%%@dirrmtry share/locale/tr/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/tr
+%%NLS%%@dirrmtry share/locale/zh_CN/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/zh_CN
+%%NLS%%@dirrmtry share/locale