aboutsummaryrefslogtreecommitdiff
path: root/deskutils/flameshot
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-02-03 15:09:40 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-02-03 15:09:40 +0000
commit227ed9abe1e8d512d95b5f20da8c80bdb06a98ab (patch)
tree5d7647f4d5cb097fd52f16e106a16e17f1d606ae /deskutils/flameshot
parent917c955c7e3b098e9e6e023866aa1f05cb709ae1 (diff)
downloadports-227ed9abe1e8d512d95b5f20da8c80bdb06a98ab.tar.gz
ports-227ed9abe1e8d512d95b5f20da8c80bdb06a98ab.zip
Drop USE_GCC and add missing build dependency
Backport an upstream commit that fixes the build with clang, which allows us to drop USE_GCC. It is broken on at least FreeBSD 10: ===> Configuring for flameshot-0.5.0 Project ERROR: Cannot run compiler 'g++'. Output: =================== g++: not found =================== Maybe you forgot to setup the environment? *** Error code 3 Also add a dependency on qt5-buildtools, otherwise the build complains that rcc is not found. Approved by: portmgr (antoine) Differential Revision: https://reviews.freebsd.org/D14100
Notes
Notes: svn path=/head/; revision=460819
Diffstat (limited to 'deskutils/flameshot')
-rw-r--r--deskutils/flameshot/Makefile5
-rw-r--r--deskutils/flameshot/files/patch-git_48106925
2 files changed, 28 insertions, 2 deletions
diff --git a/deskutils/flameshot/Makefile b/deskutils/flameshot/Makefile
index 1021174a512c..ab7e7016b21b 100644
--- a/deskutils/flameshot/Makefile
+++ b/deskutils/flameshot/Makefile
@@ -4,6 +4,7 @@
PORTNAME= flameshot
PORTVERSION= 0.5.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= deskutils
MAINTAINER= nivit@FreeBSD.org
@@ -17,10 +18,10 @@ GH_ACCOUNT= lupoDharkael
INSTALL_ICONS= yes
USES= qmake
-USE_GCC= yes
USE_GITHUB= yes
USE_GL= gl
-USE_QT5= core dbus gui linguist network widgets
+USE_QT5= core dbus gui linguist network widgets \
+ buildtools_build
post-patch:
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},1' \
diff --git a/deskutils/flameshot/files/patch-git_481069 b/deskutils/flameshot/files/patch-git_481069
new file mode 100644
index 000000000000..1640921a78ca
--- /dev/null
+++ b/deskutils/flameshot/files/patch-git_481069
@@ -0,0 +1,25 @@
+From 48106975fb120fa7b6b1abb136183cb84bc957c9 Mon Sep 17 00:00:00 2001
+From: Peter Schuller <peter.schuller@infidyne.com>
+Date: Mon, 22 Jan 2018 12:15:21 -0800
+Subject: [PATCH] Fix case statement (so we build with clang). (#101)
+
+--- src/utils/screengrabber.cpp.orig 2017-12-20 13:41:48 UTC
++++ src/utils/screengrabber.cpp
+@@ -35,7 +35,7 @@ QPixmap ScreenGrabber::grabEntireDesktop(bool &ok) {
+ QPixmap res;
+ // handle screenshot based on DE
+ switch (m_info.windowManager()) {
+- case m_info.GNOME: {
++ case DesktopInfo::GNOME: {
+ // https://github.com/GNOME/gnome-shell/blob/695bfb96160033be55cfb5ac41c121998f98c328/data/org.gnome.Shell.Screenshot.xml
+ QString path = FileNameHandler().generateAbsolutePath("/tmp") + ".png";
+ QDBusInterface gnomeInterface(QStringLiteral("org.gnome.Shell"),
+@@ -48,7 +48,7 @@ QPixmap ScreenGrabber::grabEntireDesktop(bool &ok) {
+ ok = false;
+ }
+ break;
+- } case m_info.KDE: {
++ } case DesktopInfo::KDE: {
+ // https://github.com/KDE/spectacle/blob/517a7baf46a4ca0a45f32fd3f2b1b7210b180134/src/PlatformBackends/KWinWaylandImageGrabber.cpp#L145
+ QDBusInterface kwinInterface(QStringLiteral("org.kde.KWin"),
+ QStringLiteral("/Screenshot"),