aboutsummaryrefslogtreecommitdiff
path: root/deskutils/ganttproject
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-06 02:38:35 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-06 02:38:35 +0000
commit0924d8884dedc135c790f0a7af1a9d45d1dba9cc (patch)
treee689da61837465d103dbede5c94adc1fa2377b9c /deskutils/ganttproject
parent126b7632340f53b9e1e5b5499c81bc7abf503594 (diff)
downloadports-0924d8884dedc135c790f0a7af1a9d45d1dba9cc.tar.gz
ports-0924d8884dedc135c790f0a7af1a9d45d1dba9cc.zip
re-import ganttproject 1.9.11
Plan projects using a Gantt chart
Notes
Notes: svn path=/head/; revision=113023
Diffstat (limited to 'deskutils/ganttproject')
-rw-r--r--deskutils/ganttproject/Makefile41
-rw-r--r--deskutils/ganttproject/distinfo2
-rw-r--r--deskutils/ganttproject/files/ganttproject3
-rw-r--r--deskutils/ganttproject/pkg-descr5
4 files changed, 51 insertions, 0 deletions
diff --git a/deskutils/ganttproject/Makefile b/deskutils/ganttproject/Makefile
new file mode 100644
index 000000000000..bb82990ad243
--- /dev/null
+++ b/deskutils/ganttproject/Makefile
@@ -0,0 +1,41 @@
+# ex:ts=8
+# Ports collection makefile for: ganttproject
+# Date created: Jul 6, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ganttproject
+PORTVERSION= 1.9.11
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= -src.zip
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Plan projects using a Gantt chart
+
+BUILD_DEPENDS= ${ANT_CMD}:${PORTSDIR}/devel/apache-ant
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_BUILD= yes
+JAVA_RUN= yes
+ANT_CMD?= ${LOCALBASE}/bin/ant
+ANT= ${SETENV} JAVA_HOME=${JAVA_HOME} ${ANT_CMD}
+
+PLIST_FILES= bin/ganttproject %%JAVAJARDIR%%/ganttproject.jar
+
+post-patch:
+ @${SED} 's,%%JAVAJARDIR%%,${JAVAJARDIR},' ${FILESDIR}/${PORTNAME} > ${WRKSRC}/${PORTNAME}
+
+do-build:
+ @cd ${WRKSRC} && ${ANT}
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/build/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/deskutils/ganttproject/distinfo b/deskutils/ganttproject/distinfo
new file mode 100644
index 000000000000..fcca3618ddd0
--- /dev/null
+++ b/deskutils/ganttproject/distinfo
@@ -0,0 +1,2 @@
+MD5 (ganttproject-1.9.11-src.zip) = 6bf6f999791ab8d23c90206ca9c1336c
+SIZE (ganttproject-1.9.11-src.zip) = 4562369
diff --git a/deskutils/ganttproject/files/ganttproject b/deskutils/ganttproject/files/ganttproject
new file mode 100644
index 000000000000..8ef9316c2de3
--- /dev/null
+++ b/deskutils/ganttproject/files/ganttproject
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+java -jar %%JAVAJARDIR%%/ganttproject.jar $@
diff --git a/deskutils/ganttproject/pkg-descr b/deskutils/ganttproject/pkg-descr
new file mode 100644
index 000000000000..5acca5c3728c
--- /dev/null
+++ b/deskutils/ganttproject/pkg-descr
@@ -0,0 +1,5 @@
+Ganttproject lets you plan projects using a Gantt chart. GanttProject use a XML
+file format. It can export the project in HTML Web pages or PDF document (using
+XSLT) or image files.
+
+WWW: http://ganttproject.sourceforge.net/