aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gcal
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-12-28 21:33:14 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-12-28 21:33:14 +0000
commita5953c001795d186a7f6bf257f5b5c9999be1525 (patch)
treed0c42ef3e82b71d1676eb333e8c5173851405c1e /deskutils/gcal
parent3e90622b0cc92a5991da09952d4c922a15696637 (diff)
downloadports-a5953c001795d186a7f6bf257f5b5c9999be1525.tar.gz
ports-a5953c001795d186a7f6bf257f5b5c9999be1525.zip
- Enable stage support
- Fix perl shebang path - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=337919
Diffstat (limited to 'deskutils/gcal')
-rw-r--r--deskutils/gcal/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/deskutils/gcal/Makefile b/deskutils/gcal/Makefile
index 52b0670f8bf3..1beaf15ce37d 100644
--- a/deskutils/gcal/Makefile
+++ b/deskutils/gcal/Makefile
@@ -1,10 +1,11 @@
# Created by: Cyrille Lefevre <clefevre@citeweb.net>
# $FreeBSD$
-PORTNAME= gcal
-PORTVERSION= 3.6.3
-CATEGORIES= deskutils
-MASTER_SITES= GNU
+PORTNAME= gcal
+PORTVERSION= 3.6.3
+PORTREVISION= 1
+CATEGORIES= deskutils
+MASTER_SITES= GNU
MAINTAINER= johans@FreeBSD.org
COMMENT= The GNU Gregorian calendar program
@@ -12,15 +13,15 @@ COMMENT= The GNU Gregorian calendar program
USE_XZ= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
+USES= shebangfix
+SHEBANG_FILES= misc/gcalltx/gcalltxp.in misc/gcalltx/gcalltx.pl
INFO= gcal
-#MAN1= gcal.1 gcal2txt.1 tcal.1 txt2gcal.1
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USES= gettext
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
@@ -39,10 +40,11 @@ post-patch:
post-install:
@${TAR} -cf - -C ${WRKSRC} --exclude '*.in' --exclude '*.in.bak' \
- --exclude '*.alias' misc | ${TAR} -xpf - -C ${DATADIR}
+ --exclude '*.alias' misc | \
+ ${TAR} -xpf - -C ${STAGEDIR}${DATADIR}
.for p in ${GCAL_SCRIPTS}
- @${CHMOD} +x ${DATADIR}/misc/${p}
- @${LN} -s ${DATADIR}/misc/${p} ${PREFIX}/bin/gcal-${p:T}
+ @${CHMOD} +x ${STAGEDIR}${DATADIR}/misc/${p}
+ @${LN} -s ${DATADIR}/misc/${p} ${STAGEDIR}${PREFIX}/bin/gcal-${p:T}
.endfor
.include <bsd.port.mk>