aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gdesklets-sensor-psi_memo
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-17 20:54:32 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-17 20:54:32 +0000
commit0a370a25f55ad36b8e7ed55544db0971a8c90bad (patch)
tree9b311c9968a024127fdaa75ecf8f9b6186804de0 /deskutils/gdesklets-sensor-psi_memo
parent176283d85c858c660c99f211f032156b34c6f0cf (diff)
downloadports-0a370a25f55ad36b8e7ed55544db0971a8c90bad.tar.gz
ports-0a370a25f55ad36b8e7ed55544db0971a8c90bad.zip
Notes
Diffstat (limited to 'deskutils/gdesklets-sensor-psi_memo')
-rw-r--r--deskutils/gdesklets-sensor-psi_memo/Makefile43
-rw-r--r--deskutils/gdesklets-sensor-psi_memo/distinfo1
-rw-r--r--deskutils/gdesklets-sensor-psi_memo/files/patch-Install_Memo_Sensor.bin19
-rw-r--r--deskutils/gdesklets-sensor-psi_memo/pkg-descr3
-rw-r--r--deskutils/gdesklets-sensor-psi_memo/pkg-message8
-rw-r--r--deskutils/gdesklets-sensor-psi_memo/pkg-plist5
6 files changed, 79 insertions, 0 deletions
diff --git a/deskutils/gdesklets-sensor-psi_memo/Makefile b/deskutils/gdesklets-sensor-psi_memo/Makefile
new file mode 100644
index 000000000000..0edec118e6d4
--- /dev/null
+++ b/deskutils/gdesklets-sensor-psi_memo/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: gdesklets-sensor-psi_memo
+# Date created: 20 September 2003
+# Whom: Franz Klammer <klammer@webonaut.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= memo
+PORTVERSION= 0.1.4
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://gdesklets.gnomedesktop.org/files/
+PKGNAMEPREFIX= gdesklets-sensor-psi_
+DISTNAME= PsiSensorPackage-${DISTVERSION}
+
+MAINTAINER= klammer@webonaut.com
+COMMENT= Memo Sensor from the Psi Sensor Package
+
+RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gdesklets-core.pc:${PORTSDIR}/deskutils/gdesklets
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_X_PREFIX= yes
+
+DISTVERSION= 20031028
+NAME= Memo
+DATADIR= ${PREFIX}/share/gnome
+WRKSRC= ${WRKDIR}/${NAME}-${PORTVERSION}
+
+do-build:
+ @${WRKSRC}/Install_${NAME}_Sensor.bin --nomsg ${WRKSRC}
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
+
+do-install:
+ @${MKDIR} ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${INSTALL_DATA} ${WRKSRC}/${NAME}/*.py ${DATADIR}/gdesklets/Sensors/${NAME}/
+ @${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}/gdesklets/Sensors/${NAME}/
+
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/deskutils/gdesklets-sensor-psi_memo/distinfo b/deskutils/gdesklets-sensor-psi_memo/distinfo
new file mode 100644
index 000000000000..bf4d02f7d5c7
--- /dev/null
+++ b/deskutils/gdesklets-sensor-psi_memo/distinfo
@@ -0,0 +1 @@
+MD5 (PsiSensorPackage-20031028.tar.bz2) = 24c891e1d0f66426040b4e4fb618f9f5
diff --git a/deskutils/gdesklets-sensor-psi_memo/files/patch-Install_Memo_Sensor.bin b/deskutils/gdesklets-sensor-psi_memo/files/patch-Install_Memo_Sensor.bin
new file mode 100644
index 000000000000..fe343f6e8682
--- /dev/null
+++ b/deskutils/gdesklets-sensor-psi_memo/files/patch-Install_Memo_Sensor.bin
@@ -0,0 +1,19 @@
+--- Install_Memo_Sensor.bin.orig Wed Nov 19 18:34:09 2003
++++ Install_Memo_Sensor.bin Wed Nov 19 18:34:26 2003
+@@ -75,15 +75,9 @@
+ else:
+ cmd = "mkdir -p %(destination)s; cd %(destination)s; " \
+ "LANG=C tar -xzvf %(tmp)s 2>&1"
+- fail, out = commands.getstatusoutput(cmd % vars())
++ commands.getstatusoutput(cmd % vars())
+ os.unlink(tmp)
+
+- if (fail):
+- if (no_message): print ERROR_TAR + out
+- else: message(ERROR_TAR + out, "error")
+- sys.exit(1)
+-
+- print out
+ if (not list_only):
+ if (no_message): print SUCCESS
+ else: message(SUCCESS, "info")
diff --git a/deskutils/gdesklets-sensor-psi_memo/pkg-descr b/deskutils/gdesklets-sensor-psi_memo/pkg-descr
new file mode 100644
index 000000000000..f519b06f7f08
--- /dev/null
+++ b/deskutils/gdesklets-sensor-psi_memo/pkg-descr
@@ -0,0 +1,3 @@
+Memo Sensor from the Psi Sensor Package.
+
+WWW: http://gdesklets.gnomedesktop.org/
diff --git a/deskutils/gdesklets-sensor-psi_memo/pkg-message b/deskutils/gdesklets-sensor-psi_memo/pkg-message
new file mode 100644
index 000000000000..2db9048e2f62
--- /dev/null
+++ b/deskutils/gdesklets-sensor-psi_memo/pkg-message
@@ -0,0 +1,8 @@
+##
+To view the README, do the command following:
+
+ cat ${PREFIX}/share/gnome/gdesklets/Sensors/Memo/README
+
+This is just a sensor, to actually see the data it collects, you have to install
+an appropriate display plugin.
+##
diff --git a/deskutils/gdesklets-sensor-psi_memo/pkg-plist b/deskutils/gdesklets-sensor-psi_memo/pkg-plist
new file mode 100644
index 000000000000..807fa6f1a429
--- /dev/null
+++ b/deskutils/gdesklets-sensor-psi_memo/pkg-plist
@@ -0,0 +1,5 @@
+share/gnome/gdesklets/Sensors/Memo/__init__.py
+share/gnome/gdesklets/Sensors/Memo/__init__.pyc
+share/gnome/gdesklets/Sensors/Memo/__init__.pyo
+share/gnome/gdesklets/Sensors/Memo/README
+@dirrm share/gnome/gdesklets/Sensors/Memo