aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-contacts
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-09-30 11:58:29 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-09-30 11:58:29 +0000
commit951c1f5d1c7354f058f5919d858dbb0c174dc73e (patch)
tree6146e775343aaf339921799078894a48fef9aa15 /deskutils/gnome-contacts
parentc9b47f0427d70ba42c2d53271f8b64b8e8096825 (diff)
downloadports-951c1f5d1c7354f058f5919d858dbb0c174dc73e.tar.gz
ports-951c1f5d1c7354f058f5919d858dbb0c174dc73e.zip
The FreeBSD GNOME team proudly presents GNOME 3.28 for FreeBSD.
The offical GNOME 3.28 release notes can be found at https://help.gnome.org/misc/release-notes/3.28/ Thanks to Antoine Brodin for running the exp-runs. PR: 229761
Notes
Notes: svn path=/head/; revision=480951
Diffstat (limited to 'deskutils/gnome-contacts')
-rw-r--r--deskutils/gnome-contacts/Makefile38
-rw-r--r--deskutils/gnome-contacts/distinfo5
-rw-r--r--deskutils/gnome-contacts/files/patch-src_contacts-contact-editor.vala11
-rw-r--r--deskutils/gnome-contacts/files/patch-src_contacts-contact-pane.vala34
-rw-r--r--deskutils/gnome-contacts/pkg-plist11
5 files changed, 26 insertions, 73 deletions
diff --git a/deskutils/gnome-contacts/Makefile b/deskutils/gnome-contacts/Makefile
index 864076ee971c..fac95ae0193d 100644
--- a/deskutils/gnome-contacts/Makefile
+++ b/deskutils/gnome-contacts/Makefile
@@ -2,14 +2,16 @@
# $FreeBSD$
PORTNAME= gnome-contacts
-PORTVERSION= 3.18.0
-PORTREVISION= 6
+PORTVERSION= 3.28.2
CATEGORIES= deskutils gnome
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= Contacts manager for gnome
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= vala>=0.14.0:lang/vala
LIB_DEPENDS= libchamplain-0.12.so:graphics/libchamplain \
libclutter-gtk-1.0.so:graphics/clutter-gtk3 \
@@ -31,22 +33,18 @@ LIB_DEPENDS= libchamplain-0.12.so:graphics/libchamplain \
PORTSCOUT= limitw:1,even
-USE_XORG= x11 xcb xcomposite xdamage xext xfixes xi xrandr
-USE_GNOME= cairo evolutiondataserver3 gdkpixbuf2 glib20 gnomedesktop3 \
- gtk30 intlhack introspection:build
USE_GL= egl
-USES= gettext gmake gnome pathfix perl5 pkgconfig sqlite tar:xz
-GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-MAKE_ENV= XDG_CACHE_HOME=${WRKDIR}
+USE_GNOME= cairo evolutiondataserver3 gdkpixbuf2 gnomedesktop3 gtk30 \
+ intlhack introspection:build
+USE_XORG= x11 xcomposite xdamage xext xfixes xi xrandr
+USES= gettext gnome localbase meson perl5 pkgconfig \
+ python:3.4+,build shebangfix sqlite tar:xz
+SHEBANG_FILES= meson_post_install.py
-GLIB_SCHEMAS= org.gnome.Contacts.enums.xml \
- org.gnome.Contacts.gschema.xml
+GLIB_SCHEMAS= org.gnome.Contacts.gschema.xml
OPTIONS_SUB= yes
-OPTIONS_DEFINE= MANPAGES NLS
+OPTIONS_DEFINE= MANPAGES
OPTIONS_DEFAULT=MANPAGES
OPTIONS_DEFINE_i386= CHEESE
@@ -54,21 +52,13 @@ OPTIONS_DEFINE_amd64= CHEESE
OPTIONS_DEFAULT_i386= CHEESE
OPTIONS_DEFAULT_amd64= CHEESE
-MANPAGES_CONFIGURE_ENABLE= man-pages
+MANPAGES_MESON_TRUE= with-manpage
MANPAGES_USE= GNOME=libxslt:build
MANPAGES_BUILD_DEPENDS= docbook-xml>=0:textproc/docbook-xml \
docbook-xsl>=0:textproc/docbook-xsl
-NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext
-
CHEESE_DESC= Cheese webcam support
-CHEESE_CONFIGURE_WITH= cheese
+CHEESE_MESON_YES= with-cheese
CHEESE_LIB_DEPENDS= libcheese-gtk.so:multimedia/cheese
-post-patch:
- # touch vala sources to force regen c sources to honor cheese setting
- ${TOUCH} ${WRKSRC}/src/main.vala \
- ${WRKSRC}/src/contacts-avatar-dialog.vala
-
.include <bsd.port.mk>
diff --git a/deskutils/gnome-contacts/distinfo b/deskutils/gnome-contacts/distinfo
index 0b487b065969..4a3af387d738 100644
--- a/deskutils/gnome-contacts/distinfo
+++ b/deskutils/gnome-contacts/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gnome-contacts-3.18.0.tar.xz) = c81ad739a1f554e4c89979564565e32ceaf1d2cc6c93a6a75d929d7d1fe8e287
-SIZE (gnome-contacts-3.18.0.tar.xz) = 784616
+TIMESTAMP = 1525958162
+SHA256 (gnome-contacts-3.28.2.tar.xz) = 1c65ceff37d06ff7114b0d335f6c26e0f6bf1eff40af9feba73ad87cdfae8fc6
+SIZE (gnome-contacts-3.28.2.tar.xz) = 365188
diff --git a/deskutils/gnome-contacts/files/patch-src_contacts-contact-editor.vala b/deskutils/gnome-contacts/files/patch-src_contacts-contact-editor.vala
deleted file mode 100644
index c67280951db9..000000000000
--- a/deskutils/gnome-contacts/files/patch-src_contacts-contact-editor.vala
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/contacts-contact-editor.vala.orig 2018-01-12 21:18:52 UTC
-+++ src/contacts-contact-editor.vala
-@@ -77,7 +77,7 @@ public class Contacts.ContactEditor : Gr
- }
-
- struct RowData {
-- AbstractFieldDetails<string> details;
-+ AbstractFieldDetails details;
- }
-
- struct Field {
diff --git a/deskutils/gnome-contacts/files/patch-src_contacts-contact-pane.vala b/deskutils/gnome-contacts/files/patch-src_contacts-contact-pane.vala
deleted file mode 100644
index ac29403550e6..000000000000
--- a/deskutils/gnome-contacts/files/patch-src_contacts-contact-pane.vala
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/contacts-contact-pane.vala.orig 2018-01-12 21:20:00 UTC
-+++ src/contacts-contact-pane.vala
-@@ -451,7 +451,6 @@ public class Contacts.ContactPane : Note
- DialogFlags.MODAL,
- MessageType.ERROR,
- ButtonsType.OK,
-- "%s",
- _("You need to enter some data"));
- dialog.show ();
- dialog.response.connect ( () => {
-@@ -463,7 +462,6 @@ public class Contacts.ContactPane : Note
- DialogFlags.MODAL,
- MessageType.ERROR,
- ButtonsType.OK,
-- "%s",
- _("No primary addressbook configured"));
- dialog.show ();
- dialog.response.connect ( () => {
-@@ -482,7 +480,6 @@ public class Contacts.ContactPane : Note
- DialogFlags.MODAL,
- MessageType.ERROR,
- ButtonsType.OK,
-- "%s",
- _("Unable to create new contacts: %s"), e.message);
- }
-
-@@ -493,7 +490,6 @@ public class Contacts.ContactPane : Note
- DialogFlags.MODAL,
- MessageType.ERROR,
- ButtonsType.OK,
-- "%s",
- _("Unable to find newly created contact"));
- }
-
diff --git a/deskutils/gnome-contacts/pkg-plist b/deskutils/gnome-contacts/pkg-plist
index 44d85bf42c49..09780053eccd 100644
--- a/deskutils/gnome-contacts/pkg-plist
+++ b/deskutils/gnome-contacts/pkg-plist
@@ -1,11 +1,16 @@
bin/gnome-contacts
libexec/gnome-contacts-search-provider
%%MANPAGES%%man/man1/gnome-contacts.1.gz
-share/appdata/org.gnome.Contacts.appdata.xml
share/applications/org.gnome.Contacts.desktop
share/dbus-1/services/org.gnome.Contacts.SearchProvider.service
share/dbus-1/services/org.gnome.Contacts.service
share/gnome-shell/search-providers/org.gnome.Contacts.search-provider.ini
+share/icons/hicolor/16x16/apps/gnome-contacts.png
+share/icons/hicolor/22x22/apps/gnome-contacts.png
+share/icons/hicolor/32x32/apps/gnome-contacts.png
+share/icons/hicolor/48x48/apps/gnome-contacts.png
+share/icons/hicolor/512x512/apps/gnome-contacts.png
+share/icons/hicolor/symbolic/apps/gnome-contacts-symbolic.svg
share/locale/af/LC_MESSAGES/gnome-contacts.mo
share/locale/ar/LC_MESSAGES/gnome-contacts.mo
share/locale/as/LC_MESSAGES/gnome-contacts.mo
@@ -36,14 +41,15 @@ share/locale/gl/LC_MESSAGES/gnome-contacts.mo
share/locale/gu/LC_MESSAGES/gnome-contacts.mo
share/locale/he/LC_MESSAGES/gnome-contacts.mo
share/locale/hi/LC_MESSAGES/gnome-contacts.mo
+share/locale/hr/LC_MESSAGES/gnome-contacts.mo
share/locale/hu/LC_MESSAGES/gnome-contacts.mo
share/locale/id/LC_MESSAGES/gnome-contacts.mo
share/locale/is/LC_MESSAGES/gnome-contacts.mo
share/locale/it/LC_MESSAGES/gnome-contacts.mo
share/locale/ja/LC_MESSAGES/gnome-contacts.mo
-share/locale/ko/LC_MESSAGES/gnome-contacts.mo
share/locale/kk/LC_MESSAGES/gnome-contacts.mo
share/locale/kn/LC_MESSAGES/gnome-contacts.mo
+share/locale/ko/LC_MESSAGES/gnome-contacts.mo
share/locale/lt/LC_MESSAGES/gnome-contacts.mo
share/locale/lv/LC_MESSAGES/gnome-contacts.mo
share/locale/mk/LC_MESSAGES/gnome-contacts.mo
@@ -76,3 +82,4 @@ share/locale/vi/LC_MESSAGES/gnome-contacts.mo
share/locale/zh_CN/LC_MESSAGES/gnome-contacts.mo
share/locale/zh_HK/LC_MESSAGES/gnome-contacts.mo
share/locale/zh_TW/LC_MESSAGES/gnome-contacts.mo
+share/metainfo/org.gnome.Contacts.appdata.xml