aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-utils
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 04:53:48 +0000
commite18151212d3326dbf04797c6d5300fb1211ee875 (patch)
tree1ca56d6a4227efdb653cc8e2b2cbedbbc8de3d88 /deskutils/gnome-utils
parentcc0f3248a2eb77d7e3df88333fd25eb8594223dc (diff)
downloadports-e18151212d3326dbf04797c6d5300fb1211ee875.tar.gz
ports-e18151212d3326dbf04797c6d5300fb1211ee875.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Notes
Notes: svn path=/head/; revision=147261
Diffstat (limited to 'deskutils/gnome-utils')
-rw-r--r--deskutils/gnome-utils/Makefile7
-rw-r--r--deskutils/gnome-utils/distinfo4
-rw-r--r--deskutils/gnome-utils/files/patch-logview_logview.c10
-rw-r--r--deskutils/gnome-utils/files/patch-logview_userprefs.c10
-rw-r--r--deskutils/gnome-utils/pkg-plist2
5 files changed, 13 insertions, 20 deletions
diff --git a/deskutils/gnome-utils/Makefile b/deskutils/gnome-utils/Makefile
index fe275b6bfe4a..3df0b8bed07b 100644
--- a/deskutils/gnome-utils/Makefile
+++ b/deskutils/gnome-utils/Makefile
@@ -3,14 +3,15 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/deskutils/gnomeutils2/Makefile,v 1.70 2005/10/04 17:39:31 mezz Exp $
#
PORTNAME= gnomeutils2
-PORTVERSION= 2.10.1
+PORTVERSION= 2.12.1
PORTEPOCH= 1
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-utils/2.10
+MASTER_SITE_SUBDIR= sources/gnome-utils/2.12
DISTNAME= gnome-utils-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -25,7 +26,7 @@ USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
USE_GNOME= gnomeprefix gnomehack intlhack gnomepanel \
libgnomeprintui gnomedesktop
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/deskutils/gnome-utils/distinfo b/deskutils/gnome-utils/distinfo
index 431d41d29274..f89b2634bf02 100644
--- a/deskutils/gnome-utils/distinfo
+++ b/deskutils/gnome-utils/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-utils-2.10.1.tar.bz2) = 78c0afdc112757b13d203fe1ad9c04ad
-SIZE (gnome2/gnome-utils-2.10.1.tar.bz2) = 2049143
+MD5 (gnome2/gnome-utils-2.12.1.tar.bz2) = 345a330b7a80e09c0d5a6562438b346b
+SIZE (gnome2/gnome-utils-2.12.1.tar.bz2) = 1714248
diff --git a/deskutils/gnome-utils/files/patch-logview_logview.c b/deskutils/gnome-utils/files/patch-logview_logview.c
index 4ac243d34e9a..5dd057d1a77c 100644
--- a/deskutils/gnome-utils/files/patch-logview_logview.c
+++ b/deskutils/gnome-utils/files/patch-logview_logview.c
@@ -1,6 +1,6 @@
---- logview/logview.c.orig Tue Nov 30 00:29:01 2004
-+++ logview/logview.c Tue Nov 30 00:30:44 2004
-@@ -656,7 +656,7 @@
+--- logview/logview.c.orig Tue Oct 4 12:31:47 2005
++++ logview/logview.c Tue Oct 4 12:32:04 2005
+@@ -930,7 +930,7 @@
if ( ! found) {
g_snprintf (full_name, sizeof (full_name),
@@ -9,7 +9,7 @@
if (access (full_name, R_OK) == 0) {
found = TRUE;
g_free (cfg->regexp_db_path);
-@@ -678,7 +678,7 @@
+@@ -952,7 +952,7 @@
if ( ! found) {
g_snprintf (full_name, sizeof (full_name),
@@ -18,7 +18,7 @@
if (access (full_name, R_OK) == 0) {
found = TRUE;
g_free (cfg->descript_db_path);
-@@ -709,7 +709,7 @@
+@@ -983,7 +983,7 @@
if ( ! found) {
g_snprintf (full_name, sizeof (full_name),
diff --git a/deskutils/gnome-utils/files/patch-logview_userprefs.c b/deskutils/gnome-utils/files/patch-logview_userprefs.c
deleted file mode 100644
index d93f8ae57fc2..000000000000
--- a/deskutils/gnome-utils/files/patch-logview_userprefs.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- logview/userprefs.c.orig Tue Nov 30 00:35:05 2004
-+++ logview/userprefs.c Tue Nov 30 00:36:34 2004
-@@ -56,6 +56,7 @@
- /* remove trailing newline */
- if (logfile[strlen(logfile)-1] == '\n')
- logfile[strlen(logfile)-1] = '\0';
-+ if (strcmp (logfile, "/dev/console") == 0) continue;
- return logfile;
- }
- }
diff --git a/deskutils/gnome-utils/pkg-plist b/deskutils/gnome-utils/pkg-plist
index ef6c79aab8ae..24ef4bd1cfd7 100644
--- a/deskutils/gnome-utils/pkg-plist
+++ b/deskutils/gnome-utils/pkg-plist
@@ -116,6 +116,7 @@ share/gnome/omf/gnome-utils/gnome-system-log-sv.omf
share/gnome/omf/gnome-utils/gnome-system-log-uk.omf
share/gnome/omf/gnome-utils/gnome-system-log-zh_CN.omf
share/gnome/omf/gnome-utils/gnome-system-log-zh_TW.omf
+share/gnome/pixmaps/gsearchtool/thumbnail_frame.png
share/locale/am/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/ar/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/az/LC_MESSAGES/gnome-utils-2.0.mo
@@ -181,6 +182,7 @@ share/locale/wa/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/xh/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/zh_CN/LC_MESSAGES/gnome-utils-2.0.mo
share/locale/zh_TW/LC_MESSAGES/gnome-utils-2.0.mo
+@dirrm share/gnome/pixmaps/gsearchtool
@dirrm share/gnome/omf/gnome-utils
@dirrm share/gnome/help/gnome-system-log/zh_TW/figures
@dirrm share/gnome/help/gnome-system-log/zh_TW