aboutsummaryrefslogtreecommitdiff
path: root/deskutils/griffith/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2016-11-08 21:30:21 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2016-11-08 21:30:21 +0000
commit762712a2324b85ade45e3d70f191a40b07ae771c (patch)
tree25995b116d20d58bc1b3848522f7d4abf1595681 /deskutils/griffith/Makefile
parent402660492aa228ad08bb6321d49af27b1b845e28 (diff)
downloadports-762712a2324b85ade45e3d70f191a40b07ae771c.tar.gz
ports-762712a2324b85ade45e3d70f191a40b07ae771c.zip
Remove broken option
Notes
Notes: svn path=/head/; revision=425766
Diffstat (limited to 'deskutils/griffith/Makefile')
-rw-r--r--deskutils/griffith/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/deskutils/griffith/Makefile b/deskutils/griffith/Makefile
index c7bb4f8a6520..7c4c21ec4595 100644
--- a/deskutils/griffith/Makefile
+++ b/deskutils/griffith/Makefile
@@ -15,13 +15,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}sqlalchemy08>=0.5:databases/py-sqlalchemy08 \
- ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow
+ ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow \
+ ${PYTHON_PKGNAMEPREFIX}reportlab1>=1.19:print/py-reportlab1
USE_GNOME= pygtk2
USES= gmake gettext python:2 tar:xz
NO_BUILD= yes
-OPTIONS_DEFINE= CHARDET LXML REPORTLAB2
+OPTIONS_DEFINE= CHARDET LXML
OPTIONS_DEFAULT= LXML
CHARDET_DESC= chardet support
@@ -30,16 +31,8 @@ CHARDET_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet
LXML_DESC= lxml support
LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml
-REPORTLAB2_DESC= ReportLab2 support
-
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MREPORTLAB2}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}reportlab2>=2:print/py-reportlab2
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}reportlab1>=1.19:print/py-reportlab1
-.endif
-
post-patch:
.for file in Makefile
@${REINPLACE_CMD} -e \