aboutsummaryrefslogtreecommitdiff
path: root/deskutils/growl-for-linux
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2013-11-18 02:41:22 +0000
committerNicola Vitale <nivit@FreeBSD.org>2013-11-18 02:41:22 +0000
commitb1f9a4eb540545874602f6f4e4ef22e849b0844e (patch)
tree28db4bdaf9cd9ace2fe18dcec159d001cd0f57ed /deskutils/growl-for-linux
parent639c936996f77508a22f8694cbaf2e75db4b8f38 (diff)
downloadports-b1f9a4eb540545874602f6f4e4ef22e849b0844e.tar.gz
ports-b1f9a4eb540545874602f6f4e4ef22e849b0844e.zip
- Update to 0.6.9
- Use new syntax in LIB_DEPENDS - Set USE_GCC - Remove desktopfileutils from USE_GNOME - Add files/patch-plugins__Makefile.am (see https://github.com/mattn/growl-for-linux/commit/a74962e5f7cca0b31ef86d3edb273aefa9431dcb) - Enable stage target
Notes
Notes: svn path=/head/; revision=334139
Diffstat (limited to 'deskutils/growl-for-linux')
-rw-r--r--deskutils/growl-for-linux/Makefile21
-rw-r--r--deskutils/growl-for-linux/distinfo4
-rw-r--r--deskutils/growl-for-linux/files/patch-plugins__Makefile.am8
-rw-r--r--deskutils/growl-for-linux/pkg-plist12
4 files changed, 25 insertions, 20 deletions
diff --git a/deskutils/growl-for-linux/Makefile b/deskutils/growl-for-linux/Makefile
index 504807e6f557..d62fa2965626 100644
--- a/deskutils/growl-for-linux/Makefile
+++ b/deskutils/growl-for-linux/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= growl-for-linux
-PORTVERSION= 0.6.8
-PORTREVISION= 2
+PORTVERSION= 0.6.9
+PORTREVISION= 0
CATEGORIES= deskutils
MAINTAINER= nivit@FreeBSD.org
@@ -10,11 +10,11 @@ COMMENT= Notification system compatible with Growl
LICENSE= BSD
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
GH_ACCOUNT= mattn
-GH_COMMIT= cab80f2
+GH_COMMIT= ac7c8cd
GH_TAGNAME= ${GH_COMMIT}
GNU_CONFIGURE= yes
@@ -23,24 +23,23 @@ OPTIONS_DEFINE= LIBNOTIFY
OPTIONS_DEFAULT= LIBNOTIFY
LIBNOTIFY_DESC= Use notify-osd for libnotify display plugin
-USES= pkgconfig
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLIBNOTIFY}
-LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= libnotify.so:${PORTSDIR}/devel/libnotify
RUN_DEPENDS+= notify-osd>=0.9.29_3:${PORTSDIR}/deskutils/notify-osd
.endif
-PLIST_SUB= DESKTOPDIR=${_DESKTOPDIR_REL}
+PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,}
USE_AUTOTOOLS= autoconf:env automake:env libtoolize:env
USE_GITHUB= yes
-USE_GNOME= desktopfileutils gtk20
+USE_GCC= any
+USE_GNOME= gtk20
USE_LDCONFIG= yes
USE_OPENSSL= yes
USE_SQLITE= 3
+USES= pkgconfig
WITH_OPENSSL_PORT= yes
diff --git a/deskutils/growl-for-linux/distinfo b/deskutils/growl-for-linux/distinfo
index ef171ff1c743..45c0fd10801e 100644
--- a/deskutils/growl-for-linux/distinfo
+++ b/deskutils/growl-for-linux/distinfo
@@ -1,2 +1,2 @@
-SHA256 (growl-for-linux-0.6.8.tar.gz) = cd8b1b2dadb57f2beaf5fc6a5d6798b33a11fdf7177b82b0d03c4d331cc8121a
-SIZE (growl-for-linux-0.6.8.tar.gz) = 739994
+SHA256 (growl-for-linux-0.6.9.tar.gz) = 483627273764ec1e8d0f16a91492904516910cfbea27966722cfd18ef7e2ba22
+SIZE (growl-for-linux-0.6.9.tar.gz) = 740009
diff --git a/deskutils/growl-for-linux/files/patch-plugins__Makefile.am b/deskutils/growl-for-linux/files/patch-plugins__Makefile.am
new file mode 100644
index 000000000000..bd8a141041cf
--- /dev/null
+++ b/deskutils/growl-for-linux/files/patch-plugins__Makefile.am
@@ -0,0 +1,8 @@
+--- ./plugins/Makefile.am.orig 2013-11-18 02:12:05.000000000 +0100
++++ ./plugins/Makefile.am 2013-11-18 02:12:12.000000000 +0100
+@@ -1,4 +1,4 @@
+-lib_LIBRARIES = libgolplug.a
++noinst_LIBRARIES = libgolplug.a
+ libgolplug_a_SOURCES = memfile.c memfile.h from_url.c from_url.h
+ libgolplug_a_CFLAGS = $(GTK2_CFLAGS) $(LIBCURL_CFLAGS) -fPIC -I$(srcdir)/..
+ #libgolplug_a_LIBADD = $(GTK2_LIBS) $(LIBCURL_LIBS)
diff --git a/deskutils/growl-for-linux/pkg-plist b/deskutils/growl-for-linux/pkg-plist
index 8a6322d5c8c2..85fd44a76f4c 100644
--- a/deskutils/growl-for-linux/pkg-plist
+++ b/deskutils/growl-for-linux/pkg-plist
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
bin/gol
lib/growl-for-linux/display/libballoon.a
lib/growl-for-linux/display/libballoon.la
@@ -24,14 +23,13 @@ lib/growl-for-linux/subscribe/libtweets.a
lib/growl-for-linux/subscribe/libtweets.la
lib/growl-for-linux/subscribe/libtweets.so
lib/growl-for-linux/subscribe/libtweets.so.0
-lib/libgolplug.a
%%DESKTOPDIR%%/gol.desktop
%%DATADIR%%/data/growl4linux.jpg
%%DATADIR%%/data/icon.png
%%DATADIR%%/data/icon_dnd.png
%%DATADIR%%/data/mattn.png
-@dirrm %%DATADIR%%/data
-@dirrm %%DATADIR%%
-@dirrm lib/growl-for-linux/subscribe
-@dirrm lib/growl-for-linux/display
-@dirrm lib/growl-for-linux
+@dirrmtry %%DATADIR%%/data
+@dirrmtry %%DATADIR%%
+@dirrmtry lib/growl-for-linux/subscribe
+@dirrmtry lib/growl-for-linux/display
+@dirrmtry lib/growl-for-linux