aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gsimplecal
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2015-03-07 21:31:40 +0000
committerLars Engels <lme@FreeBSD.org>2015-03-07 21:31:40 +0000
commitd29d4eedbe05902ec88f0897288d34337c09ae84 (patch)
tree507f2267e2167a2adcca14def2d68f2725a17a21 /deskutils/gsimplecal
parent58e5d866f71444c4b73a3abd3c70cf8e1ca09959 (diff)
downloadports-d29d4eedbe05902ec88f0897288d34337c09ae84.tar.gz
ports-d29d4eedbe05902ec88f0897288d34337c09ae84.zip
Add deskutils/gsimplecal
Gsimplecal is a lightweight calendar applet written in C++ using GTK. It was intentionally made for use with tint2 panel in the openbox environment to be launched upon clock click, but of course it will work without it. In fact, binding the gsimplecal to some hotkey in you window manager will probably make you happy. The thing is that when it is started it first shows up, when you run it again it closes the running instance. In that way it is very easy to integrate anywhere. No need to write some wrapper scripts or whatever. Also, you can configure it to not only show the calendar, but also display multiple clocks for different world timezones. Read the manual page for the details (there is info about keyboard controls as well!). WWW: https://github.com/dmedvinsky/gsimplecal
Notes
Notes: svn path=/head/; revision=380718
Diffstat (limited to 'deskutils/gsimplecal')
-rw-r--r--deskutils/gsimplecal/Makefile26
-rw-r--r--deskutils/gsimplecal/distinfo2
-rw-r--r--deskutils/gsimplecal/pkg-descr14
3 files changed, 42 insertions, 0 deletions
diff --git a/deskutils/gsimplecal/Makefile b/deskutils/gsimplecal/Makefile
new file mode 100644
index 000000000000..5c6fd2fc5aa5
--- /dev/null
+++ b/deskutils/gsimplecal/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= gsimplecal
+PORTVERSION= 2.1
+CATEGORIES= deskutils
+
+MAINTAINER= lme@FfreeBSD.org
+COMMENT= Lightweight calendar applet written in C++ using GTK
+
+LICENSE= GPLv3
+
+USE_GITHUB= yes
+GH_ACCOUNT= dmedvinsky
+GH_COMMIT= c544ee9
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= ${GH_COMMIT}
+
+GNU_CONFIGURE= yes
+
+USES= autoreconf gmake pkgconfig
+USE_GNOME= glib20 gtk30
+
+PLIST_FILES= bin/gsimplecal \
+ man/man1/gsimplecal.1.gz
+
+.include <bsd.port.mk>
diff --git a/deskutils/gsimplecal/distinfo b/deskutils/gsimplecal/distinfo
new file mode 100644
index 000000000000..ebb844678fab
--- /dev/null
+++ b/deskutils/gsimplecal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gsimplecal-2.1.tar.gz) = afd3cf128ce2cf3fbd0738c929467ca4b3a9c9c0778c637449a3284a972bde9d
+SIZE (gsimplecal-2.1.tar.gz) = 14154
diff --git a/deskutils/gsimplecal/pkg-descr b/deskutils/gsimplecal/pkg-descr
new file mode 100644
index 000000000000..bb8ce8bd5cdf
--- /dev/null
+++ b/deskutils/gsimplecal/pkg-descr
@@ -0,0 +1,14 @@
+Gsimplecal is a lightweight calendar applet written in C++ using GTK.
+
+It was intentionally made for use with tint2 panel in the openbox environment
+to be launched upon clock click, but of course it will work without it. In
+fact, binding the gsimplecal to some hotkey in you window manager will probably
+make you happy. The thing is that when it is started it first shows up, when
+you run it again it closes the running instance. In that way it is very easy to
+integrate anywhere. No need to write some wrapper scripts or whatever.
+
+Also, you can configure it to not only show the calendar, but also display
+multiple clocks for different world timezones. Read the manual page for the
+details (there is info about keyboard controls as well!).
+
+WWW: https://github.com/dmedvinsky/gsimplecal