aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gtg
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-17 19:20:33 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-17 19:20:33 +0000
commitfdef6b0ea81976c25b4de8374f3ffdc326947dc2 (patch)
treee451c2beb412898114cae792193a75b1875ed3f1 /deskutils/gtg
parent3d0c982416f7793d1444e7317072e9f9b1814120 (diff)
downloadports-fdef6b0ea81976c25b4de8374f3ffdc326947dc2.tar.gz
ports-fdef6b0ea81976c25b4de8374f3ffdc326947dc2.zip
Notes
Diffstat (limited to 'deskutils/gtg')
-rw-r--r--deskutils/gtg/Makefile3
-rw-r--r--deskutils/gtg/files/patch-GTG___init__.py21
2 files changed, 18 insertions, 6 deletions
diff --git a/deskutils/gtg/Makefile b/deskutils/gtg/Makefile
index 41e43cb7f21d..66f515f13006 100644
--- a/deskutils/gtg/Makefile
+++ b/deskutils/gtg/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtg
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= deskutils gnome python
MASTER_SITES= http://launchpad.net/gtg/trunk/${PORTVERSION}/+download/ \
http://freebsd.unixfreunde.de/sources/
@@ -27,6 +28,8 @@ MAN1= gtg.1
post-patch:
@${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' \
+ ${WRKSRC}/gtg.desktop ${WRKSRC}/GTG/__init__.py
post-install:
@-update-desktop-database
diff --git a/deskutils/gtg/files/patch-GTG___init__.py b/deskutils/gtg/files/patch-GTG___init__.py
index 672ec383f95d..e10ef92c2840 100644
--- a/deskutils/gtg/files/patch-GTG___init__.py
+++ b/deskutils/gtg/files/patch-GTG___init__.py
@@ -1,11 +1,20 @@
---- GTG/__init__.py.orig 2009-03-07 02:09:57.000000000 +0300
-+++ GTG/__init__.py 2009-03-16 01:19:21.000000000 +0300
-@@ -22,7 +22,7 @@
+--- GTG/__init__.py.orig 2009-04-04 01:00:16.000000000 +0400
++++ GTG/__init__.py 2009-06-17 12:59:18.000000000 +0400
+@@ -32,7 +32,7 @@
EMAIL = "gtg@lists.launchpad.net"
- VERSION = '0.1'
+ VERSION = '0.1.1'
LOCAL_ROOTDIR = os.path.abspath(os.path.join(os.path.dirname(__file__), '..'))
-DIST_ROOTDIR = "/usr/share/gtg"
+DIST_ROOTDIR = "/usr/local/share/gtg"
- if not os.path.isdir( os.path.join(LOCAL_ROOTDIR,'data') ) :
- DATA_DIR = DIST_ROOTDIR
+ # CREDITS
+ AUTHORS = ["Main developers:", \
+@@ -60,7 +60,7 @@
+ GETTEXT_DOMAIN = 'gtg'
+ LOCALE_PATH = abspath(join(dirname(__file__), pardir, 'locales'))
+ if not os.path.isdir(LOCALE_PATH):
+- LOCALE_PATH = '/usr/share/locale'
++ LOCALE_PATH = '/usr/local/share/locale'
+ languages_used = []
+ lc, encoding = locale.getdefaultlocale()
+ if lc: