aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gworkspace
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-11-30 18:55:36 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-11-30 18:55:36 +0000
commitbfeac5741dead0efc959b7a1ef47d7e4b29ba86e (patch)
tree52d3a4b0effa8944f566e25d03ad60b9655c391d /deskutils/gworkspace
parent9faaba0186eac2b7bb559569203870e1dab2fe29 (diff)
downloadports-bfeac5741dead0efc959b7a1ef47d7e4b29ba86e.tar.gz
ports-bfeac5741dead0efc959b7a1ef47d7e4b29ba86e.zip
- add missing include
Notes
Notes: svn path=/head/; revision=178363
Diffstat (limited to 'deskutils/gworkspace')
-rw-r--r--deskutils/gworkspace/Makefile14
-rw-r--r--deskutils/gworkspace/pkg-plist1
2 files changed, 10 insertions, 5 deletions
diff --git a/deskutils/gworkspace/Makefile b/deskutils/gworkspace/Makefile
index d9ae94271640..d7169395fd90 100644
--- a/deskutils/gworkspace/Makefile
+++ b/deskutils/gworkspace/Makefile
@@ -7,24 +7,24 @@
PORTNAME= gworkspace
PORTVERSION= 0.8.3
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= http://www.gnustep.it/enrico/gworkspace/
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep workspace manager
-WRKSRC= ${WRKDIR}/GWorkspace-${PORTVERSION}
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_CONFIGURE= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE= GNUmakefile
+USE_GNUSTEP_LDCONFIG= ${SYSLIBDIR}
+
+WRKSRC= ${WRKDIR}/GWorkspace-${PORTVERSION}
+GNU_CONFIGURE= yes
ADDITIONAL_LDFLAGS+= -L${WRKSRC}/FSNode/FSNode.framework/Versions/A
-MAKE_ENV+= ADDITIONAL_LDFLAGS="${ADDITIONAL_LDFLAGS}"
DEFAULT_LIBVERSION2= 0.1.0
PLIST_SUB+= LIBVERSION2=${DEFAULT_LIBVERSION2}
PLIST_SUB+= MAJORLIBVERSION2=${DEFAULT_LIBVERSION2:C/([0-9]).*/\1/1}
@@ -36,4 +36,8 @@ PLIST_SUB+= PDFVIEW=""
USE_GHOSTSCRIPT= yes
.endif
+post-install:
+ ${CP} ${WRKSRC}/Inspector/ContentViewersProtocol.h \
+ ${SYSTEMDIR}/Library/Frameworks/Inspector.framework/Versions/A/Headers/ContentViewersProtocol.h
+
.include <bsd.port.mk>
diff --git a/deskutils/gworkspace/pkg-plist b/deskutils/gworkspace/pkg-plist
index 4250bc52bdd5..13a501c298b6 100644
--- a/deskutils/gworkspace/pkg-plist
+++ b/deskutils/gworkspace/pkg-plist
@@ -389,6 +389,7 @@ System/Library/Frameworks/FSNode.framework/Versions/A/libFSNode.so.%%LIBVERSION2
System/Library/Frameworks/FSNode.framework/Versions/Current
System/Library/Frameworks/Inspector.framework/Headers
System/Library/Frameworks/Inspector.framework/Resources
+System/Library/Frameworks/Inspector.framework/Versions/A/Headers/ContentViewersProtocol.h
System/Library/Frameworks/Inspector.framework/Versions/A/Headers/Inspector.h
System/Library/Frameworks/Inspector.framework/Versions/A/Inspector
System/Library/Frameworks/Inspector.framework/Versions/A/Resources/Date-0.tiff