aboutsummaryrefslogtreecommitdiff
path: root/deskutils/horde-mnemo/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-01-06 00:38:13 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-01-06 00:38:13 +0000
commite23ee358fa1ac94e411715abac088791dc154c19 (patch)
tree2f2d07d89e8f9b0b1bbbaa61fc0a3c53d8b1308c /deskutils/horde-mnemo/Makefile
parent8931540e0ace91aa22d2f957ccaefa11eb78adca (diff)
downloadports-e23ee358fa1ac94e411715abac088791dc154c19.tar.gz
ports-e23ee358fa1ac94e411715abac088791dc154c19.zip
Notes
Diffstat (limited to 'deskutils/horde-mnemo/Makefile')
-rw-r--r--deskutils/horde-mnemo/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/deskutils/horde-mnemo/Makefile b/deskutils/horde-mnemo/Makefile
index 61dc04ee2164..e5e46cdc2342 100644
--- a/deskutils/horde-mnemo/Makefile
+++ b/deskutils/horde-mnemo/Makefile
@@ -24,10 +24,13 @@ COMMENT= Mnemo is the Horde notes and memos application
RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
NO_BUILD= yes
-USE_REINPLACE= yes
+USE_APACHE= 1.3+ # needed to test APACHE_VERSION
-PLIST_SUB= MNEMODIR=${LMNEMODIR}
+PLIST_SUB= MNEMODIR=${LMNEMODIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-message pkg-deinstall
+SUB_LIST= MNEMODIR=${MNEMODIR}
DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL \
docs/RELEASE_NOTES docs/TODO docs/UPGRADING
@@ -40,11 +43,17 @@ LMNEMODIR?= ${LHORDEDIR}/mnemo
MNEMODIR= ${PREFIX}/${LMNEMODIR}
CONFDIR= ${MNEMODIR}/config
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} >= 20
+HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes
+.else
HORDE_INC= ${LOCALBASE}/etc/horde
+.endif
pre-configure:
@${SED} -e "s:/home/httpd/html/horde/mnemo:${MNEMODIR}:g" \
- ${FILESDIR}/httpd.conf.mnemo > ${WRKDIR}/httpd.conf.mnemo
+ ${FILESDIR}/httpd.conf.mnemo > ${WRKDIR}/httpd-mnemo.conf
do-install:
@${MKDIR} ${MNEMODIR}
@@ -59,7 +68,7 @@ do-install:
.endfor
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${MNEMODIR}
@${CHMOD} -R o-rwx ${CONFDIR}
- @${INSTALL_DATA} ${WRKDIR}/httpd.conf.mnemo ${HORDE_INC}
+ @${INSTALL_DATA} ${WRKDIR}/httpd-mnemo.conf ${HORDE_INC}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@@ -69,10 +78,8 @@ do-install:
.endif
post-install:
- @${SED} -e "s:%%MNEMODIR%%:${MNEMODIR}:g;s:%%DOCSDIR%%:${DOCSDIR}:g" \
- < ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>