aboutsummaryrefslogtreecommitdiff
path: root/deskutils/horde4-mnemo/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-03-16 22:28:57 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-03-16 22:28:57 +0000
commit9835e7cc57ec619941c620463cb7d95049adbe8b (patch)
tree07b18f0ffbc99ed5df9e90a56759afcb22e8acd1 /deskutils/horde4-mnemo/Makefile
parent8b485e2b8ced1b3fd06107037e414fafb7b3464c (diff)
downloadports-9835e7cc57ec619941c620463cb7d95049adbe8b.tar.gz
ports-9835e7cc57ec619941c620463cb7d95049adbe8b.zip
Notes
Diffstat (limited to 'deskutils/horde4-mnemo/Makefile')
-rw-r--r--deskutils/horde4-mnemo/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/deskutils/horde4-mnemo/Makefile b/deskutils/horde4-mnemo/Makefile
index 2fc47c5708ef..9d2a8fd2382d 100644
--- a/deskutils/horde4-mnemo/Makefile
+++ b/deskutils/horde4-mnemo/Makefile
@@ -6,15 +6,17 @@
#
PORTNAME= mnemo
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.1.1
CATEGORIES= deskutils www
MASTER_SITES= ftp://ftp.horde.org/pub/mnemo/ \
+ ftp://ftp.planetmirror.com/pub/horde/mnemo/ \
ftp://ftp.au.horde.org/pub/horde/mnemo/ \
+ ftp://ftp.be.horde.org/mnemo/ \
ftp://ftp.es.horde.org/pub/mnemo/ \
ftp://ftp.it.horde.org/pub/mirror/horde.org/mnemo/ \
ftp://ftp.nl.horde.org/mirror/horde-ftp/pub/mnemo/ \
- ftp://ftp.pt.horde.org/pub/horde-ftp/mnemo/
+ ftp://ftp.uk.horde.org/mirrors/ftp.horde.org/pub/mnemo/ \
+ http://ftp.horde.org/pub/mnemo/
MAINTAINER= thierry@pompo.net
COMMENT= Mnemo is the Horde notes and memos application
@@ -28,7 +30,8 @@ REINPLACE_ARGS= -i.beforeMnemo
PLIST_SUB= HORDEDIR=${LHORDEDIR} MNEMODIR=${LMNEMODIR}
-DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL
+DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL \
+ docs/RELEASE_NOTES
CONFFILE= conf.php menu.php prefs.php
SUB_DIRS= config graphics lib locale po scripts templates util
@@ -41,6 +44,9 @@ CONFDIR= ${MNEMODIR}/config
HORDE_INC= ${LOCALBASE}/etc/horde
+post-patch:
+ @${RM} ${WRKSRC}/config/conf.php.dist.orig
+
do-install:
@${MKDIR} ${MNEMODIR}
.for REP in ${SUB_DIRS}
@@ -73,8 +79,8 @@ do-install:
post-install:
@${ECHO_MSG}
- @${CAT} ${PKGMESSAGE} | \
- ${SED} -e "s:%%MNEMODIR%%:${MNEMODIR}:g;s:%%PORTSDIR%%:${PORTSDIR}:g;s:%%CONFDIR%%:${CONFDIR}:g;s:%%HORDEDIR%%:${HORDEDIR}:"
+ @${SED} -e "s:%%MNEMODIR%%:${MNEMODIR}:g;s:%%PORTSDIR%%:${PORTSDIR}:g" \
+ -e "s:%%CONFDIR%%:${CONFDIR}:g;s:%%HORDEDIR%%:${HORDEDIR}:" ${PKGMESSAGE}
@${ECHO_MSG}
.include <bsd.port.mk>