aboutsummaryrefslogtreecommitdiff
path: root/deskutils/ical
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-10-29 03:46:01 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-10-29 03:46:01 +0000
commit50832123ad104a36492c75a9461513494e80f6ad (patch)
tree5fa76c5be3f6bff4ae0cdce41b322e9babc08543 /deskutils/ical
parent1b9ee0e7dd5696bfef43321c8d82b22516b4f484 (diff)
downloadports-50832123ad104a36492c75a9461513494e80f6ad.tar.gz
ports-50832123ad104a36492c75a9461513494e80f6ad.zip
Consume tcl/tk 8.4.
Notes
Notes: svn path=/head/; revision=120453
Diffstat (limited to 'deskutils/ical')
-rw-r--r--deskutils/ical/Makefile23
-rw-r--r--deskutils/ical/files/patch-aa58
-rw-r--r--deskutils/ical/files/patch-ab108
-rw-r--r--deskutils/ical/files/patch-dateeditor.C11
-rw-r--r--deskutils/ical/files/patch-dispatch.C11
-rw-r--r--deskutils/ical/files/patch-ical.h14
-rw-r--r--deskutils/ical/files/patch-main.C25
-rw-r--r--deskutils/ical/files/patch-object.C20
-rw-r--r--deskutils/ical/files/patch-pref.tcl16
9 files changed, 273 insertions, 13 deletions
diff --git a/deskutils/ical/Makefile b/deskutils/ical/Makefile
index 366036405169..019dbe7f3e89 100644
--- a/deskutils/ical/Makefile
+++ b/deskutils/ical/Makefile
@@ -1,3 +1,4 @@
+# ex:ts=8
# New ports collection makefile for: ical
# Date created: Mon Aug 28 13:35:31 CDT 1995
# Whom: erich@rrnet.com
@@ -7,25 +8,21 @@
PORTNAME= ical
PORTVERSION= 2.2
-PORTREVISION= 1
-CATEGORIES= deskutils tk83
-MASTER_SITES= ftp://ftp.sco.com/skunkware/src/shellutil/ \
- ftp://ftp.sunet.se/pub/vendor/sco/skunkware/src/shellutil/ \
- ftp://ftp.netsw.org/netsw/X11/Tools/Desktop/ \
- ftp://ftp.kddlabs.co.jp/sourceforge/ical/ \
- ftp://ftp.sunsite.org.uk/Mirrors/ftp.sco.com/skunkware/src/shellutil/
+PORTREVISION= 2
+CATEGORIES= deskutils tk84
+MASTER_SITES= ftp://ftp.sunet.se/pub/vendor/sco/skunkware/src/shellutil/
MAINTAINER= obrien@FreeBSD.org
COMMENT= A calendar application
-LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
+LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tclconfig=${PREFIX}/lib/tcl8.3 \
- --with-tclhdir=${PREFIX}/include/tcl8.3 \
- --with-tclsh=${PREFIX}/bin/tclsh8.3 \
- --with-tkconfig=${PREFIX}/lib/tk8.3 \
- --with-tkhdir=${PREFIX}/include/tk8.3
+CONFIGURE_ARGS= --with-tclconfig=${PREFIX}/lib/tcl8.4 \
+ --with-tclhdir=${PREFIX}/include/tcl8.4 \
+ --with-tclsh=${PREFIX}/bin/tclsh8.4 \
+ --with-tkconfig=${PREFIX}/lib/tk8.4 \
+ --with-tkhdir=${PREFIX}/include/tk8.4
MAN1= ical.1
diff --git a/deskutils/ical/files/patch-aa b/deskutils/ical/files/patch-aa
index 3811adda6b80..38105617557b 100644
--- a/deskutils/ical/files/patch-aa
+++ b/deskutils/ical/files/patch-aa
@@ -1,5 +1,63 @@
--- cal_tcl.C.orig Sun Nov 28 17:29:13 1999
+++ cal_tcl.C Sun Nov 28 17:30:24 1999
+@@ -214,27 +214,27 @@ static int cal_loopf (ClientData, Tcl_In
+ static int cal_loopb (ClientData, Tcl_Interp*, int, char*[]);
+
+ static Dispatch_Entry calendar_dispatch[] = {
+- { "delete", 0, 0, cal_delete },
+- { "main", 0, 0, cal_main },
+- { "include", 1, 1, cal_include },
+- { "exclude", 1, 1, cal_exclude },
+- { "forincludes", 2, 2, cal_forincs },
+- { "add", 1, 2, cal_add },
+- { "remove", 1, 1, cal_remove },
+- { "hide", 1, 1, cal_hide },
+- { "readonly", 0, 1, cal_ronly },
+- { "dirty", 0, 1, cal_dirty },
+- { "stale", 0, 1, cal_stale },
+- { "save", 0, 1, cal_save },
+- { "reread", 0, 1, cal_reread },
+- { "query", 5, 7, cal_query },
+- { "listing", 5, 7, cal_listing },
+- { "loop", 2, 4, cal_loop },
+- { "incalendar", 3, 3, cal_incal },
+- { "option", 1, 4, cal_option },
+- { "delete_option", 1, 3, cal_doption },
+- { "loop_forward", 5, 7, cal_loopf },
+- { "loop_backward", 5, 7, cal_loopb },
++ { "delete", 0, 0, (Tcl_CmdProc *)cal_delete },
++ { "main", 0, 0, (Tcl_CmdProc *)cal_main },
++ { "include", 1, 1, (Tcl_CmdProc *)cal_include },
++ { "exclude", 1, 1, (Tcl_CmdProc *)cal_exclude },
++ { "forincludes", 2, 2, (Tcl_CmdProc *)cal_forincs },
++ { "add", 1, 2, (Tcl_CmdProc *)cal_add },
++ { "remove", 1, 1, (Tcl_CmdProc *)cal_remove },
++ { "hide", 1, 1, (Tcl_CmdProc *)cal_hide },
++ { "readonly", 0, 1, (Tcl_CmdProc *)cal_ronly },
++ { "dirty", 0, 1, (Tcl_CmdProc *)cal_dirty },
++ { "stale", 0, 1, (Tcl_CmdProc *)cal_stale },
++ { "save", 0, 1, (Tcl_CmdProc *)cal_save },
++ { "reread", 0, 1, (Tcl_CmdProc *)cal_reread },
++ { "query", 5, 7, (Tcl_CmdProc *)cal_query },
++ { "listing", 5, 7, (Tcl_CmdProc *)cal_listing },
++ { "loop", 2, 4, (Tcl_CmdProc *)cal_loop },
++ { "incalendar", 3, 3, (Tcl_CmdProc *)cal_incal },
++ { "option", 1, 4, (Tcl_CmdProc *)cal_option },
++ { "delete_option", 1, 3, (Tcl_CmdProc *)cal_doption },
++ { "loop_forward", 5, 7, (Tcl_CmdProc *)cal_loopf },
++ { "loop_backward", 5, 7, (Tcl_CmdProc *)cal_loopb },
+ { 0, 0, 0, 0 }
+ };
+
+@@ -281,7 +281,7 @@ static int parse_items(Tcl_Interp* tcl,
+
+ if ((argc >= 2) && (strcmp(argv[0], "-items") == 0)) {
+ int count;
+- char** list;
++ CONST84 char** list;
+ if (Tcl_SplitList(tcl, argv[1], &count, &list) != TCL_OK) {
+ TCL_Error(tcl, "invalid item list");
+ }
@@ -516,7 +516,7 @@
TCL_Error(tcl, "no such calendar");
}
diff --git a/deskutils/ical/files/patch-ab b/deskutils/ical/files/patch-ab
index ae2264c1c776..acef1336c29c 100644
--- a/deskutils/ical/files/patch-ab
+++ b/deskutils/ical/files/patch-ab
@@ -1,5 +1,104 @@
--- item_tcl.C.orig Sun Nov 28 17:31:26 1999
+++ item_tcl.C Sun Nov 28 17:32:25 1999
+@@ -106,52 +106,52 @@
+ static int item_mlweekday (ClientData, Tcl_Interp*, int, char*[]);
+
+ static Dispatch_Entry item_dispatch[] = {
+- { "delete", 0, 0, item_delete },
+- { "clone", 0, 0, item_clone },
++ { "delete", 0, 0, (Tcl_CmdProc *)item_delete },
++ { "clone", 0, 0, (Tcl_CmdProc *)item_clone },
+
+- { "length", 0, 1, item_length },
+- { "starttime", 0, 1, item_startt },
+- { "alarms", 0, 1, item_alarms },
+- { "option", 1, 2, item_option },
+- { "delete_option", 1, 1, item_doption },
+-
+- { "is", 1, 1, item_is },
+- { "calendar", 0, 0, item_cal },
+- { "text", 0, 1, item_text },
+- { "uid", 0, 0, item_uid },
+- { "earlywarning", 0, 1, item_early },
+- { "owner", 0, 1, item_owner },
+- { "owned", 0, 0, item_owned },
+- { "own", 0, 0, item_own },
+- { "hilite", 0, 1, item_hilite },
+- { "todo", 0, 1, item_todo },
+- { "is_done", 0, 0, item_is_done },
+- { "done", 1, 1, item_done },
+-
+- { "contains", 1, 1, item_cont },
+- { "empty", 0, 0, item_empty },
+- { "repeats", 0, 0, item_repeat },
+- { "first", 0, 0, item_first },
+- { "next", 1, 1, item_next },
+- { "range", 2, 2, item_range },
+- { "type", 0, 0, item_type },
+- { "describe_repeat", 0, 0, item_desc },
+-
+- { "date", 1, 1, item_date },
+- { "dayrepeat", 2, 2, item_dayr },
+-
+- { "monthrepeat", 2, 2, item_monthr },
+- { "month_day", 1, 3, item_mday },
+- { "month_last_day", 1, 3, item_mlday },
+- { "month_work_day", 1, 3, item_mworkday },
+- { "month_last_work_day", 1, 3, item_mlworkday },
+- { "month_week_day", 2, 4, item_mweekday },
+- { "month_last_week_day", 2, 4, item_mlweekday },
+-
+- { "weekdays", 0, -1, item_wdays },
+- { "start", 1, 1, item_start },
+- { "finish", 1, 1, item_finish },
+- { "deleteon", 1, 1, item_ondel },
++ { "length", 0, 1, (Tcl_CmdProc *)item_length },
++ { "starttime", 0, 1, (Tcl_CmdProc *)item_startt },
++ { "alarms", 0, 1, (Tcl_CmdProc *)item_alarms },
++ { "option", 1, 2, (Tcl_CmdProc *)item_option },
++ { "delete_option", 1, 1, (Tcl_CmdProc *)item_doption },
++
++ { "is", 1, 1, (Tcl_CmdProc *)item_is },
++ { "calendar", 0, 0, (Tcl_CmdProc *)item_cal },
++ { "text", 0, 1, (Tcl_CmdProc *)item_text },
++ { "uid", 0, 0, (Tcl_CmdProc *)item_uid },
++ { "earlywarning", 0, 1, (Tcl_CmdProc *)item_early },
++ { "owner", 0, 1, (Tcl_CmdProc *)item_owner },
++ { "owned", 0, 0, (Tcl_CmdProc *)item_owned },
++ { "own", 0, 0, (Tcl_CmdProc *)item_own },
++ { "hilite", 0, 1, (Tcl_CmdProc *)item_hilite },
++ { "todo", 0, 1, (Tcl_CmdProc *)item_todo },
++ { "is_done", 0, 0, (Tcl_CmdProc *)item_is_done },
++ { "done", 1, 1, (Tcl_CmdProc *)item_done },
++
++ { "contains", 1, 1, (Tcl_CmdProc *)item_cont },
++ { "empty", 0, 0, (Tcl_CmdProc *)item_empty },
++ { "repeats", 0, 0, (Tcl_CmdProc *)item_repeat },
++ { "first", 0, 0, (Tcl_CmdProc *)item_first },
++ { "next", 1, 1, (Tcl_CmdProc *)item_next },
++ { "range", 2, 2, (Tcl_CmdProc *)item_range },
++ { "type", 0, 0, (Tcl_CmdProc *)item_type },
++ { "describe_repeat", 0, 0, (Tcl_CmdProc *)item_desc },
++
++ { "date", 1, 1, (Tcl_CmdProc *)item_date },
++ { "dayrepeat", 2, 2, (Tcl_CmdProc *)item_dayr },
++
++ { "monthrepeat", 2, 2, (Tcl_CmdProc *)item_monthr },
++ { "month_day", 1, 3, (Tcl_CmdProc *)item_mday },
++ { "month_last_day", 1, 3, (Tcl_CmdProc *)item_mlday },
++ { "month_work_day", 1, 3, (Tcl_CmdProc *)item_mworkday },
++ { "month_last_work_day", 1, 3, (Tcl_CmdProc *)item_mlworkday },
++ { "month_week_day", 2, 4, (Tcl_CmdProc *)item_mweekday },
++ { "month_last_week_day", 2, 4, (Tcl_CmdProc *)item_mlweekday },
++
++ { "weekdays", 0, -1, (Tcl_CmdProc *)item_wdays },
++ { "start", 1, 1, (Tcl_CmdProc *)item_start },
++ { "finish", 1, 1, (Tcl_CmdProc *)item_finish },
++ { "deleteon", 1, 1, (Tcl_CmdProc *)item_ondel },
+
+ { 0, 0, 0, 0 }
+ };
++++ item_tcl.C Sun Nov 28 17:32:25 1999
@@ -329,7 +329,7 @@
static int item_owned(ClientData c, Tcl_Interp* tcl, int argc, char* argv[]) {
@@ -9,6 +108,15 @@
}
static int item_own(ClientData c, Tcl_Interp* tcl, int argc, char* argv[]) {
+@@ -431,7 +431,7 @@ static int item_alarms(ClientData c, Tcl
+ }
+
+ int count;
+- char** list;
++ CONST84 char** list;
+ if (Tcl_SplitList(tcl, argv[0], &count, &list) != TCL_OK) {
+ TCL_Error(tcl, "invalid alarm list");
+ }
@@ -492,12 +492,12 @@
static int item_empty(ClientData c, Tcl_Interp* tcl, int argc, char* argv[]) {
diff --git a/deskutils/ical/files/patch-dateeditor.C b/deskutils/ical/files/patch-dateeditor.C
new file mode 100644
index 000000000000..f869d6c57f4c
--- /dev/null
+++ b/deskutils/ical/files/patch-dateeditor.C
@@ -0,0 +1,11 @@
+--- dateeditor.C.orig 1996-02-10 04:17:35.000000000 +0100
++++ dateeditor.C 2003-04-28 18:14:32.000000000 +0200
+@@ -113,7 +113,7 @@ int Cmd_HiliteLoop(ClientData, Tcl_Inter
+ }
+
+ int count;
+- char** strlist;
++ CONST84 char** strlist;
+ if (Tcl_SplitList(tcl, argv[2], &count, &strlist) != TCL_OK) {
+ return TCL_ERROR;
+ }
diff --git a/deskutils/ical/files/patch-dispatch.C b/deskutils/ical/files/patch-dispatch.C
new file mode 100644
index 000000000000..c495c7b21ed4
--- /dev/null
+++ b/deskutils/ical/files/patch-dispatch.C
@@ -0,0 +1,11 @@
+--- dispatch.C.orig 1994-05-20 05:21:54.000000000 +0200
++++ dispatch.C 2003-04-28 18:14:32.000000000 +0200
+@@ -24,7 +24,7 @@ int Dispatch(Dispatch_Entry* table, Clie
+ if ((entry->max_arg_count >= 0) && (argc > entry->max_arg_count)) {
+ TCL_Error(tcl, "too many arguments");
+ }
+- return entry->handler(c, tcl, argc, argv);
++ return entry->handler(c, tcl, argc, (CONST84 char **)argv);
+ }
+ }
+
diff --git a/deskutils/ical/files/patch-ical.h b/deskutils/ical/files/patch-ical.h
new file mode 100644
index 000000000000..b2a29fa52e85
--- /dev/null
+++ b/deskutils/ical/files/patch-ical.h
@@ -0,0 +1,14 @@
+--- ical.h.orig 1996-02-10 04:17:36.000000000 +0100
++++ ical.h 2003-04-28 18:14:32.000000000 +0200
+@@ -4,6 +4,11 @@
+
+ #include <tcl.h>
+
++// That was introduced in tcl8.4
++#ifndef CONST84
++#define CONST84
++#endif
++
+ // Proc for triggering tcl code based on changes
+ // to calendars/items.
+
diff --git a/deskutils/ical/files/patch-main.C b/deskutils/ical/files/patch-main.C
new file mode 100644
index 000000000000..369021ca0ce7
--- /dev/null
+++ b/deskutils/ical/files/patch-main.C
@@ -0,0 +1,25 @@
+--- main.C.tcl84fixes 1996-02-16 02:57:42.000000000 +0100
++++ main.C 2003-04-28 18:14:32.000000000 +0200
+@@ -255,14 +255,14 @@ int Ical_Init(Tcl_Interp* tcl) {
+ return TCL_ERROR;
+
+ // Non-Tk ical commands
+- Tcl_CreateCommand(tcl, "calendar", Cmd_CreateCalendar, NULL, NULL);
+- Tcl_CreateCommand(tcl, "notice", Cmd_CreateNotice, NULL, NULL);
+- Tcl_CreateCommand(tcl, "appointment", Cmd_CreateAppt, NULL, NULL);
+- Tcl_CreateCommand(tcl, "date", Cmd_Date, NULL, NULL);
+- Tcl_CreateCommand(tcl, "ical_time", Cmd_Time, NULL, NULL);
+- Tcl_CreateCommand(tcl, "de_monthdays", Cmd_MonthDays, NULL, NULL);
+- Tcl_CreateCommand(tcl, "hilite_loop", Cmd_HiliteLoop, NULL, NULL);
+- Tcl_CreateCommand(tcl, "ical_expand_file_name", Cmd_ExpandFileName, 0, 0);
++ Tcl_CreateCommand(tcl, "calendar", (Tcl_CmdProc *)Cmd_CreateCalendar, NULL, NULL);
++ Tcl_CreateCommand(tcl, "notice", (Tcl_CmdProc *)Cmd_CreateNotice, NULL, NULL);
++ Tcl_CreateCommand(tcl, "appointment", (Tcl_CmdProc *)Cmd_CreateAppt, NULL, NULL);
++ Tcl_CreateCommand(tcl, "date", (Tcl_CmdProc *)Cmd_Date, NULL, NULL);
++ Tcl_CreateCommand(tcl, "ical_time", (Tcl_CmdProc *)Cmd_Time, NULL, NULL);
++ Tcl_CreateCommand(tcl, "de_monthdays", (Tcl_CmdProc *)Cmd_MonthDays, NULL, NULL);
++ Tcl_CreateCommand(tcl, "hilite_loop", (Tcl_CmdProc *)Cmd_HiliteLoop, NULL, NULL);
++ Tcl_CreateCommand(tcl, "ical_expand_file_name", (Tcl_CmdProc *)Cmd_ExpandFileName, 0, 0);
+
+ #ifdef STANDALONE
+ // Load tcllib files
diff --git a/deskutils/ical/files/patch-object.C b/deskutils/ical/files/patch-object.C
new file mode 100644
index 000000000000..61f532459c2c
--- /dev/null
+++ b/deskutils/ical/files/patch-object.C
@@ -0,0 +1,20 @@
+--- object.C.orig 1994-05-20 05:22:04.000000000 +0200
++++ object.C 2003-04-28 18:14:32.000000000 +0200
+@@ -33,7 +33,7 @@ void Object::init(Tcl_Interp* t, char co
+ interp = t;
+
+ /* Create TCL Command */
+- Tcl_CreateCommand(interp, name, obj_handle, (ClientData) this, NULL);
++ Tcl_CreateCommand(interp, name, (Tcl_CmdProc *)obj_handle, (ClientData) this, NULL);
+ }
+
+ Object::~Object() {
+@@ -46,7 +46,7 @@ Object::~Object() {
+ Object* Object::find(Tcl_Interp* tcl, char const* h) {
+ Tcl_CmdInfo i;
+
+- if (Tcl_GetCommandInfo(tcl, (char*)h, &i) && (i.proc == obj_handle))
++ if (Tcl_GetCommandInfo(tcl, (char*)h, &i) && (i.proc == (Tcl_CmdProc *)obj_handle))
+ return ((Object*) i.clientData);
+
+ return 0;
diff --git a/deskutils/ical/files/patch-pref.tcl b/deskutils/ical/files/patch-pref.tcl
new file mode 100644
index 000000000000..09337cafcfb9
--- /dev/null
+++ b/deskutils/ical/files/patch-pref.tcl
@@ -0,0 +1,16 @@
+--- pref.tcl.orig 1997-06-13 00:50:36.000000000 +0200
++++ pref.tcl 2003-04-28 18:46:04.000000000 +0200
+@@ -118,7 +118,12 @@ proc pref_init {} {
+ # XXX People do not seem to like the motif-style popup behavior
+ global tk_strictMotif
+ if {!$tk_strictMotif} {
+- bind Menubutton <Any-ButtonRelease-1> {tkMenuUnpost {}}
++ set tv [info tclversion]
++ if {[package vcompare $tv 8.4] >= 0} {
++ bind Menubutton <Any-ButtonRelease-1> {::tk::MenuUnpost {}}
++ } else {
++ bind Menubutton <Any-ButtonRelease-1> {tkMenuUnpost {}}
++ }
+ }
+
+ # Handle command line preferences