aboutsummaryrefslogtreecommitdiff
path: root/deskutils/jlj/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-30 19:32:23 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-30 19:32:23 +0000
commitb8689d95f0f2b62fbca7c0f36e591a417322c230 (patch)
tree14fd17b4581a52219d77f5271dc2ed6f049f1a14 /deskutils/jlj/Makefile
parentf84a8cef42afc5a7be29ac3e76352a3fea769e47 (diff)
downloadports-b8689d95f0f2b62fbca7c0f36e591a417322c230.tar.gz
ports-b8689d95f0f2b62fbca7c0f36e591a417322c230.zip
Stage support
Notes
Notes: svn path=/head/; revision=341875
Diffstat (limited to 'deskutils/jlj/Makefile')
-rw-r--r--deskutils/jlj/Makefile21
1 files changed, 7 insertions, 14 deletions
diff --git a/deskutils/jlj/Makefile b/deskutils/jlj/Makefile
index f71f2daf34f1..abbc40df75e2 100644
--- a/deskutils/jlj/Makefile
+++ b/deskutils/jlj/Makefile
@@ -20,25 +20,18 @@ SUB_FILES= pkg-message
PLIST_FILES= bin/jlj share/examples/jlj/dot.livejournal.rc
PLIST_DIRS= share/examples/jlj
+PORTDOCS= README
SHEBANG_FILES= jlj.pl
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= README
-.endif
+OPTIONS_DEFINE= DOCS
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/jlj.pl ${PREFIX}/bin/jlj
- @${MKDIR} ${PREFIX}/share/examples/jlj
+ ${INSTALL_SCRIPT} ${WRKSRC}/jlj.pl ${STAGEDIR}${PREFIX}/bin/jlj
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/examples/jlj
${INSTALL_DATA} ${WRKSRC}/.livejournal.rc \
- ${PREFIX}/share/examples/jlj/dot.livejournal.rc
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.JLJ ${DOCSDIR}/README
-.endif
- @${CAT} ${PKGMESSAGE}
+ ${STAGEDIR}${PREFIX}/share/examples/jlj/dot.livejournal.rc
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.JLJ ${STAGEDIR}${DOCSDIR}/README
.include <bsd.port.mk>