aboutsummaryrefslogtreecommitdiff
path: root/deskutils/jlj
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-24 14:17:27 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-24 14:17:27 +0000
commit5f99cf5ae008ea8c599dde3daf88efc968e57b6a (patch)
tree4263d4d4db0806d6dc2e57d3964eab5d958f01a9 /deskutils/jlj
parent2d9788132588683092456bc0b004b96071909940 (diff)
downloadports-5f99cf5ae008ea8c599dde3daf88efc968e57b6a.tar.gz
ports-5f99cf5ae008ea8c599dde3daf88efc968e57b6a.zip
Notes
Diffstat (limited to 'deskutils/jlj')
-rw-r--r--deskutils/jlj/Makefile35
-rw-r--r--deskutils/jlj/distinfo1
-rw-r--r--deskutils/jlj/pkg-comment1
-rw-r--r--deskutils/jlj/pkg-descr7
-rw-r--r--deskutils/jlj/pkg-message3
-rw-r--r--deskutils/jlj/pkg-plist5
6 files changed, 52 insertions, 0 deletions
diff --git a/deskutils/jlj/Makefile b/deskutils/jlj/Makefile
new file mode 100644
index 000000000000..e5d22bd5193d
--- /dev/null
+++ b/deskutils/jlj/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: jlj
+# Date created: 29 April 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jlj
+PORTVERSION= 1.7
+CATEGORIES= deskutils net
+MASTER_SITES= http://www.cis.rit.edu/~jerry/Software/perl/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= petef@databits.net
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e 's!/usr/bin/perl!${PERL}!' ${WRKSRC}/jlj.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/jlj.pl ${PREFIX}/bin/jlj
+ @${MKDIR} ${PREFIX}/share/examples/jlj
+ ${INSTALL_DATA} ${WRKSRC}/.livejournal.rc \
+ ${PREFIX}/share/examples/jlj/dot.livejournal.rc
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/jlj
+ ${INSTALL_DATA} ${WRKSRC}/README.JLJ ${PREFIX}/share/doc/jlj/README
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/deskutils/jlj/distinfo b/deskutils/jlj/distinfo
new file mode 100644
index 000000000000..0a9760f76be1
--- /dev/null
+++ b/deskutils/jlj/distinfo
@@ -0,0 +1 @@
+MD5 (jlj_1.7.tar.gz) = afcecc02e65477b7f5d75810e468e6cc
diff --git a/deskutils/jlj/pkg-comment b/deskutils/jlj/pkg-comment
new file mode 100644
index 000000000000..441d0471998e
--- /dev/null
+++ b/deskutils/jlj/pkg-comment
@@ -0,0 +1 @@
+Jerry's command-line LiveJournal.com entry system
diff --git a/deskutils/jlj/pkg-descr b/deskutils/jlj/pkg-descr
new file mode 100644
index 000000000000..cf848495eebd
--- /dev/null
+++ b/deskutils/jlj/pkg-descr
@@ -0,0 +1,7 @@
+Jerry's LiveJournal system is a command-line system written in perl
+to interact with LiveJournal.com.
+
+WWW: http://www.cis.rit.edu/~jerry/Software/perl/#jlj
+
+- Pete
+petef@databits.net
diff --git a/deskutils/jlj/pkg-message b/deskutils/jlj/pkg-message
new file mode 100644
index 000000000000..ee8e351d5126
--- /dev/null
+++ b/deskutils/jlj/pkg-message
@@ -0,0 +1,3 @@
+Be sure to copy ${PREFIX}/share/examples/jlj/dot.livejournal.rc to
+~/.livejournal.rc before running jlj. More details can be found
+in ${PREFIX}/share/doc/jlj/README.
diff --git a/deskutils/jlj/pkg-plist b/deskutils/jlj/pkg-plist
new file mode 100644
index 000000000000..2f479ba85b18
--- /dev/null
+++ b/deskutils/jlj/pkg-plist
@@ -0,0 +1,5 @@
+bin/jlj
+%%PORTDOCS%%share/doc/jlj/README
+share/examples/jlj/dot.livejournal.rc
+%%PORTDOCS%%@dirrm share/doc/jlj
+@dirrm share/examples/jlj