aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kaddressbook
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-12-08 20:03:07 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-12-08 20:03:07 +0000
commit47b26d9293f196d71c39ba4d82df23d179884405 (patch)
tree3984ac0366432e29f9e1ac47cbac9b18032f7c04 /deskutils/kaddressbook
parent96fd51619a1ebc0b215ab75ccc37ce7ab300ed8b (diff)
downloadports-47b26d9293f196d71c39ba4d82df23d179884405.tar.gz
ports-47b26d9293f196d71c39ba4d82df23d179884405.zip
Update Qt/PySide2 to 5.15.2 / PyQt to 5.15.1 / SIP to 5.4.0
This commit combines several updates. - Update Qt to 5.12.2 - Update PyQt to 5.15.1 - Since PySide 5.15.1 is broken with Qt 5.15.2, so PySide and Shiboken are also updated to 5.15.2. - Update sip to 5.4.0 SIP is a collection of tools to create Python bindings for C and C++ libraries and used by PyQt and wxPython. There are some changes with sip5 [1]: - python 3.5+ is required - sip drops support of old deprecated methods as sipdistutils & cie. - this version breaks also PyQt5 extension ABI. SIP files will be installed in ${PYTHON_SITELIBDIR}/PyQt${_PYQT_VERSION}/bindings - some ports will use the new pyqtbuilder package with the pyproject.toml setup. Instead if the project have a setup.py, you should use sip-build to build it. - if a port needs sip, it should also needs pysip. BTW, py-qt5-core requires pysip, so that should be enough for PyQt packages. List of ports impacted by this change. Most of the patches have been integrated or are in the process of being integrated upstream: - devel/libsavitar - graphics/py-python-poppler-qt5 - net-im/scudcloud - net/libarcus - print/py-frescobaldi - science/py-veusz - graphics/qgis and graphics/qgis-ltr - deskutils/calibre A special note regarding calibre. New versions require sip>=5, we update it to the latest version (thanks to madpilot@) science/scidavis will remove the PyQt binding soon and there is no patch planned, so we remove the python option (ok makc@) While here, convert some ports to USE_PYQT (cad/cura, cad/uranium, devel/eric6, ...) Thanks to tcberner and adridg! [1] https://www.riverbankcomputing.com/static/Docs/sip/ PR: 250853 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=557300
Diffstat (limited to 'deskutils/kaddressbook')
-rw-r--r--deskutils/kaddressbook/files/patch-git-8aee8d40ae2a1c920d3520163d550d3b49720226.diff60
1 files changed, 60 insertions, 0 deletions
diff --git a/deskutils/kaddressbook/files/patch-git-8aee8d40ae2a1c920d3520163d550d3b49720226.diff b/deskutils/kaddressbook/files/patch-git-8aee8d40ae2a1c920d3520163d550d3b49720226.diff
new file mode 100644
index 000000000000..7c891d615b8c
--- /dev/null
+++ b/deskutils/kaddressbook/files/patch-git-8aee8d40ae2a1c920d3520163d550d3b49720226.diff
@@ -0,0 +1,60 @@
+Author: Volker Krause <vkrause@kde.org>
+Date: Sun Oct 25 18:22:58 2020 +0100
+
+ Compile with recent Qt 5.15
+
+ More QPrinter methods got deprecated there. DevicePixel no longer exists
+ as a unit, visually Point looks pretty much the same though.
+
+diff --git src/printing/compact/compactstyle.cpp src/printing/compact/compactstyle.cpp
+index d950a963..71e74c0f 100644
+--- src/printing/compact/compactstyle.cpp
++++ src/printing/compact/compactstyle.cpp
+@@ -168,7 +168,7 @@ void CompactStyle::print(const KContacts::Addressee::List &contacts, PrintProgre
+
+ // print
+ QPrinter *printer = wizard()->printer();
+- printer->setPageMargins(20, 20, 20, 20, QPrinter::DevicePixel);
++ printer->setPageMargins(QMarginsF(20, 20, 20, 20), QPageLayout::Point);
+
+ progress->addMessage(i18n("Setting up document"));
+
+diff --git src/printing/grantlee/grantleeprintstyle.cpp src/printing/grantlee/grantleeprintstyle.cpp
+index d7afe8ef..49b5e494 100644
+--- src/printing/grantlee/grantleeprintstyle.cpp
++++ src/printing/grantlee/grantleeprintstyle.cpp
+@@ -38,7 +38,7 @@ GrantleePrintStyle::~GrantleePrintStyle()
+ void GrantleePrintStyle::print(const KContacts::Addressee::List &contacts, PrintProgress *progress)
+ {
+ QPrinter *printer = wizard()->printer();
+- printer->setPageMargins(20, 20, 20, 20, QPrinter::DevicePixel);
++ printer->setPageMargins(QMarginsF(20, 20, 20, 20), QPageLayout::Point);
+
+ progress->addMessage(i18n("Setting up document"));
+
+diff --git src/printing/mike/mikesstyle.cpp src/printing/mike/mikesstyle.cpp
+index 9f698c53..81a4bd6f 100644
+--- src/printing/mike/mikesstyle.cpp
++++ src/printing/mike/mikesstyle.cpp
+@@ -107,7 +107,7 @@ MikesStyle::~MikesStyle()
+ void MikesStyle::print(const KContacts::Addressee::List &contacts, PrintProgress *progress)
+ {
+ QPrinter *printer = wizard()->printer();
+- printer->setPageMargins(20, 20, 20, 20, QPrinter::DevicePixel);
++ printer->setPageMargins(QMarginsF(20, 20, 20, 20), QPageLayout::Point);
+
+ progress->addMessage(i18n("Setting up document"));
+
+diff --git src/printing/ringbinder/ringbinderstyle.cpp src/printing/ringbinder/ringbinderstyle.cpp
+index 60a39c86..5f600d6a 100644
+--- src/printing/ringbinder/ringbinderstyle.cpp
++++ src/printing/ringbinder/ringbinderstyle.cpp
+@@ -159,7 +159,7 @@ void RingBinderPrintStyle::print(const KContacts::Addressee::List &contacts, Pri
+ config.sync();
+
+ QPrinter *printer = wizard()->printer();
+- printer->setPageMargins(50, 20, 0, 50, QPrinter::DevicePixel);
++ printer->setPageMargins(QMarginsF(50, 20, 0, 50), QPageLayout::Point);
+
+ progress->addMessage(i18n("Setting up document"));
+