aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kalarm
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /deskutils/kalarm
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'deskutils/kalarm')
-rw-r--r--deskutils/kalarm/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/deskutils/kalarm/Makefile b/deskutils/kalarm/Makefile
index bc4d36d9dbd5..226e824dcadd 100644
--- a/deskutils/kalarm/Makefile
+++ b/deskutils/kalarm/Makefile
@@ -10,7 +10,7 @@ COMMENT= Personal alarm scheduler
LIB_DEPENDS= libical.so:devel/libical
-USES= cmake:outsource compiler:c++11-lib gettext kde:5 shebangfix tar:xz
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 qt:5 shebangfix tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons ecm guiaddons i18n iconthemes \
itemmodels itemviews jobwidgets kcmutils kdelibs4support kio \
@@ -21,7 +21,7 @@ USE_KDE+= akonadi akonadicontacts akonadimime alarmcalendar calendarcore \
calendarutils contacts holidays identitymanagement \
kdepim-apps-libs libkdepim mailcommon mailtransport mime \
pimcommon pimtextedit imap
-USE_QT5= core dbus gui network phonon4 printsupport widgets x11extras xml \
+USE_QT= core dbus gui network phonon4 printsupport widgets x11extras xml \
buildtools_build qmake_build
USE_LDCONFIG= yes