aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdepim4
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-08-11 01:27:37 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-08-11 01:27:37 +0000
commit461f3c5adb635525af6de102321df3e6288bfb1c (patch)
tree2025e3327a038c580b6f13bdc201e220e2077bb4 /deskutils/kdepim4
parent5036b1c6d43d4a6652f933702bfcc8b3553fddfd (diff)
downloadports-461f3c5adb635525af6de102321df3e6288bfb1c.tar.gz
ports-461f3c5adb635525af6de102321df3e6288bfb1c.zip
Notes
Diffstat (limited to 'deskutils/kdepim4')
-rw-r--r--deskutils/kdepim4/Makefile10
-rw-r--r--deskutils/kdepim4/files/plist.base.rm208
-rw-r--r--deskutils/kdepim4/files/plist.kpilot99
-rw-r--r--deskutils/kdepim4/files/plist.kpilot.rm17
-rw-r--r--deskutils/kdepim4/pkg-plist (renamed from deskutils/kdepim4/files/plist.base)260
5 files changed, 230 insertions, 364 deletions
diff --git a/deskutils/kdepim4/Makefile b/deskutils/kdepim4/Makefile
index bd4b4717c39f..7e147c85a6ca 100644
--- a/deskutils/kdepim4/Makefile
+++ b/deskutils/kdepim4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kdepim
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= deskutils mail news kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -28,7 +29,7 @@ USE_REINPLACE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
-KDE_BUILD_PLIST=yes
+DO_NOT_COMPILE+=kpilot
OPTIONS= KPILOT "Build KPilot, hotsync software for KDE" off \
GNOKII "KAdressbook import/export for Nokia phones" off
@@ -48,11 +49,7 @@ LIB_DEPENDS+= gnokii:${PORTSDIR}/comms/gnokii
.endif # defined ($(WITH_GNOKII))
.if defined(WITH_KPILOT)
-LIB_DEPENDS+= mal:${PORTSDIR}/palm/libmal \
- pisock:${PORTSDIR}/palm/pilot-link
-PLIST_APPEND+= plist.kpilot
-.elseif defined(WITHOUT_KPILOT)
-DO_NOT_COMPILE+=kpilot
+RUN_DEPENDS+= kpilot:${PORTSDIR}/palm/kpilot
.endif
.if defined(DO_NOT_COMPILE)
@@ -72,5 +69,6 @@ pre-everything::
pre-configure:
${REINPLACE_CMD} -e 's|-ldl||' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|-lgnokii|-lgnokii -liconv -lintl|' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e '/^SUBDIRS/s/kpilot//g' ${WRKSRC}/doc/Makefile.in
.include <bsd.port.post.mk>
diff --git a/deskutils/kdepim4/files/plist.base.rm b/deskutils/kdepim4/files/plist.base.rm
deleted file mode 100644
index b7fde2f7fea9..000000000000
--- a/deskutils/kdepim4/files/plist.base.rm
+++ /dev/null
@@ -1,208 +0,0 @@
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/libkpimexchange/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/libkdepim/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/libkcal/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/ksync/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/korganizer/korgac/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/korganizer/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/kontact/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/konsolekalendar/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/knotes/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/kmail/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/kgantt/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/kfile-plugins/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/karm/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/kandy/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/kalarmd/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/kaddressbook/html || true
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/kabc/kabc2mutt/html || true
-@dirrm share/servicetypes
-@dirrm share/services/kresources/kcal
-@dirrm share/services/kresources/kabc
-@dirrm share/services/kresources
-@dirrm share/services/korganizer
-@dirrm share/services/kontact
-@dirrm share/services/kaddressbook
-@dirrm share/services
-@dirrm share/mimelnk/application
-@dirrm share/mimelnk
-@dirrm share/icons/locolor/32x32/apps
-@dirrm share/icons/locolor/32x32
-@dirrm share/icons/locolor/16x16/apps
-@dirrm share/icons/locolor/16x16
-@dirrm share/icons/locolor
-@dirrm share/icons/hicolor/48x48/apps
-@dirrm share/icons/hicolor/48x48
-@dirrm share/icons/hicolor
-@dirrm share/icons/crystalsvg/64x64/apps
-@dirrm share/icons/crystalsvg/64x64/actions
-@dirrm share/icons/crystalsvg/64x64
-@dirrm share/icons/crystalsvg/48x48/apps
-@dirrm share/icons/crystalsvg/48x48
-@dirrm share/icons/crystalsvg/32x32/apps
-@dirrm share/icons/crystalsvg/32x32/actions
-@dirrm share/icons/crystalsvg/32x32
-@dirrm share/icons/crystalsvg/22x22/apps
-@dirrm share/icons/crystalsvg/22x22/actions
-@dirrm share/icons/crystalsvg/22x22
-@dirrm share/icons/crystalsvg/16x16/apps
-@dirrm share/icons/crystalsvg/16x16/actions
-@dirrm share/icons/crystalsvg/16x16
-@dirrm share/icons/crystalsvg/128x128/apps
-@dirrm share/icons/crystalsvg/128x128
-@dirrm share/icons/crystalsvg
-@dirrm share/icons
-@dirrm share/doc/HTML/en/kpilot
-@dirrm share/doc/HTML/en/korn
-@dirrm share/doc/HTML/en/korganizer
-@dirrm share/doc/HTML/en/kontact
-@dirrm share/doc/HTML/en/konsolekalendar
-@dirrm share/doc/HTML/en/knotes
-@dirrm share/doc/HTML/en/knode
-@dirrm share/doc/HTML/en/kmail
-@dirrm share/doc/HTML/en/kgpgcertmanager
-@dirrm share/doc/HTML/en/kdepim-apidocs/libkpimexchange
-@dirrm share/doc/HTML/en/kdepim-apidocs/libkdepim
-@dirrm share/doc/HTML/en/kdepim-apidocs/libkcal
-@dirrm share/doc/HTML/en/kdepim-apidocs/ksync
-@dirrm share/doc/HTML/en/kdepim-apidocs/korganizer/korgac
-@dirrm share/doc/HTML/en/kdepim-apidocs/korganizer
-@dirrm share/doc/HTML/en/kdepim-apidocs/kontact
-@dirrm share/doc/HTML/en/kdepim-apidocs/konsolekalendar
-@dirrm share/doc/HTML/en/kdepim-apidocs/knotes
-@dirrm share/doc/HTML/en/kdepim-apidocs/kmail
-@dirrm share/doc/HTML/en/kdepim-apidocs/kgantt
-@dirrm share/doc/HTML/en/kdepim-apidocs/kfile-plugins
-@dirrm share/doc/HTML/en/kdepim-apidocs/karm
-@dirrm share/doc/HTML/en/kdepim-apidocs/kandy
-@dirrm share/doc/HTML/en/kdepim-apidocs/kalarmd
-@dirrm share/doc/HTML/en/kdepim-apidocs/kaddressbook
-@dirrm share/doc/HTML/en/kdepim-apidocs/kabc/kabc2mutt
-@dirrm share/doc/HTML/en/kdepim-apidocs/kabc
-@dirrm share/doc/HTML/en/kdepim-apidocs
-@dirrm share/doc/HTML/en/kcontrol/kalarmd
-@dirrm share/doc/HTML/en/kcontrol
-@dirrm share/doc/HTML/en/karm
-@dirrm share/doc/HTML/en/kandy
-@dirrm share/doc/HTML/en/kalarm
-@dirrm share/doc/HTML/en/kaddressbook
-@dirrm share/doc/HTML/en
-@dirrm share/doc/HTML
-@dirrm share/config.kcfg
-@dirrm share/config
-@dirrm share/autostart
-@dirrm share/apps/ktnef/icons/locolor/16x16/actions
-@dirrm share/apps/ktnef/icons/locolor/16x16
-@dirrm share/apps/ktnef/icons/locolor
-@dirrm share/apps/ktnef/icons/hicolor/22x22/actions
-@dirrm share/apps/ktnef/icons/hicolor/22x22
-@dirrm share/apps/ktnef/icons/hicolor
-@dirrm share/apps/ktnef/icons
-@dirrm share/apps/ktnef
-@dirrm share/apps/ksync
-@dirrm share/apps/korganizer/sounds
-@dirrm share/apps/korganizer/plugins
-@dirrm share/apps/korganizer/icons/crystalsvg/32x32/actions
-@dirrm share/apps/korganizer/icons/crystalsvg/32x32
-@dirrm share/apps/korganizer/icons/crystalsvg/22x22/actions/emptybox
-@dirrm share/apps/korganizer/icons/crystalsvg/22x22/actions
-@dirrm share/apps/korganizer/icons/crystalsvg/22x22
-@dirrm share/apps/korganizer/icons/crystalsvg/16x16/actions
-@dirrm share/apps/korganizer/icons/crystalsvg/16x16
-@dirrm share/apps/korganizer/icons/crystalsvg
-@dirrm share/apps/korganizer/icons
-@dirrm share/apps/korganizer
-@dirrm share/apps/korgac/icons/crystalsvg/22x22/actions
-@dirrm share/apps/korgac/icons/crystalsvg/22x22
-@dirrm share/apps/korgac/icons/crystalsvg
-@dirrm share/apps/korgac/icons
-@dirrm share/apps/korgac
-@dirrm share/apps/kontactsummary
-@dirrm share/apps/kontact/pics
-@dirrm share/apps/kontact
-@dirrm share/apps/knotes/icons/crystalsvg/16x16/actions
-@dirrm share/apps/knotes/icons/crystalsvg/16x16
-@dirrm share/apps/knotes/icons/crystalsvg
-@dirrm share/apps/knotes/icons
-@dirrm share/apps/knotes
-@dirrm share/apps/knode/pics
-@dirrm share/apps/knode/icons/crystalsvg/32x32/actions
-@dirrm share/apps/knode/icons/crystalsvg/32x32
-@dirrm share/apps/knode/icons/crystalsvg/22x22/actions
-@dirrm share/apps/knode/icons/crystalsvg/22x22
-@dirrm share/apps/knode/icons/crystalsvg/16x16/actions
-@dirrm share/apps/knode/icons/crystalsvg/16x16
-@dirrm share/apps/knode/icons/crystalsvg
-@dirrm share/apps/knode/icons
-@dirrm share/apps/knode/filters
-@dirrm share/apps/knode
-@dirrm share/apps/knewstuff
-@dirrm share/apps/kmailcvt/pics
-@dirrm share/apps/kmailcvt
-@dirrm share/apps/kmail/pics
-@dirrm share/apps/kmail/icons/crystalsvg/48x48/actions
-@dirrm share/apps/kmail/icons/crystalsvg/48x48
-@dirrm share/apps/kmail/icons/crystalsvg/32x32/actions
-@dirrm share/apps/kmail/icons/crystalsvg/32x32
-@dirrm share/apps/kmail/icons/crystalsvg/22x22/actions
-@dirrm share/apps/kmail/icons/crystalsvg/22x22
-@dirrm share/apps/kmail/icons/crystalsvg/16x16/actions
-@dirrm share/apps/kmail/icons/crystalsvg/16x16
-@dirrm share/apps/kmail/icons/crystalsvg
-@dirrm share/apps/kmail/icons
-@dirrm share/apps/kmail/about
-@dirrm share/apps/kmail
-@dirrm share/apps/kgpgcertmanager
-@dirrm share/apps/kgantt/icons/crystalsvg/32x32/actions
-@dirrm share/apps/kgantt/icons/crystalsvg/32x32
-@dirrm share/apps/kgantt/icons/crystalsvg/22x22/actions
-@dirrm share/apps/kgantt/icons/crystalsvg/22x22
-@dirrm share/apps/kgantt/icons/crystalsvg/16x16/actions
-@dirrm share/apps/kgantt/icons/crystalsvg/16x16
-@dirrm share/apps/kgantt/icons/crystalsvg
-@dirrm share/apps/kgantt/icons
-@dirrm share/apps/kgantt
-@dirrm share/apps/kconf_update
-@dirrm share/apps/karm/pics
-@dirrm share/apps/karm
-@dirrm share/apps/kandy
-@dirrm share/apps/kalarm/icons/crystalsvg/22x22/actions
-@dirrm share/apps/kalarm/icons/crystalsvg/22x22
-@dirrm share/apps/kalarm/icons/crystalsvg/16x16/actions
-@dirrm share/apps/kalarm/icons/crystalsvg/16x16
-@dirrm share/apps/kalarm/icons/crystalsvg
-@dirrm share/apps/kalarm/icons
-@dirrm share/apps/kalarm
-@dirrm share/apps/kaddressbook/printing
-@dirrm share/apps/kaddressbook/pics
-@dirrm share/apps/kaddressbook/icons/locolor/22x22/actions
-@dirrm share/apps/kaddressbook/icons/locolor/22x22
-@dirrm share/apps/kaddressbook/icons/locolor/16x16/actions
-@dirrm share/apps/kaddressbook/icons/locolor/16x16
-@dirrm share/apps/kaddressbook/icons/locolor
-@dirrm share/apps/kaddressbook/icons/crystalsvg/32x32/actions
-@dirrm share/apps/kaddressbook/icons/crystalsvg/32x32
-@dirrm share/apps/kaddressbook/icons/crystalsvg/16x16/actions
-@dirrm share/apps/kaddressbook/icons/crystalsvg/16x16
-@dirrm share/apps/kaddressbook/icons/crystalsvg
-@dirrm share/apps/kaddressbook/icons
-@dirrm share/apps/kaddressbook/csv-templates
-@dirrm share/apps/kaddressbook
-@dirrm share/apps
-@dirrm share/applnk/Utilities
-@dirrm share/applnk/Applications
-@dirrm share/applnk/.hidden
-@dirrm share/applnk
-@dirrm share/applications/kde
-@dirrm share/applications
-@dirrm lib/kde3
-@dirrm include/mimelib
-@dirrm include/libkcal
-@dirrm include/ktnef
-@dirrm include/ksieve
-@dirrm include/korganizer
-@dirrm include/kontact
-@dirrm include/knewstuff
-@dirrm include/kgantt
-@dirrm include/kdepim
-@dirrm include/kaddressbook
-@dirrm include/calendar
diff --git a/deskutils/kdepim4/files/plist.kpilot b/deskutils/kdepim4/files/plist.kpilot
deleted file mode 100644
index 52ac53ef75da..000000000000
--- a/deskutils/kdepim4/files/plist.kpilot
+++ /dev/null
@@ -1,99 +0,0 @@
-bin/kpalmdoc
-bin/kpilot
-bin/kpilotDaemon
-include/kpilot/kpilotlink.h
-include/kpilot/pilotDatabase.h
-include/kpilot/pilotLocalDatabase.h
-include/kpilot/pilotRecord.h
-include/kpilot/pilotSerialDatabase.h
-include/kpilot/plugin.h
-include/kpilot/syncAction.h
-include/kpilot/uiDialog.h
-lib/kde3/conduit_address.la
-lib/kde3/conduit_address.so
-lib/kde3/conduit_doc.la
-lib/kde3/conduit_doc.so
-lib/kde3/conduit_knotes.la
-lib/kde3/conduit_knotes.so
-lib/kde3/conduit_mal.la
-lib/kde3/conduit_mal.so
-lib/kde3/conduit_popmail.la
-lib/kde3/conduit_popmail.so
-lib/kde3/conduit_sysinfo.la
-lib/kde3/conduit_sysinfo.so
-lib/kde3/conduit_time.la
-lib/kde3/conduit_time.so
-lib/kde3/conduit_todo.la
-lib/kde3/conduit_todo.so
-lib/kde3/conduit_vcal.la
-lib/kde3/conduit_vcal.so
-lib/libkpilot.la
-lib/libkpilot.so
-lib/libkpilot.so.0
-share/applications/kde/kpalmdoc.desktop
-share/applications/kde/kpilot.desktop
-share/applications/kde/kpilotdaemon.desktop
-share/apps/kpilot/icons/crystalsvg/16x16/actions/backup.png
-share/apps/kpilot/icons/crystalsvg/16x16/actions/busysync.png
-share/apps/kpilot/icons/crystalsvg/16x16/actions/fastsync.png
-share/apps/kpilot/icons/crystalsvg/16x16/actions/hotsync.png
-share/apps/kpilot/icons/crystalsvg/16x16/actions/restore.png
-share/apps/kpilot/icons/crystalsvg/16x16/apps/kpalmdoc.png
-share/apps/kpilot/icons/crystalsvg/22x22/actions/backup.png
-share/apps/kpilot/icons/crystalsvg/22x22/actions/busysync.png
-share/apps/kpilot/icons/crystalsvg/22x22/actions/fastsync.png
-share/apps/kpilot/icons/crystalsvg/22x22/actions/hotsync.png
-share/apps/kpilot/icons/crystalsvg/22x22/actions/restore.png
-share/apps/kpilot/icons/crystalsvg/22x22/apps/kpalmdoc.png
-share/apps/kpilot/icons/crystalsvg/32x32/apps/kpalmdoc.png
-share/apps/kpilot/icons/crystalsvg/48x48/apps/kpalmdoc.png
-share/apps/kpilot/kpilot-address.png
-share/apps/kpilot/kpilot-calendar.png
-share/apps/kpilot/kpilot-db.png
-share/apps/kpilot/kpilot-fileinstaller.png
-share/apps/kpilot/kpilot-hotsync.png
-share/apps/kpilot/kpilot-knotes.png
-share/apps/kpilot/kpilot-splash.png
-share/apps/kpilot/kpilot-todo.png
-share/apps/kpilot/kpilotui.rc
-share/apps/kpilot/sysinfoconduit/Template.html
-share/apps/kpilot/sysinfoconduit/Template.txt
-share/icons/crystalsvg/16x16/apps/kpalmdoc.png
-share/icons/crystalsvg/16x16/apps/kpilot.png
-share/icons/crystalsvg/16x16/apps/kpilotDaemon.png
-share/icons/crystalsvg/22x22/apps/kpalmdoc.png
-share/icons/crystalsvg/22x22/apps/kpilot.png
-share/icons/crystalsvg/32x32/apps/kpalmdoc.png
-share/icons/crystalsvg/32x32/apps/kpilot.png
-share/icons/crystalsvg/48x48/apps/kpalmdoc.png
-share/icons/crystalsvg/48x48/apps/kpilot.png
-share/icons/crystalsvg/48x48/apps/kpilotDaemon.png
-share/icons/locolor/16x16/apps/kpilot.png
-share/services/abbrowser_conduit.desktop
-share/services/doc_conduit.desktop
-share/services/knotes-conduit.desktop
-share/services/mal_conduit.desktop
-share/services/popmail-conduit.desktop
-share/services/sysinfo_conduit.desktop
-share/services/time_conduit.desktop
-share/services/todo-conduit.desktop
-share/services/vcal-conduit.desktop
-share/servicetypes/kpilotconduit.desktop
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kabc/kabc2mutt/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kaddressbook/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kalarmd/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kandy/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/karm/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kfile-plugins/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kgantt/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kmail/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/knotes/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/konsolekalendar/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kontact/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/korganizer/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/korganizer/korgac/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kpilot/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/ksync/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/libkcal/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/libkdepim/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/libkpimexchange/html
diff --git a/deskutils/kdepim4/files/plist.kpilot.rm b/deskutils/kdepim4/files/plist.kpilot.rm
deleted file mode 100644
index 7ef3ea71a465..000000000000
--- a/deskutils/kdepim4/files/plist.kpilot.rm
+++ /dev/null
@@ -1,17 +0,0 @@
-@unexec /bin/rmdir %D/share/doc/HTML/en/kdepim-apidocs/kpilot/html || true
-@dirrm share/doc/HTML/en/kdepim-apidocs/kpilot
-@dirrm share/apps/kpilot/sysinfoconduit
-@dirrm share/apps/kpilot/icons/crystalsvg/48x48/apps
-@dirrm share/apps/kpilot/icons/crystalsvg/48x48
-@dirrm share/apps/kpilot/icons/crystalsvg/32x32/apps
-@dirrm share/apps/kpilot/icons/crystalsvg/32x32
-@dirrm share/apps/kpilot/icons/crystalsvg/22x22/apps
-@dirrm share/apps/kpilot/icons/crystalsvg/22x22/actions
-@dirrm share/apps/kpilot/icons/crystalsvg/22x22
-@dirrm share/apps/kpilot/icons/crystalsvg/16x16/apps
-@dirrm share/apps/kpilot/icons/crystalsvg/16x16/actions
-@dirrm share/apps/kpilot/icons/crystalsvg/16x16
-@dirrm share/apps/kpilot/icons/crystalsvg
-@dirrm share/apps/kpilot/icons
-@dirrm share/apps/kpilot
-@dirrm include/kpilot
diff --git a/deskutils/kdepim4/files/plist.base b/deskutils/kdepim4/pkg-plist
index 8e6fde07cf60..7938345058e0 100644
--- a/deskutils/kdepim4/files/plist.base
+++ b/deskutils/kdepim4/pkg-plist
@@ -826,29 +826,6 @@ share/doc/HTML/en/korganizer/outlook-to-vcalendar.docbook
share/doc/HTML/en/korn/common
share/doc/HTML/en/korn/index.cache.bz2
share/doc/HTML/en/korn/index.docbook
-share/doc/HTML/en/kpilot/address-app.png
-share/doc/HTML/en/kpilot/common
-share/doc/HTML/en/kpilot/conduit-knotes.png
-share/doc/HTML/en/kpilot/conduit-popmail-kmail.png
-share/doc/HTML/en/kpilot/conduit-popmail-recv-method.png
-share/doc/HTML/en/kpilot/conduit-popmail-send-as.png
-share/doc/HTML/en/kpilot/conduit-popmail-send-method.png
-share/doc/HTML/en/kpilot/conduit-popmail-sendmail.png
-share/doc/HTML/en/kpilot/conduit-popmail-smtp.png
-share/doc/HTML/en/kpilot/conduit-popmail-top.png
-share/doc/HTML/en/kpilot/conduit-vcal.png
-share/doc/HTML/en/kpilot/file-app.png
-share/doc/HTML/en/kpilot/index.cache.bz2
-share/doc/HTML/en/kpilot/index.docbook
-share/doc/HTML/en/kpilot/main-app.png
-share/doc/HTML/en/kpilot/memo-app.png
-share/doc/HTML/en/kpilot/setup-address.png
-share/doc/HTML/en/kpilot/setup-conduit.png
-share/doc/HTML/en/kpilot/setup-dbspecial.png
-share/doc/HTML/en/kpilot/setup-general.png
-share/doc/HTML/en/kpilot/setup-sync.png
-share/doc/HTML/en/kpilot/toolbar_backup.png
-share/doc/HTML/en/kpilot/toolbar_hotsync.png
share/icons/crystalsvg/128x128/apps/kaddressbook.png
share/icons/crystalsvg/128x128/apps/karm.png
share/icons/crystalsvg/128x128/apps/kmail.png
@@ -977,20 +954,235 @@ share/servicetypes/kaddressbook_view.desktop
share/servicetypes/kaddressbook_xxport.desktop
share/servicetypes/kontactplugin.desktop
share/servicetypes/korganizerpart.desktop
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kabc/kabc2mutt/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kaddressbook/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kalarmd/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kandy/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/libkpimexchange/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/libkpimexchange/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/libkdepim/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/libkdepim/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/libkcal/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/libkcal/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/ksync/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/ksync/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/korganizer/korgac/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/korganizer/korgac/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/korganizer/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/korganizer/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/korganizer/korgac/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kontact/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kontact/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/konsolekalendar/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/konsolekalendar/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/knotes/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/knotes/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kmail/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kmail/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kgantt/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kgantt/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kfile-plugins/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kfile-plugins/html
@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/karm/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/karm/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kandy/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kandy/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kalarmd/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kalarmd/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kaddressbook/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kaddressbook/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kabc/kabc2mutt/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kabc/kabc2mutt/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kabc/kabc2mutt/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kabc/kabc2mutt/html
@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kfile-plugins/html
@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kgantt/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kmail/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/knotes/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/konsolekalendar/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kontact/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/korganizer/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/korganizer/korgac/html
-@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/ksync/html
@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/libkcal/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/knotes/html
@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/libkdepim/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/ksync/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kalarmd/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kmail/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/karm/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kandy/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kaddressbook/html
@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/libkpimexchange/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/korganizer/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/korganizer/korgac/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/konsolekalendar/html
+@exec /bin/mkdir -p %D/share/doc/HTML/en/kdepim-apidocs/kontact/html
+@dirrm share/services/kresources/kcal
+@dirrm share/services/korganizer
+@dirrm share/services/kontact
+@dirrm share/services/kaddressbook
+@dirrm share/icons/locolor/32x32/apps
+@dirrm share/icons/locolor/32x32
+@dirrm share/icons/locolor/16x16/apps
+@dirrm share/icons/locolor/16x16
+@dirrm share/icons/locolor
+@dirrm share/icons/hicolor/48x48/apps
+@dirrm share/icons/hicolor/48x48
+@dirrm share/icons/crystalsvg/64x64/apps
+@dirrm share/icons/crystalsvg/48x48/apps
+@dirrm share/icons/crystalsvg/32x32/apps
+@dirrm share/icons/crystalsvg/22x22/apps
+@dirrm share/icons/crystalsvg/16x16/apps
+@dirrm share/icons/crystalsvg/128x128/apps
+@dirrm share/doc/HTML/en/korn
+@dirrm share/doc/HTML/en/korganizer
+@dirrm share/doc/HTML/en/kontact
+@dirrm share/doc/HTML/en/konsolekalendar
+@dirrm share/doc/HTML/en/knotes
+@dirrm share/doc/HTML/en/knode
+@dirrm share/doc/HTML/en/kmail
+@dirrm share/doc/HTML/en/kgpgcertmanager
+@dirrm share/doc/HTML/en/kdepim-apidocs/libkpimexchange/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/libkpimexchange
+@dirrm share/doc/HTML/en/kdepim-apidocs/libkdepim/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/libkdepim
+@dirrm share/doc/HTML/en/kdepim-apidocs/libkcal/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/libkcal
+@dirrm share/doc/HTML/en/kdepim-apidocs/ksync/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/ksync
+@dirrm share/doc/HTML/en/kdepim-apidocs/korganizer/korgac/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/korganizer/korgac
+@dirrm share/doc/HTML/en/kdepim-apidocs/korganizer/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/korganizer
+@dirrm share/doc/HTML/en/kdepim-apidocs/kontact/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/kontact
+@dirrm share/doc/HTML/en/kdepim-apidocs/konsolekalendar/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/konsolekalendar
+@dirrm share/doc/HTML/en/kdepim-apidocs/knotes/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/knotes
+@dirrm share/doc/HTML/en/kdepim-apidocs/kmail/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/kmail
+@dirrm share/doc/HTML/en/kdepim-apidocs/kgantt/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/kgantt
+@dirrm share/doc/HTML/en/kdepim-apidocs/kfile-plugins/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/kfile-plugins
+@dirrm share/doc/HTML/en/kdepim-apidocs/karm/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/karm
+@dirrm share/doc/HTML/en/kdepim-apidocs/kandy/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/kandy
+@dirrm share/doc/HTML/en/kdepim-apidocs/kalarmd/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/kalarmd
+@dirrm share/doc/HTML/en/kdepim-apidocs/kaddressbook/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/kaddressbook
+@dirrm share/doc/HTML/en/kdepim-apidocs/kabc/kabc2mutt/html
+@dirrm share/doc/HTML/en/kdepim-apidocs/kabc/kabc2mutt
+@dirrm share/doc/HTML/en/kdepim-apidocs/kabc
+@dirrm share/doc/HTML/en/kdepim-apidocs
+@dirrm share/doc/HTML/en/kcontrol/kalarmd
+@dirrm share/doc/HTML/en/kcontrol
+@dirrm share/doc/HTML/en/karm
+@dirrm share/doc/HTML/en/kandy
+@dirrm share/doc/HTML/en/kalarm
+@dirrm share/doc/HTML/en/kaddressbook
+@dirrm share/config.kcfg
+@dirrm share/apps/ktnef/icons/locolor/16x16/actions
+@dirrm share/apps/ktnef/icons/locolor/16x16
+@dirrm share/apps/ktnef/icons/locolor
+@dirrm share/apps/ktnef/icons/hicolor/22x22/actions
+@dirrm share/apps/ktnef/icons/hicolor/22x22
+@dirrm share/apps/ktnef/icons/hicolor
+@dirrm share/apps/ktnef/icons
+@dirrm share/apps/ktnef
+@dirrm share/apps/ksync
+@dirrm share/apps/korganizer/sounds
+@dirrm share/apps/korganizer/plugins
+@dirrm share/apps/korganizer/icons/crystalsvg/32x32/actions
+@dirrm share/apps/korganizer/icons/crystalsvg/32x32
+@dirrm share/apps/korganizer/icons/crystalsvg/22x22/actions/emptybox
+@dirrm share/apps/korganizer/icons/crystalsvg/22x22/actions
+@dirrm share/apps/korganizer/icons/crystalsvg/22x22
+@dirrm share/apps/korganizer/icons/crystalsvg/16x16/actions
+@dirrm share/apps/korganizer/icons/crystalsvg/16x16
+@dirrm share/apps/korganizer/icons/crystalsvg
+@dirrm share/apps/korganizer/icons
+@dirrm share/apps/korganizer
+@dirrm share/apps/korgac/icons/crystalsvg/22x22/actions
+@dirrm share/apps/korgac/icons/crystalsvg/22x22
+@dirrm share/apps/korgac/icons/crystalsvg
+@dirrm share/apps/korgac/icons
+@dirrm share/apps/korgac
+@dirrm share/apps/kontactsummary
+@dirrm share/apps/kontact/pics
+@dirrm share/apps/kontact
+@dirrm share/apps/knotes/icons/crystalsvg/16x16/actions
+@dirrm share/apps/knotes/icons/crystalsvg/16x16
+@dirrm share/apps/knotes/icons/crystalsvg
+@dirrm share/apps/knotes/icons
+@dirrm share/apps/knotes
+@dirrm share/apps/knode/pics
+@dirrm share/apps/knode/icons/crystalsvg/32x32/actions
+@dirrm share/apps/knode/icons/crystalsvg/32x32
+@dirrm share/apps/knode/icons/crystalsvg/22x22/actions
+@dirrm share/apps/knode/icons/crystalsvg/22x22
+@dirrm share/apps/knode/icons/crystalsvg/16x16/actions
+@dirrm share/apps/knode/icons/crystalsvg/16x16
+@dirrm share/apps/knode/icons/crystalsvg
+@dirrm share/apps/knode/icons
+@dirrm share/apps/knode/filters
+@dirrm share/apps/knode
+@dirrm share/apps/knewstuff
+@dirrm share/apps/kmailcvt/pics
+@dirrm share/apps/kmailcvt
+@dirrm share/apps/kmail/pics
+@dirrm share/apps/kmail/icons/crystalsvg/48x48/actions
+@dirrm share/apps/kmail/icons/crystalsvg/48x48
+@dirrm share/apps/kmail/icons/crystalsvg/32x32/actions
+@dirrm share/apps/kmail/icons/crystalsvg/32x32
+@dirrm share/apps/kmail/icons/crystalsvg/22x22/actions
+@dirrm share/apps/kmail/icons/crystalsvg/22x22
+@dirrm share/apps/kmail/icons/crystalsvg/16x16/actions
+@dirrm share/apps/kmail/icons/crystalsvg/16x16
+@dirrm share/apps/kmail/icons/crystalsvg
+@dirrm share/apps/kmail/icons
+@dirrm share/apps/kmail/about
+@dirrm share/apps/kmail
+@dirrm share/apps/kgpgcertmanager
+@dirrm share/apps/kgantt/icons/crystalsvg/32x32/actions
+@dirrm share/apps/kgantt/icons/crystalsvg/32x32
+@dirrm share/apps/kgantt/icons/crystalsvg/22x22/actions
+@dirrm share/apps/kgantt/icons/crystalsvg/22x22
+@dirrm share/apps/kgantt/icons/crystalsvg/16x16/actions
+@dirrm share/apps/kgantt/icons/crystalsvg/16x16
+@dirrm share/apps/kgantt/icons/crystalsvg
+@dirrm share/apps/kgantt/icons
+@dirrm share/apps/kgantt
+@dirrm share/apps/karm/pics
+@dirrm share/apps/karm
+@dirrm share/apps/kandy
+@dirrm share/apps/kalarm/icons/crystalsvg/22x22/actions
+@dirrm share/apps/kalarm/icons/crystalsvg/22x22
+@dirrm share/apps/kalarm/icons/crystalsvg/16x16/actions
+@dirrm share/apps/kalarm/icons/crystalsvg/16x16
+@dirrm share/apps/kalarm/icons/crystalsvg
+@dirrm share/apps/kalarm/icons
+@dirrm share/apps/kalarm
+@dirrm share/apps/kaddressbook/printing
+@dirrm share/apps/kaddressbook/pics
+@dirrm share/apps/kaddressbook/icons/locolor/22x22/actions
+@dirrm share/apps/kaddressbook/icons/locolor/22x22
+@dirrm share/apps/kaddressbook/icons/locolor/16x16/actions
+@dirrm share/apps/kaddressbook/icons/locolor/16x16
+@dirrm share/apps/kaddressbook/icons/locolor
+@dirrm share/apps/kaddressbook/icons/crystalsvg/32x32/actions
+@dirrm share/apps/kaddressbook/icons/crystalsvg/32x32
+@dirrm share/apps/kaddressbook/icons/crystalsvg/16x16/actions
+@dirrm share/apps/kaddressbook/icons/crystalsvg/16x16
+@dirrm share/apps/kaddressbook/icons/crystalsvg
+@dirrm share/apps/kaddressbook/icons
+@dirrm share/apps/kaddressbook/csv-templates
+@dirrm share/apps/kaddressbook
+@dirrm share/applnk/Utilities
+@dirrm share/applnk/Applications
+@dirrm share/applnk/.hidden
+@dirrm share/applnk
+@dirrm include/mimelib
+@dirrm include/libkcal
+@dirrm include/ktnef
+@dirrm include/ksieve
+@dirrm include/korganizer
+@dirrm include/kontact
+@dirrm include/knewstuff
+@dirrm include/kgantt
+@dirrm include/kdepim
+@dirrm include/kaddressbook
+@dirrm include/calendar