aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdepim
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-03-30 09:07:53 +0000
committerWill Andrews <will@FreeBSD.org>2002-03-30 09:07:53 +0000
commit97e6d164088095904ab49eafe23f9e1c67c494de (patch)
tree2a01fc85decccff8ce009661334e22692c899251 /deskutils/kdepim
parent8b392d97c6346a46347c1582408f145698da0544 (diff)
downloadports-97e6d164088095904ab49eafe23f9e1c67c494de.tar.gz
ports-97e6d164088095904ab49eafe23f9e1c67c494de.zip
Fix the KDE ports to not use objprelink, if OSVERSION >= 500029. This is
not tested other than for syntax, but should DTRT from what I understand of the problem. Submitted by: bento
Notes
Notes: svn path=/head/; revision=56912
Diffstat (limited to 'deskutils/kdepim')
-rw-r--r--deskutils/kdepim/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/deskutils/kdepim/Makefile b/deskutils/kdepim/Makefile
index 4185e7a41cd3..7d9c3d4d4f47 100644
--- a/deskutils/kdepim/Makefile
+++ b/deskutils/kdepim/Makefile
@@ -24,6 +24,11 @@ USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500029
+_NO_KDE_OBJPRELINK=yes
+.endif
+
.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
QTCPPFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
@@ -55,4 +60,4 @@ pre-configure:
find ${WRKSRC}/libical -name Makefile.in | xargs ${PERL} -pi -e \
"s|INSTALL = \@INSTALL\@|INSTALL=${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP}|g"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>