aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kdepim
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-03 08:14:43 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-03 08:14:43 +0000
commitdbba8af6447e625aae93ec45e619acbecb4ab189 (patch)
treed696a8c2d3e835a743132aa1f6a5cc0557d1c435 /deskutils/kdepim
parent683eaaa4ff765b627c52f147501abfaec4449cce (diff)
downloadports-dbba8af6447e625aae93ec45e619acbecb4ab189.tar.gz
ports-dbba8af6447e625aae93ec45e619acbecb4ab189.zip
Overhaul QT/KDE support:
- bsd.port.mk update to use bsd.kde.mk for USE_{QT,KDE}* - Cleanup corresponding ports for bsd.kde.mk update. - Fix bsd.kde.mk: use correct kdelibs dependency, put qt at the bottom, introduce QT_NONSTANDARD variable for nonstandard configure setup. - Update KDE2 to 2.1.1. Two patches included in x11/kdelibs2 to fix the proxy authentication that was broken for 2.1.1. Remove old patches. - Potentially fix kdelibs build for alpha. - Fix qt-designer 2.3.0 build. - Ruby stuff left alone since it looks like black magic to me. Should still work w/ compat shims for older USE_QT[,2] style. Some others were also left alone for the same reason. Reviewed by: portmgr, ports (bsd.kde.mk+bsd.port.mk) Submitted by: David Faure <faure@kde.org> (proxy auth patches) Alex Zepeda <garbanzo@kde.org> (old patches removal)
Notes
Notes: svn path=/head/; revision=40792
Diffstat (limited to 'deskutils/kdepim')
-rw-r--r--deskutils/kdepim/Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/deskutils/kdepim/Makefile b/deskutils/kdepim/Makefile
index 77391cdace22..b4a66e40cfcc 100644
--- a/deskutils/kdepim/Makefile
+++ b/deskutils/kdepim/Makefile
@@ -13,20 +13,11 @@ MASTER_SITE_SUBDIR= stable/${PORTVERSION}/distribution/tar/generic/src
MAINTAINER= demon@FreeBSD.org
-LIB_DEPENDS= kdecore.4:${PORTSDIR}/x11/kdelibs2
-
+USE_KDELIBS_VER=2
USE_BISON= yes
-USE_QT2= yes
-MOC?= ${X11BASE}/bin/moc2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib \
- --with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${PREFIX}/include" \
- MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lgcc -lstdc++"
USE_GMAKE= yes
.include <bsd.port.mk>