aboutsummaryrefslogtreecommitdiff
path: root/deskutils/kmail-account-wizard
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:31:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-04-10 19:31:53 +0000
commitb23d58fb6208b7ce383fc02b29883825567dd2a7 (patch)
tree7dd8d38fba0f783f52046ed64480422275947e61 /deskutils/kmail-account-wizard
parent6b76837295efce053cfb7540bd720c9665d24aca (diff)
downloadports-b23d58fb6208b7ce383fc02b29883825567dd2a7.tar.gz
ports-b23d58fb6208b7ce383fc02b29883825567dd2a7.zip
New ports: KDE Applications deskutils/
* deskutils/akonadi-calendar-tools * deskutils/akonadi-import-wizard * deskutils/akonadiconsole * deskutils/akregator * deskutils/grantlee-editor * deskutils/kaddressbook * deskutils/kalarm * deskutils/kcharselect * deskutils/kdepim-addons * deskutils/kdepim-runtime * deskutils/keditbookmarks * deskutils/kfind * deskutils/kmail * deskutils/kmail-account-wizard * deskutils/knotes * deskutils/kontact * deskutils/korganizer * deskutils/kruler * deskutils/mbox-importer * deskutils/pim-data-exporter * deskutils/pim-sieve-editor This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4. This adds a slew of KDE Pim related ports and some of their dependencies. Note, that KDE Pim has a history of working poorly on FreeBSD.
Notes
Notes: svn path=/head/; revision=467009
Diffstat (limited to 'deskutils/kmail-account-wizard')
-rw-r--r--deskutils/kmail-account-wizard/Makefile30
-rw-r--r--deskutils/kmail-account-wizard/distinfo3
-rw-r--r--deskutils/kmail-account-wizard/pkg-plist100
3 files changed, 133 insertions, 0 deletions
diff --git a/deskutils/kmail-account-wizard/Makefile b/deskutils/kmail-account-wizard/Makefile
new file mode 100644
index 000000000000..ada68bb3bbfc
--- /dev/null
+++ b/deskutils/kmail-account-wizard/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= kmail-account-wizard
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= deskutils kde kde-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE mail account wizard
+
+LIB_DEPENDS= libassuan.so:security/libassuan \
+ libgpg-error.so:security/libgpg-error \
+ libgpgme.so:security/gpgme \
+ libgpgmepp.so:security/gpgme-cpp \
+ libqgpgme.so:security/gpgme-qt5
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= attica auth codecs config configwidgets coreaddons crash \
+ dbusaddons ecm i18n itemmodels itemviews kcmutils kio kross \
+ newstuff notifications notifyconfig service texteditor wallet \
+ widgetsaddons xmlgui
+# pim components
+USE_KDE+= akonadi akonadimime identitymanagement ldap libkdepim libkleo \
+ mailtransport mime pimcommon pimtextedit
+USE_QT5= core dbus gui network script widgets xml \
+ buildtools_build qmake_build
+USE_LDCONFIG= yes
+
+DESCR= ${.CURDIR:H:H}/deskutils/kdepim/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/deskutils/kmail-account-wizard/distinfo b/deskutils/kmail-account-wizard/distinfo
new file mode 100644
index 000000000000..4d47ad33803c
--- /dev/null
+++ b/deskutils/kmail-account-wizard/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520519267
+SHA256 (KDE/applications/17.12.3/kmail-account-wizard-17.12.3.tar.xz) = bd6d196fec122e844fd4ae73dc525e869e25f1db76455e2bc2adcc614ec3bce1
+SIZE (KDE/applications/17.12.3/kmail-account-wizard-17.12.3.tar.xz) = 153456
diff --git a/deskutils/kmail-account-wizard/pkg-plist b/deskutils/kmail-account-wizard/pkg-plist
new file mode 100644
index 000000000000..b11bb6a28aca
--- /dev/null
+++ b/deskutils/kmail-account-wizard/pkg-plist
@@ -0,0 +1,100 @@
+bin/accountwizard
+bin/ispdb
+etc/xdg/accountwizard.categories
+etc/xdg/accountwizard.knsrc
+etc/xdg/accountwizard.renamecategories
+%%QT_PLUGINDIR%%/accountwizard_plugin.so
+share/akonadi/accountwizard/tine20/tine20wizard.desktop
+share/akonadi/accountwizard/tine20/tine20wizard.es
+share/akonadi/accountwizard/tine20/tine20wizard.ui
+share/applications/org.kde.accountwizard.desktop
+share/locale/ar/LC_MESSAGES/accountwizard.mo
+share/locale/ar/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/ast/LC_MESSAGES/accountwizard.mo
+share/locale/ast/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/bs/LC_MESSAGES/accountwizard.mo
+share/locale/bs/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/ca/LC_MESSAGES/accountwizard.mo
+share/locale/ca/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/ca@valencia/LC_MESSAGES/accountwizard.mo
+share/locale/ca@valencia/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/cs/LC_MESSAGES/accountwizard.mo
+share/locale/cs/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/da/LC_MESSAGES/accountwizard.mo
+share/locale/da/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/de/LC_MESSAGES/accountwizard.mo
+share/locale/de/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/el/LC_MESSAGES/accountwizard.mo
+share/locale/el/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/en_GB/LC_MESSAGES/accountwizard.mo
+share/locale/en_GB/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/eo/LC_MESSAGES/accountwizard.mo
+share/locale/es/LC_MESSAGES/accountwizard.mo
+share/locale/es/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/et/LC_MESSAGES/accountwizard.mo
+share/locale/et/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/fi/LC_MESSAGES/accountwizard.mo
+share/locale/fi/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/fr/LC_MESSAGES/accountwizard.mo
+share/locale/fr/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/ga/LC_MESSAGES/accountwizard.mo
+share/locale/ga/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/gl/LC_MESSAGES/accountwizard.mo
+share/locale/gl/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/he/LC_MESSAGES/accountwizard.mo
+share/locale/hu/LC_MESSAGES/accountwizard.mo
+share/locale/hu/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/ia/LC_MESSAGES/accountwizard.mo
+share/locale/ia/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/it/LC_MESSAGES/accountwizard.mo
+share/locale/it/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/ja/LC_MESSAGES/accountwizard.mo
+share/locale/ja/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/kk/LC_MESSAGES/accountwizard.mo
+share/locale/kk/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/km/LC_MESSAGES/accountwizard.mo
+share/locale/km/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/ko/LC_MESSAGES/accountwizard.mo
+share/locale/ko/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/lt/LC_MESSAGES/accountwizard.mo
+share/locale/lt/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/lv/LC_MESSAGES/accountwizard.mo
+share/locale/mr/LC_MESSAGES/accountwizard.mo
+share/locale/mr/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/nb/LC_MESSAGES/accountwizard.mo
+share/locale/nb/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/nds/LC_MESSAGES/accountwizard.mo
+share/locale/nds/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/nl/LC_MESSAGES/accountwizard.mo
+share/locale/nl/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/nn/LC_MESSAGES/accountwizard.mo
+share/locale/pa/LC_MESSAGES/accountwizard.mo
+share/locale/pl/LC_MESSAGES/accountwizard.mo
+share/locale/pl/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/pt/LC_MESSAGES/accountwizard.mo
+share/locale/pt/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/pt_BR/LC_MESSAGES/accountwizard.mo
+share/locale/pt_BR/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/ro/LC_MESSAGES/accountwizard.mo
+share/locale/ro/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/ru/LC_MESSAGES/accountwizard.mo
+share/locale/ru/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/sk/LC_MESSAGES/accountwizard.mo
+share/locale/sk/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/sl/LC_MESSAGES/accountwizard.mo
+share/locale/sl/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/sr/LC_MESSAGES/accountwizard.mo
+share/locale/sr/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/sv/LC_MESSAGES/accountwizard.mo
+share/locale/sv/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/tr/LC_MESSAGES/accountwizard.mo
+share/locale/tr/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/ug/LC_MESSAGES/accountwizard.mo
+share/locale/ug/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/uk/LC_MESSAGES/accountwizard.mo
+share/locale/uk/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/zh_CN/LC_MESSAGES/accountwizard.mo
+share/locale/zh_CN/LC_MESSAGES/accountwizard_tine20.mo
+share/locale/zh_TW/LC_MESSAGES/accountwizard.mo
+share/locale/zh_TW/LC_MESSAGES/accountwizard_tine20.mo
+share/mime/packages/accountwizard-mime.xml